HDMI "No Signal" after update


After the latest update, having an Nvidia GPU, I had my share of troubles (system crash), which were all solved thanks to the quick reaction of this community. See threads: system failure, driver failure - both solved.

Now, I cannot cast anything via HDMI. I’m using a projector and all I get is the blue “NO SIGNAL” notice. In the past (previous Kernel versions), I had sound issues, but I always managed to find some existing solution on the forums. I only found this that could be relevant for my current issue, but that didn’t help.

Any ideas on where to look and what to do?

I believe the problem is probably the same as here.

1 Like

I see. I don’t want to downgrade now that I have managed to get it running. Especially since I need the machine every day for work and don’t want to lose time on messing with system critical measures.

Is the “fourth” option to sit and wait until this is patched? And do You know whether this is a recognised issue, thus making waiting a viable solution?

You don’t need to downgrade anything, just install the 5.9 kernel and start that in your bootloader. If you don’t use snap, I consider 5.4 a better choice.

As you can see in my other comment, the NVIDIA 460xx driver already fixes the problem, but since that’s labelled as “beta”, I cannot really recommend it, especially for a machine that you use for work and downtime is not desirable.

1 Like

I understand. Sorry, I’m still quite new to some of the concepts. Thank You for the explanation.

Also confirming that booting from 5.4 Kernel works.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.