Has the Mate DE been removed from the site?

Hey!

I dont see the Mate option anymore - I thought I saw it when I last gave Manjaro a spin. If so when did it go?

Yes. Unmaintained community editions have been dropped.

1 Like

Is there a reason they’re all suddenly unmaintained? Wayland?

If not, then where would I find the profile for mate? I can’t find it in the commit that removed unmaintained profiles (unless it’s bspwm-mate).

It’s not “suddenly”; they’ve been unmaintained for a while already, due to the people behind them having lost interest or no longer having the time.

Eventually, due to the evolution of the packages that make up the main distribution, the unmaintained community editions then end up broken, and at that point, there’s no point in advertising them anymore or offering them for download. :man_shrugging:

Not all is lost, though. There are still three maintained community editions…: :point_down:

  • Cinnamon
  • i3
  • Sway

Also, nothing says that the currently discontinued community editions would not return at some point in the future. They are after all community editions, and we would welcome it if someone from within the now already quite large community were to step up and start maintaining one or several of the discontinued community editions again.

5 Likes

I get that, but I hadn’t heard of it, my fault I assume, so I was asking if there’s a reason the DEs wouldn’t work any more, perhaps due to package changes.

Otherwise I’d like to get the latest profile for mate, so I can have a go at building my own iso.

Because:

I’m gutted, this is my choice now (when I want to re-install):

  1. Gnome - :face_vomiting: (sorry gnome users)
  2. KDE - Really want to like it, but don’t (it’s just about ok for a laptop I barely use, way too annoying for main pc). Non-traditional, they like to get carried away and forget to make things work properly, then refuse to fix them (eg icons only task manager).
  3. XFCE - Traditional which is a plus. Don’t like it.
  4. i3 - Don’t want tiling
  5. Sway - no idea what it’s like, don’t really wanna know
  6. Install one, then replace DE.
  7. Build my own iso.
  8. Move distro.

EDIT:

Not sure I’m quite up for being relied upon, but I’d give it a go. If I could find the profile that is…all I can find so far is awesome and bspwm-mate. It seems the others must’ve been removed earlier.

EDIT:

Nothing obvious comes up for mate or drop search terms, except for this, the latest commit I can find that contains the profile, from 2 years ago. If anyone knows of a newer one let me know.

I’ll hopefully have a go in the next few days.

2 Likes

It’s a tiling window manager, like i3, but intended for use on Wayland.

1 Like

As part of Manjaro’s ongoing development - a major cleanup is going on

  • unmaintained profiles has been dropped from the master branch
  • related unmaintained packages are being dropped from the repo as well

And before you ask

  • I am not package maintainer
  • I am not edition maintainer
  • I am not involved in the process
  • I solely use Plasma on Arch and Manjaro Edge

I am developer, writing code to make useful applications

Amongst those applications are Manjaro infrastructure applications

  • pacman-mirrors
  • bxtctl
3 Likes

I have a minimal iso built, and it loads up, but I haven’t tried installing from it yet. No spare partitions on this laptop, but there should be a spare partition on my desktop so I may be able to test it later.

If anyone’s interested I’ll build a full .iso too.

Not sure where to host them though…any ideas? :man_shrugging:

2 Likes

I’ll leave that up to one of the team members to answer. I imagine that it should be possible to host them together with the other community editions. :thinking:

1 Like

The point is there hasn’t been anything close to an updated profile in years. In the meantime, there have been a lot of upstream changes which include Robert Tari’s Ayatana Indicators. Robert maintains the related packages in the AUR.

There are some MATE packages in the Arch repos we inherit; i.e., the mate and mate-extra package groups. However, there technically hasn’t been an Arch maintainer for quite some time now. The packages were orphaned for a long time, then someone picked them up just to update them. There are also other MATE packages in the AUR that we previously had imported to the Manjaro repos that Arch never did.

Long story short, anyone using MATE on Arch has always had to install AUR packages in order to have a complete experience.

This guy was creating custom Manjaro MATE spins, maybe check with him along with @Jim.B’s SbK Spins

1 Like

Installed the old community edition of mate minimal (still using the pkgs from the official repo) over 6 years ago, Helped me to jump from Mint to Manjaro. Never had an issue, love it.

Is there even a need for a full iso that takes much time and commitment to maintain? I guess most ppl pick mate for the minimal ram/graphics requirements and the amazingly quick boot (2009 MBP 14s to desktop), so just an updated minimal iso would be great.

1 Like

I did assume arch maintained the packages properly, or at least enough. I figured it would mostly be maintaining the profile, building the images, and some testing. Perhaps I was naive.

I’d forgotten about FreaxMATE, and I have seen SbK’s spins. So far I’ve preferred to stick with the version Manjaro hosted. I must admit I’ve stopped keeping track of changes to MATE, and I didn’t do it much to start with. You’ve certainly given me a few things to think about, and of course to look into.

Having said that, I’ve been happy with what was provided, I’ve never installed anything MATE from the AUR. As you say, it does seem like I’ve not had a few things, but I never missed them.

As for Arch not maintaining the packages, do you think that means MATE on Arch based distros is in jeopardy altogether, or will they maintain them just enough to keep it going?

I doubt I could maintain them all even if someone let me, unless I had some (perhaps a lot of) experienced help. I can handle packaging relatively simple stuff, at least for myself, but I’m not sure I’m good enough to handle it on this level, or if I have enough time and energy for so many packages.

I should be able to maintain the profile and build the images, etc, as long as the necessary packages are there. Just not sure what problems may arise. I could look into adding new stuff in time.

@6x12

It’s my favourite DE. Simple, traditional, and they’re not obsessed with trying to redesign everything.

I also think that just a minimal would be fine, but I think there are some useful packages in the full iso. We could perhaps merge the most useful.

I only had to remove 5 packages that are no longer in the repos, there may be a few more for the full iso (I’ll have a look hopefully sometime today). I still haven’t tested the iso properly, but it seems to work.

In case it’s useful, here are the packages I removed:

vino
opencl-mesa
xf86-video-openchrome
manjaro-firmware
systemd-fsck-silent


@ everyone who helped maintain the MATE iso over the years

Thank you. :heart:


EDIT:

I also needed to remove these for the full version, haven’t tested the result at all yet.

extra manjaro-documentation-en
extra steam-manjaro

I’ve seen a couple of error messages from mkinitcpio (happens with minimal and full).

==> ERROR: invalid symlink: '/usr/lib/libnss_files.so.2'
==> ERROR: invalid symlink: '/usr/lib/libnss_dns.so.2'

I found this, where @philm says to use manjaro-tools-git, but it’s unclear if it has anything to do with the error messages as they seem to have nothing to do with the actual problem. Anyway I’m using manjaro-tools-iso-git from the repo.

So far I haven’t seen any problems, but I just booted the minimal iso and shutdown again. It probably won’t be today, but I’ll test it a bit more sometime soon.

ignore them

2 Likes

Thanks. I thought I should, just wanted to check.

1 Like

I made several ISOs with different graphic environments and each time it appeared but the generated ISOs worked well all the time

2 Likes

I think here’s the fix, way over my head though.

1 Like

Ok good,
so for manjaro you need to make the modification given in the link to the file which comes from the Manjaro-tools-iso-git package:

/etc/initcpio/install/miso_pxe_common

once edit the file looks like this

#!/bin/bash

build() {
    add_checked_modules -f "(irda|phy|wimax|wireless|ppp_|plip|pppoe)" "/drivers/net/"

    add_runscript

    add_binary /usr/lib/initcpio/ipconfig /bin/ipconfig

    # Add hosts support files+dns
#    add_symlink /usr/lib/libnss_files.so.2 $(readlink /usr/lib/libnss_files.so.2)
#    add_binary $(readlink -f /usr/lib/libnss_files.so.2)
#    add_symlink /usr/lib/libnss_dns.so.2 $(readlink /usr/lib/libnss_dns.so.2)
#    add_binary $(readlink -f /usr/lib/libnss_dns.so.2)
    add_binary /usr/lib/libnss_files.so.2
    add_binary /usr/lib/libnss_dns.so.2

    add_dir /etc
    echo "hosts: files dns" > $BUILDROOT/etc/nsswitch.conf
}

help() {
cat<<HELPEOF
  This hook loads the necessary modules for boot via PXE.
HELPEOF
}

# vim: set ft=sh ts=4 sw=4 et:

We can perhaps do something cleaner but now it no longer marks the errors
sorry for my bad english i use an automatic translator

EDIT:
PS: On the other hand, if an Administrator goes through here, would it be possible to cut the post into another post from the “Edit: from dmt” please

1 Like

Good that it worked but please read the linked post again. You applied the ‘crude workaround’ of ‘remove the add_symlink entries’, however, the real fix is ‘updating the docker toolchain’:

@fdupoux check if building an iso works with an up-to-date docker toolchain? For me it now works.

@gvegidy Yes it did work. I was able to rebuild all docker images, custom packages, and ISO image without any issue.

But then the issue seems still present:
@francoisvalenduc I tried the latest version of the git tree and it still fails.
Exept it isn’t:
@francoisvalenduc Sorry, it works correctly if I first delete the 2 docker images.

Is not used docker toolchain with Manjaro-tools, at least I don’t think so.
This solution cannot be used.

Ok. As I said, I don’t really know what I’m talking about here, sorry. (reading up on docker right now)