Hardware decoding not working with Alder Lake UHD 770

I run an i5 12600K and have issues with the integrated UHD 770 that I currently run.
I have enabled hw encoding both in VLC and in Firefox. I can see in intel_gpu_top that it uses
the hw to decode video, but I only get green screens in firefox and flickering picture in vlc.
Something is very broken…
I am running the latest version of Manjaro and use kernel 5.16.7-1.

Any ideas? Is the drivers still not fully developed or are there any other issues?
My last computer, an i7 10700k with UHD 630 worked perfectly.,.

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    [HowTo] Provide System Information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.


1 Like