Hard Drive high temperature

Hello guys just installed new HDD to my laptop and while moving files from SSD HDD temparature was too high above 70 Celsius I used kde widget to check it but maybe it’s not right but laptop was really hot.
Is there any tool to see exact temperatures of both SSD and HDD and other hardware(such as GPU, CPU) as well

If it’s disk-related you can use hddtemp. (official repositories)
Question is : what causes the heat?

If it’s your GPU or CPU you can use sensors. Also in the official repositories.

1 Like

Yes exactly I was moving about 200 GB files to that HDD that could be reason of the heat?
I tried hddtemp and it shows 30 C now

The only way you can check the temp, is again moving some files and in the same time check your temp. 30 C is hot in the sun, but not for your drive :wink:

1 Like

I use conky for that - install HDDTEMP and enable the service, then make a conky for it:

hddtemp conky

${color}SSD ${goto 25} ${hddtemp /dev/sdc}ºC${color gray40}${if_match ${fs_used_perc}>=75}${color lightsalmon}${endif}${if_match ${fs_used_perc}>=85}${color red}${endif}${alignr }${fs_bar 6,140}${font }

Disturbing though - is this only in Manjaro?

It depends on the hardware. 100°C is too hot for all hardware, but 70°C might be OK for your HD, so we cannnot tell you unless you provide more information, so read this:


and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…

An inxi --full --admin --verbosity=7 --filter --no-host would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)

:innocent:

P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which CPU/GPU you have, …

There are multiple! psensor is the easiest:

pamac install sensors
pamac install psensor
sudo sensors-detect
psensor &

and looks like this:

The most versatile (and difficult) is Conky:

pamac install conky-cairo

but you need to create a config file for your hardware like this:

conky.config =
{
  console_bar_fill   = '»',
  console_bar_unfill = ' ',

  alignment = 'top_left',
  background = false,
  border_width = 2,
  cpu_avg_samples = 2,
  -- define Manjaro colours:
  default_color = '#1abc9c',  -- Same HTML as current terminal
  color1 = '#709080',         -- Kakhi
  color2 = '#dca3a3',         -- Salmon
  color3 = '#72d5a3',         -- Light Green
  color4 = '#f0dfaf',         -- Yellow
  color5 = '#7eb2e6',         -- Metal blue
  color6 = '#a45ec1',         -- Light aubergine
  font   = 'Envy Code R:bold:size=8',
  default_outline_color = '#1abc9c',  -- Same HTML as current terminal
  default_shade_color = '#1abc9c',  -- Same HTML as current terminal
  double_buffer = true,
  draw_borders = false,
  draw_graph_borders = true,
  draw_outline = false,
  draw_shades = false,
  extra_newline = false,
  format_human_readable=true,
  gap_x = 25,
  gap_y = 25,
  minimum_height = 200,
  minimum_width = 200,
  net_avg_samples = 2,
  no_buffers = true,
  out_to_console = false,
  out_to_ncurses = false,
  out_to_stderr = false,
  out_to_x = true,
  own_window = true,
  own_window_class = 'Conky',
  own_window_type = 'normal',
  own_window_transparent = false,
  -- set transparency:
  own_window_argb_visual = true, own_window_argb_value = 100,
  show_graph_range = false,
  show_graph_scale = false,
  stippled_borders = 0,
  update_interval = 2.0,
  uppercase = false,
  use_spacer = 'none',
  use_xft = true,
  lua_load = '~/.config/conky/MyFunctions.lua',
  lua_draw_hook_post = "main",
}

conky.text = [[
${color}Info:${color1} ${scroll 32 $nodename $kernel}
${color}$hr
${color}Uptime    :${color1} $uptime
${color}Frequency :${color1} $freq ${color}MHz
#${color}RAM Usage :${color1} ${lua conky_RoundUp ${mem} }/${lua conky_RoundUp ${memmax} } ${membar 4}
${color}RAM Usage :${color1} ${mem}/${memmax} ${membar 4}
#${color}Swap Usage:${color1} ${lua conky_RoundUp ${swap} }/${lua conky_RoundUp ${swapmax} } ${swapbar 4}
${color}Swap Usage:${color1} ${swap}/${swapmax} ${swapbar 4}
${color}CPU Usage :${color1} $cpu% ${cpubar 4}
${color}Processes :${color1} $processes  ${color}Load:${color1} $loadavg
${color}Name                 CPU%   MEM%   PID
${color1} ${top name 1} ${color2} ${top cpu 1} ${top mem 1} ${top pid 1}
${color1} ${top name 2} ${color2} ${top cpu 2} ${top mem 2} ${top pid 2}
${color1} ${top name 3} ${color2} ${top cpu 3} ${top mem 3} ${top pid 3}
${color1} ${top name 4} ${color2} ${top cpu 4} ${top mem 4} ${top pid 4}
${color}$hr
${color}File systems:
${color} /           ${color1}${fs_used /}/${fs_size /} ${fs_bar 6 /}
${color} /home       ${color1}${fs_used /home}/${fs_size /home} ${fs_bar 6 /home}
${color} /media/Data ${color1}${fs_used /media/Data}/${fs_size /media/Data} ${fs_bar 6 /media/Data}\
# Don't show NAS if not mounted
${if_existing /media/NAS/home/}
${color} /media/NAS  ${color1}${fs_used /media/NAS}/${fs_size /media/NAS} ${fs_bar 6 /media/NAS}
${endif}${color}$hr
# Networking section will not show anything if no NICS are up
# Will show speed and graph per NIC if they are up
${if_existing /sys/class/net/enp3s0/operstate up}${color}Ethernet
${color}Down: ${color1}${downspeed enp3s0}s ${alignr}${color}Up: ${color1}${upspeed enp3s0}/s
${downspeedgraph enp3s0 50,200 dca3a3 ffffff -l -t} ${alignr}${color1}${upspeedgraph enp3s0 50,200 dca3a3 ffffff -l -t}
${color}Total: ${color1}${totaldown enp3s0} ${alignr}${color}Total: ${color1}${totalup enp3s0}
${endif}${if_existing /sys/class/net/wlp2s0/operstate up}${color}WiFi
${color}Down: ${color1}${downspeed wlp2s0}/s ${alignr}${color}${color}Up: ${color1}${upspeed wlp2s0}/s
${downspeedgraph wlp2s0 50,200 dddddd ffffff -l -t} ${alignr}${color1}${upspeedgraph wlp2s0 50,200 dddddd ffffff -l -t}
${color}Total: ${color1}${totaldown wlp2s0} ${alignr}${color}Total: ${color1}${totalup wlp2s0}${endif}
${color}$hr
${color}Temperature:
${color} ISA     ${color1}${exec sensors | awk ' /Package/ {print $4}'}${alignr}${alignr}${color}CPU     ${color1}${exec sensors      | grep 'Core 0'                   | awk '{print $3}'}
${color} ACPI    ${color1}${exec sensors | grep --after-context=2 'acpitz' | awk 'FNR ==3 {print $2}'}${alignr}${color}WiFi    ${color1}${exec exec sensors | grep --after-context=2 'ath10k' | awk 'FNR ==3 {print $2}'}
${color} GPU     ${color1}+${exec nvidia-settings --query=gpucoretemp 2>/dev/null | grep 'GPUCoreTemp' | grep "\[gpu:0\]" | awk '{print $4}'}0°C
${color} SSD     ${color1}+${hddtemp /dev/sda}.0°C${alignr}${color}HDD     ${color1}+${hddtemp /dev/sda}.0°C
${color2}${execgraph "sensors | grep 'Core 0' | awk '{print $3}' | cut -b2,3"}
]]

and then it looks like this:

(The above is specific to my system, but there are even more elaborate ones like here, or here, or even this one)

4 Likes

Thank you guys for your responses really appreciate your help <3
So there is an information due to the command
inxi --full --admin --verbosity=7 --filter --no-hos
also updated my profile with some information

system: Kernel: 5.7.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 parameters: BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64 root=UUID=f3ea9f0a-64af-4f49-900f-ed76bf207bf4 rw quiet apparmor=1 security=apparmor udev.log_priority=3 Desktop: KDE Plasma 5.19.4 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux Machine: Type: Laptop System: HP product: HP ProBook 450 G6 v: N/A serial: <filter> Chassis: type: 10 serial: <filter> Mobo: HP model: 8538 v: KBC Version 51.27.00 serial: <filter> UEFI: HP v: R71 Ver. 01.10.00 date: 01/03/2020 Battery: ID-1: BAT0 charge: 19.5 Wh condition: 42.4/42.4 Wh (100%) volts: 11.0/11.6 model: Hewlett-Packard Primary type: Li-ion serial: <filter> status: Discharging Memory: RAM: total: 7.65 GiB used: 3.96 GiB (51.8%) RAM Report: permissions: Unable to run dmidecode. Root privileges required. CPU: Topology: Quad Core model: Intel Core i5-8265U bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 8E (142) stepping: C (12) microcode: D6 L2 cache: 6144 KiB bogomips: 28808 Speed: 793 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 793 2: 797 3: 794 4: 797 5: 793 6: 788 7: 798 8: 793 Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ibrs_enhanced ida intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages Type: l1tf status: Not affected Type: mds status: Not affected Type: meltdown status: Not affected Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling Type: srbds mitigation: TSX disabled Type: tsx_async_abort status: Not affected Graphics: Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3ea0 Device-2: Chicony HP HD Camera type: USB driver: uvcvideo bus ID: 1-2:2 chip ID: 04f2:b669 serial: <filter> Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: intel unloaded: modesetting alternate: fbdev,vesa display ID: :0 screens: 1 Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") diag: 389mm (15.3") OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 20.1.5 direct render: Yes Audio: Device-1: Intel Cannon Point-LP High Definition Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:9dc8 Sound Server: ALSA v: k5.7.15-1-MANJARO Network: Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi v: kernel port: 4000 bus ID: 00:14.3 chip ID: 8086:9df0 IF: wlp0s20f3 state: up mac: <filter> IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> IP v6: <filter> type: noprefixroute scope: link Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus ID: 01:00.0 chip ID: 10ec:8168 IF: enp1s0 state: down mac: <filter> IF-ID-1: docker0 state: down mac: <filter> IP v4: <filter> scope: global broadcast: <filter> WAN IP: <filter> Drives: Local Storage: total: 704.24 GiB used: 276.82 GiB (39.3%) SMART Message: Unable to run smartctl. Root privileges required. ID-1: /dev/nvme0n1 vendor: SK Hynix model: BC501 HFM256GDJTNG-8310A size: 238.47 GiB block size: physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 serial: <filter> rev: 80002C00 scheme: GPT ID-2: /dev/sda vendor: Hitachi model: HTS545050A7E380 size: 465.76 GiB block size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s rotation: 5400 rpm serial: <filter> rev: A6C0 scheme: GPT Message: No Optical or Floppy data was found. RAID: Message: No RAID data was found. Partition: ID-1: / raw size: 238.17 GiB size: 233.43 GiB (98.01%) used: 34.46 GiB (14.8%) fs: ext4 dev: /dev/nvme0n1p2 label: N/A uuid: f3ea9f0a-64af-4f49-900f-ed76bf207bf4 ID-2: /boot/efi raw size: 300.0 MiB size: 299.4 MiB (99.80%) used: 280 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 label: N/A uuid: 7CA5-EBA1 ID-3: /home/<filter>/HDD raw size: 465.76 GiB size: 457.45 GiB (98.22%) used: 242.36 GiB (53.0%) fs: ext4 dev: /dev/sda1 label: HDD uuid: 635ed0e1-a4bb-45b3-9f05-017afc78542f Swap: Alert: No Swap data was found. Unmounted: Message: No unmounted partitions found. USB: Hub: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 Device-1: 1-2:2 info: Chicony HP HD Camera type: Video driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 04f2:b669 serial: <filter> Device-2: 1-4:5 info: Sunplus Innovation Optical Mouse type: Mouse driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s chip ID: 1bcf:0005 Device-3: 1-7:3 info: Synaptics type: <vendor specific> driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s chip ID: 06cb:00b7 serial: <filter> Device-4: 1-10:4 info: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s chip ID: 8087:0aaa Hub: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.1 speed: 10 Gb/s chip ID: 1d6b:0003 Sensors: System Temperatures: cpu: 40.0 C mobo: 0.0 C Fan Speeds (RPM): N/A Info: Processes: 313 Uptime: 2h 34m Init: systemd v: 245 Compilers: gcc: 10.1.0 Packages: 1339 pacman: 1321 lib: 357 flatpak: 10 snap: 8 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.05

I also installed Psensor and here are the results

As you can see HDD is ok and turns out that m2 nvme ssd by sk hynix and cpu intel core i5 8265u get pretty hot. I don’t even play games just use browsers, vs code, xtreme download manager and stuff like that nothing that should cause heat or heavy usage of each hardware. I am a little bit worried about temperatures as it’s shown usually go above 70-80 celsius sometimes even 90+

Because:

I’m advising yo to:

  • Get a can of compressed air and blow it in all holes: look likes dust is accumulating. (10€ solution)
    OR
  • Open it up according to the HP ProBook 450 service manual [PDF], put your vacuum cleaner on its lowest setting and gently vacuum all components. (0€ solution)
    OR
  • Bring it in for service… (100€ solution)

:stuck_out_tongue_winking_eye: :crazy_face:


I’ve marked the below answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (I just want to avoid even more subjective opinions being posted and confusing you even more)

:innocent:
P.S. In the future, please mark a solution like this:
Solution
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

1 Like

Thank you a lot

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.