Grub rescue says: 'grub_debug_malloc' not found

Hey I guess I have a bigger problem than it seems. I tried to remove grub completely and reinstall it. I did the following:

  1. booted into manjaro by pressing F11 on my keyboard (circumventig the grub rescue screen) and booted into my manjaro instllation.
  2. pacman -Rns grub grub-btrfs grub-manjaro-theme
  3. rebooted
  4. now the F11 trick didnt work anymore since i removed grub completely and after chosing my manjaro installation it simply wouldnt boot up
  5. created a bootable manjaro usb
  6. booted the live OS
  7. manjaro-chroot
  8. mount /dev/sda1 /mnt
  9. mount /dev sda2 /boot/efi
  10. pacman -S grub
  11. rm -r /boot/grub
  12. mkdir /boot/grub
  13. grub-mkconfig -o /boot/grub/grub.cfg
  14. grub-install /dev/sda
    (everything worked without an error)
  15. rebooted
  16. still grub rescue…
    but now I’m at last able to ‘circumvent’ that and boot into manjaro by pressing F11 and choosing my boot device.

How can I solve this issue? I completely reinstalled grub why is the problem still persisting?

How did the problem occur:
I created a new admin user on manjaro, did pacman -Syu there (it did something with grub during the update for whatever reason) logged out, logged back into my main user deleted the second user I created 5 mins ago and used timeshift to restore to a previous point. After that the problem started ocurring.

How do I completely reinstall grub? Apparently I didn’t remove it completely?

use manjaro wiki

Hey thx for your fast reply. I have an EFI System so I did that (according to the wiki/ your link):

  1. grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
  2. grub-mkconfig -o /boot/grub/grub.cfg

Still the same issue…

and this:

That kinda does the trick. Now manjaro obviously boots but I don’t have the grub bootloader so I basically cannot chose Windows 10 for example or other operating systems.

and output from:
cat /etc/fstab
sudo blkid

and this:

cat /etc/fstab

UUID=C11B-C97D /boot/efi vfat umask=0077 0 2
UUID=b57601e1-fc85-4cd6-bd6e-944baa5d7172 / ext4 defaults,noatime 0 1
/swapfile swap swap defaults,noatime 0 0
tmpfs /tmp tmpfs defaults,noatime,mode=1777 0 0

blkid

/dev/nvme0n1p1: LABEL_FATBOOT=“NO_LABEL” LABEL=“NO_LABEL” UUID=“C11B-C97D” BLOCK_SIZE=“512” TYPE=“vfat” PARTUUID=“d1cd970f-dc28-d74a-a271-8d12e18e8041”
/dev/nvme0n1p2: UUID=“b57601e1-fc85-4cd6-bd6e-944baa5d7172” BLOCK_SIZE=“4096” TYPE=“ext4” PARTLABEL=“root” PARTUUID=“640def64-9110-174f-bf87-8f76cdfeef23”
/dev/nvme1n1p4: BLOCK_SIZE=“512” UUID=“EAF09988F0995C1F” TYPE=“ntfs” PARTUUID=“4d62dad4-cdd3-4256-a564-122eac3b328f”
/dev/nvme1n1p2: PARTLABEL=“Microsoft reserved partition” PARTUUID=“30931df2-e4fd-4981-8d20-f6e9f62037dd”
/dev/nvme1n1p3: BLOCK_SIZE=“512” UUID=“A8D8DF0BD8DED722” TYPE=“ntfs” PARTLABEL=“Basic data partition” PARTUUID=“5047b707-2a37-4707-a411-f2388f3558ee”
/dev/nvme1n1p1: UUID=“32DC-2D7F” BLOCK_SIZE=“512” TYPE=“vfat” PARTLABEL=“EFI system partition” PARTUUID=“777efcfd-3e4b-426c-80e1-cbf20de70c68”

and output from:
lsblk -f

lsblk -f

NAME FSTYPE FSVER LABEL UUID FSAVAIL FSUSE% MOUNTPOINTS
nvme1n1
├─nvme1n1p1 vfat FAT32 32DC-2D7F
├─nvme1n1p2
├─nvme1n1p3 ntfs A8D8DF0BD8DED722
└─nvme1n1p4 ntfs EAF09988F0995C1F
nvme0n1
├─nvme0n1p1 vfat FAT32 NO_LABEL C11B-C97D 299,1M 0% /boot/efi
└─nvme0n1p2 ext4 1.0 b57601e1-fc85-4cd6-bd6e-944baa5d7172 352,2G 18% /

use formatting, click this icon in editor: </> and put the output there

NAME        FSTYPE FSVER LABEL    UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
nvme1n1                                                                               
├─nvme1n1p1 vfat   FAT32          32DC-2D7F                                           
├─nvme1n1p2                                                                           
├─nvme1n1p3 ntfs                  A8D8DF0BD8DED722                                    
└─nvme1n1p4 ntfs                  EAF09988F0995C1F                                    
nvme0n1                                                                               
├─nvme0n1p1 vfat   FAT32 NO_LABEL C11B-C97D                             299,1M     0% /boot/efi
└─nvme0n1p2 ext4   1.0            b57601e1-fc85-4cd6-bd6e-944baa5d7172  352,2G    18% /

blkid:

/dev/nvme0n1p1: LABEL_FATBOOT="NO_LABEL" LABEL="NO_LABEL" UUID="C11B-C97D" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="d1cd970f-dc28-d74a-a271-8d12e18e8041"
/dev/nvme0n1p2: UUID="b57601e1-fc85-4cd6-bd6e-944baa5d7172" BLOCK_SIZE="4096" TYPE="ext4" PARTLABEL="root" PARTUUID="640def64-9110-174f-bf87-8f76cdfeef23"
/dev/nvme1n1p4: BLOCK_SIZE="512" UUID="EAF09988F0995C1F" TYPE="ntfs" PARTUUID="4d62dad4-cdd3-4256-a564-122eac3b328f"
/dev/nvme1n1p2: PARTLABEL="Microsoft reserved partition" PARTUUID="30931df2-e4fd-4981-8d20-f6e9f62037dd"
/dev/nvme1n1p3: BLOCK_SIZE="512" UUID="A8D8DF0BD8DED722" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="5047b707-2a37-4707-a411-f2388f3558ee"
/dev/nvme1n1p1: UUID="32DC-2D7F" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="777efcfd-3e4b-426c-80e1-cbf20de70c68"

cat /etc/fstab:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=C11B-C97D                            /boot/efi      vfat    umask=0077 0 2
UUID=b57601e1-fc85-4cd6-bd6e-944baa5d7172 /              ext4    defaults,noatime 0 1
/swapfile                                 swap           swap    defaults,noatime 0 0
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

here is a link from arch on how to fix it, you need to mount EFI partition to /boot/EFI before installing Grub, then run again:

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck`
grub-mkconfig -o /boot/grub/grub.cfg

But isn’t the EFI partition already mounted according to my output of lsblk -f? it says its mounted at /boot/efi

you need to be chrooted… are you still in chroot?

I’m booted into the OS

Enable the os-prober at /etc/default/grub and run update-grub

I directly booted by rearranging boot orders as you suggested earlier

in the arch link are instructions on how to do it, chroot, mount the efi, reinstall… but first try what megavolt suggest and see if that helped

Did that but I also get /usr/bin/grub-probe: warning: unknown device type nvme0n1. in the very end. Is that an issue?