GRUB "normal.mod not found"

Hello, I have been having some issues booting to my manjaro install after changing my motherboard. For context, I have a windows dual boot alongside manjaro, I used to be able to select which OS I wanted to boot to using the grub menu. Now, after changing the mobo, I get an error from grub saying “/boot/grub/i386-pc/normal.mod not found” as soon as I try to boot. I tried to restore the bootloader following the manjaro wiki instructions but had no luck so far. One thing I noticed is that, when booting to a live usb, if I select the “detect EFI bootloaders” option I can actually boot to manjaro without problems.
I’m not too savvy about this bootloader stuff, so I’m really at a loss here. Any help would be greatly appreciated.

go under motherboard UEFI
make a save profile for windows
create one for linux with

Secureboot disabled
no fastboot
no csm
all disks on AHCI
no legacy
no optane/rst

boot on USB live manjaro iso
go in chroot and
redo grub-install UEFI ( do not select UEFI > your disk , boot only on USB live iso )


Hi stephane, your solution worked like a charm. Thanks a lot!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.