GRUB menu too slow

GRUB menu is incredibly slow on a notebook with NVIDIA optimus and a high res display (2560x1440).

I’ll consider reducing the logical resolution of the boot menu it this is a possible solution.

Here’s the output of cat /etc/default/grub | grep GFX:


Here’s the output of cat /etc/default/grub:


GRUB_CMDLINE_LINUX_DEFAULT="apparmor=1 security=apparmor udev.log_priority=3"


GRUB_PRELOAD_MODULES="part_gpt part_msdos"








Here’s the output of inxi --Fxzc0:

System:    Kernel: 5.13.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: KDE Plasma 5.23.3 Distro: Manjaro Linux
           base: Arch Linux
Machine:   Type: Laptop System: Avell High Performance product: C65 MOB v: Standard serial: <superuser required>
           Mobo: Avell High Performance model: Avell C65 MOB v: Standard serial: <superuser required>
           UEFI: American Megatrends LLC. v: N.1.07AVE00 date: 07/23/2021
Battery:   ID-1: BAT0 charge: 91.6 Wh (100.0%) condition: 91.6/91.6 Wh (100.0%) volts: 13.1 min: 11.6 model: standard
           status: Full
CPU:       Info: 8-Core model: 11th Gen Intel Core i7-11800H bits: 64 type: MT MCP arch: Tiger Lake rev: 1 cache: L2: 10 MiB
           flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 73744
           Speed: 1130 MHz min/max: 800/4600 MHz Core speeds (MHz): 1: 1130 2: 1795 3: 4047 4: 3497 5: 1783 6: 2455 7: 4546
           8: 4565 9: 4143 10: 2004 11: 3010 12: 4579 13: 4598 14: 4418 15: 1086 16: 1080
Graphics:  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Tongfang Hongkong Limited driver: i915 v: kernel
           bus-ID: 00:02.0
           Device-2: NVIDIA GA104M [GeForce RTX 3070 Mobile / Max-Q] vendor: Tongfang Hongkong Limited driver: nvidia
           v: 495.44 bus-ID: 01:00.0
           Device-3: Chicony HD Webcam type: USB driver: uvcvideo bus-ID: 3-13:5
           Display: x11 server: X.Org driver: loaded: modesetting resolution: 2560x1440~165Hz
           OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 21.2.5 direct render: Yes
Audio:     Device-1: Intel Tiger Lake-H HD Audio vendor: Tongfang Hongkong Limited driver: snd_hda_intel v: kernel
           bus-ID: 00:1f.3
           Device-2: NVIDIA GA104 High Definition Audio vendor: Tongfang Hongkong Limited driver: snd_hda_intel v: kernel
           bus-ID: 01:00.1
           Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes
           Sound Server-2: sndio v: N/A running: no
           Sound Server-3: JACK v: 1.9.19 running: no
           Sound Server-4: PulseAudio v: 15.0 running: no
           Sound Server-5: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kernel bus-ID: 00:14.3
           IF: wlo1 state: up mac: <filter>
           Device-2: Realtek RTL8125 2.5GbE vendor: Tongfang Hongkong Limited driver: r8169 v: kernel port: 3000
           bus-ID: 2d:00.0
           IF: enp45s0 state: down mac: <filter>
Bluetooth: Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-14:6
           Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
Drives:    Local Storage: total: 953.87 GiB used: 97.02 GiB (10.2%)
           ID-1: /dev/nvme0n1 vendor: A-Data model: IM2P33F8BR2-1TB size: 953.87 GiB temp: 28.9 C
Partition: ID-1: / size: 229.38 GiB used: 97 GiB (42.3%) fs: ext4 dev: /dev/nvme0n1p6
           ID-2: /boot/efi size: 96 MiB used: 25.3 MiB (26.3%) fs: vfat dev: /dev/nvme0n1p1
Swap:      Alert: No swap data was found.
Sensors:   System Temperatures: cpu: 55.0 C mobo: 55.0 C
           Fan Speeds (RPM): N/A
Info:      Processes: 357 Uptime: 11m Memory: 15.38 GiB used: 3.76 GiB (24.4%) Init: systemd Compilers: gcc: 11.1.0
           clang: 13.0.0 Packages: 1505 Shell: fish v: 3.3.1 inxi: 3.3.09

What do you mean by “slow”?

It takes around 3 seconds for the screen to update according to keypresses.
Also, it’s possible to observe the screen drawing from top to bottom when full screen redraws occur.

This kernel is no longer supported. Install another one, such as 5.15 or 5.10 LTS and reboot into them. Then remove 5.13 and update your system.

This is the first thing I’d try. Did you do that and notice improvements?

Did you remove quiet in this GRUB_CMDLINE_LINUX_DEFAULT ?
Without quiet, that means it prints a lot of info in boot, probably slower than quiet .

Yeap, I did, but, as I said, the problem is with grub menu, not post msgs.

My problem kind of shifted to this for this while. Using sudo mhwd-kernel rmc linux510 makes my system stuck on boot messages. Timeshift’s got my back and I’m stuck on kernel 513.

Also, it seems I’m unable to turn off MSHybrid in bios and use just the NVIDIA display. I somehow can only see my desktop if I change to tty2 and reinstall drivers (KDE then runs, my system frame rate is way faster, but rebooting makes tty1 stuck and I have to reinstall graphics drivers with mhwd in tty2 again.

I’m considering getting a list of installed packages and reinstalling, but I’m afraid I gonna lose access to my Windows partitions.

I ended up making a fresh install, and the original problem was corrected by forcing a 1024x768 on GRUB boot menu.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.