GRUB menu disappeared after Clonezilla backup

I have very similar problem as the one described in the post GRUB disappeared after attempt to recover.

I have dual boot Win 8.1/Manjaro system. After Clonezilla whole-drive backup, GRUB startup menu disappeared completely and the system has been booting directly into Windows.

I tried the instructions from the GRUB /Restore the GRUB Bootloader
Wiki page but got stuck.

After several unsuccessful attempts (had to do the full set of commands as the base solution didn’t work) I managed to get all the way to the last step ‘sudo update-grub’ which came up with similar error message as in last section of the quoted post above (cannot find GRUB for dev/sdb1), which suggests that the Grub was not updated properly.

Upon restart of the system, the GRUB menu showed up, however, it only has a single option which is Windows (the boot loader is EFI/Manjaro/grubx64.efi). Now I am stuck how to get the Manjaro system option as well as the other two standard menu items (memtest and advanced).

My ext4 partition is sda6 and my vfat (efi) partition is sda2

Any help is much appreciated. Thanks!

Here are some outputs:

parted -l (doesn’t give any result)

efibootmgr -v

[manjaro@manjaro Desktop]$ efibootmgr -v
BootCurrent: 0003
Timeout: 0 seconds
BootOrder: 0005,0000,2001,2003,2002
Boot0000* Windows Boot Manager	HD(2,GPT,c4ffa206-eb78-11e3-9c30-aa19f3c567a3,0x200800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0001* Realtek PXE	PciRoot(0x0)/Pci(0x1c,0x0)/Pci(0x0,0x0)/MAC(008cfa83f959,0)/IPv4(,0,0)RC
Boot0002* Realtek PXE	PciRoot(0x0)/Pci(0x1c,0x0)/Pci(0x0,0x0)/MAC(008cfa83f959,0)/IPv6([::]:<->[::]:,0,0)RC
Boot0003* EFI USB Device (Generic Flash Disk)	PciRoot(0x0)/Pci(0x1d,0x0)/USB(0,0)/USB(3,0)/HD(1,MBR,0x0,0x5499e8,0x2000)RC
Boot0004* Windows Boot Manager	HD(2,GPT,c4ffa206-eb78-11e3-9c30-aa19f3c567a3,0x200800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0005* Manjaro	HD(2,GPT,c4ffa206-eb78-11e3-9c30-aa19f3c567a3,0x200800,0x32000)/File(\EFI\Manjaro\grubx64.efi)
Boot2001* EFI USB Device	RC
Boot2003* EFI Network	RC

lsblk -f

>     [manjaro@manjaro Desktop]$ lsblk -f
>     NAME FSTYPE FSVER LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINT
>     loop0
>          squash 4.0                                                    0   100% /run/miso/
>     loop1
>          squash 4.0                                                    0   100% /run/miso/
>     loop2
>          squash 4.0                                                    0   100% /run/miso/
>     loop3
>          squash 4.0                                                    0   100% /run/miso/
>     sda                                                                         
>     ├─sda1
>     │    ntfs         System
>     │                       5012E7DE12E7C6D6                                    
>     ├─sda2
>     │    vfat   FAT32       74E8-F25E                                           
>     ├─sda3
>     │    ntfs               48A4EA45A4EA34DA                                    
>     ├─sda4
>     │    ntfs         HDD1
>     │                       D4FCEC4AFCEC2886                                    
>     ├─sda5
>     │    ntfs         Recovery
>     │                       D002825302823F0A                                    
>     ├─sda6
>     │    ext4   1.0         5c64cc09-b113-44ec-9ccb-e9c10153808d                
>     └─sda7
>          ntfs         HDD2
>                             5082CE5482CE3E6A                                    
>     sdb  iso966 Jolie MANJARO_XFCE_2003
>     │                       2020-06-06-07-11-25-00                     0   100% /run/miso/
>     ├─sdb1
>     │    iso966 Jolie MANJARO_XFCE_2003
>     │                       2020-06-06-07-11-25-00                              
>     └─sdb2
>          vfat   FAT12 MISO_EFI
>                             08E4-9928                                           
>     sr0

I would like to add that initially I was able to start the original system via Detect system bootloaders menu item on the Manjaro USB live install and selecting EFI/Manjaro/grubx64.efi option from the list.

After the above procedure, this option also shows a single item which is Windows.

If you’ve booted up from the live medium, open up a terminal and type the following command… :arrow_down:

su -

Enter the root password for the medium, and then issue the following commands. Be sure to let them finish. :arrow_down:

mount -t ext4 /dev/sda6 /mnt
mount -t vfat /dev/sda2 /mnt/boot/efi
manjaro-chroot  /mnt
pacman-mirrors -f 5 && pacman -Syyu
grub-install --recheck --no-rs-codes --efi-directory="/boot/efi" --target="x86_64-efi" --modules="part_gpt part_msdos zstd"

After this, you should be able to reboot, and Manjaro should now be added to the GRUB menu again.



Bingo - all worked perfectly!

Upon the first restart there were duplicate entries for Manjaro and UEFI Firmware.

Once I got to my Manjaro System, I started the GRUB Customizer (I know, some people do not recommend using it) which detected duplicate entries and removed them upon Update and Quit.

All good now!

Thanks a lot!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.