Grub, Kernel and 2nd boot issues

Hi all guys, thanks in advance for the great work on the distro. I’ve got my fresh 20.0.3 xfce iso a couple of days ago and I’m trying to set up a shiny dual boot config with windows beside manjaro. I’ve installed win10 already and to make everything work properly I’ve also shrinked my nvme drive (from win10 disk manager) to free 128 gigs for manjaro. When I boot into the live to start calamares everything goes smooth, installation process ends well but for some reason the grub entry in boot menu is never created properly.
This is not the main thing really, because from bios I can set my path to .efi file so I can have my manjaro entry in boot priority. I’ve also followed a couple of tutorial from the archived forum such as

and even if the system works after a couple of reboots the system nukes the kernel. I suppose it is the kernel because in the first start after installation everything is fine and when I have my sudo pacman -Syyu it replaces the 5.6.x.y kernel (the one which comes with the latest iso available today 20/08) - which is not supported, according to what Manjaro Kernel Manager says - with the latest one and then stops working. I’ve also tried 4.19, 5.4 and many more (no-LTS and LTS as well) but the system wont start in any way and even if i get everything up and running (grub&kernel) always after a couple of reboots the grub rescue pops up with apparently no reason.
I’m really in trouble with this situation because I need to use some proprietary software on windows but the main core of my job is much more fast on linux. Any ideas? :sob: :sob:

I have an acer aspire a515-44g with a ryzen renoir 4500u and a western digital nvme. Another strange thing: if I play too much with partitions, boot and bios, the bios itself freezes and when I press f2 the pc is stuck on acer logo. To make it work again I must force it into bios by removing my nvme and any bootable drive :neutral_face:

PS. bootable usb made with rufus on windows using gpt partition scheme because the pc is obviously uefi and so is win10

Uninstall linux-latest to prevent automatic kernel switching of old kernels before upgrading your system.
Mind you, that linux56 is EOL and replaced for a reason.

That’s fairly new hardware and probably not supported on older kernels. You can try linux57 and linux58.
If those fail, open a new thread with a description of your hardware and clear description of what fails and possible error messages, see

I have no error messages. Simply a bunch of grub rescue or a flashing dash on a black screen when the kernel goes down.

description of your hardware

the renoir cpu is the only component which was launched on the market in June. My GPU is “old” and its drivers are all ready and set, I’ve checked them.

And how can I install the system directly with 5.7 or 5.8 kernel if the iso provided here are on 5.6? Should I use Architect edition?

Install from the ISO you have, then open a terminal to

$ sudo pacman -R linux-latest
$ sudo pacman -Syu
$ sudo mhwd-kernel -i linux57
$ sudo mhwd-kernel -i linux58

After this, you can try to boot the old linux56 or any of the newly installed kernels on your fully updated system.

You forgot manjaro-chroot -a , didn’t you?
Boot with the live USB run the command and then run the commands about the kernel.

I thought about it - but chrooting into current installation won’t bring linux56 back. According to OP, that seems to be a kernel which does boot the machine.
Nevertheless, it’s also an option if any of the newer kernels are useable - and probably even easier to try out first.

1 Like

Ah, I see. Well, there is still linux56-rt available. He could install that one when in chroot.

I’ve done chroot. Didn’t work, btw I’ll try to install my iso and also do the kernel trick. Thanks guys :smile:

I’ll update the post once done.

Edit: Which is the difference between pacman -S linux58 and mhwd-kernel -i ?

mhwd-kernel will also take care of kernel modules (virtualbox…), graphics drivers and kernel headers.

Using it for linux58 triggered installation of these packages on my system:

[2020-08-09T23:15:17+0200] [ALPM] installed linux58 (5.8.0-2)
[2020-08-09T23:15:18+0200] [ALPM] installed linux58-headers (5.8.0-2)
[2020-08-09T23:15:18+0200] [ALPM] installed linux58-nvidia-418xx (418.113-2)
[2020-08-09T23:15:25+0200] [ALPM] installed linux58-virtualbox-host-modules (6.1.12-2)

The linux-latest package was not included in the minimal-iso which I’ve installed. Anyway, I’ve done all the things that @freggel.doe told me and now I have 3 kernels in total (5.6, 5.7 and 5.8). Actually, when I tried to boot the 5.8 everything worked fine, so I’m going to keep this one as the main one (also because it’s the newest).
When I give sudo pacman -Syyu or -Syu pacman prompts to me every time

would you switch linux56 with community/linux-latest

This is the thing which gave me problems right? So should I avoid linux-latest package to avoid losing my linux56 kernel which is the one that boots my machine everytime?

Glad you found linux58 working for your system so far.
Generally speaking one should avoid keeping EOL kernels as those are no longer supported (security holes…) and sometimes will cause problems down the road when trying to update (module building and whatnot).
Feel free to remove it anytime now that linux58 is up to the job.

UPDATE: the 5.8 kernel stopped working after a couple of days. When I try to start my machine it gives me:

[FAILED]: failed to start Light Display Manager

I was thinking of a gpu driver issue but when I check the drivers through the 5.6 (which is the only one that works) it seems to be ok. I’ve also followed

and mhwd command skips installation because it’s everything already set. Should I wait for a new kernel? I have no idea about how to proceed at this point, the only way to keep my machine up and running is with kernel 5.6