"grub_is_Shim_lock_enabled not found"

Hi there.

I would appreciate any help on this on. I used Timeshift after a recent update & upon reboot, I received the following:

“grub_is_Shim_lock_enabled not found”

My laptop has Manjaro with full disk encryption. I have not been able to find a suitable solution. I see I can hit “C” for the GRUB commandline but am not sure what to do from here. Any assistance would be greatly appreciated.

Big thanks.

Ruziel :wink:

Hi @ruziel,

As far as I know, you get the error when you try and boot from a UEFI system in BIOS mode. Or something like that. Point is, ensure that any software RAID, any safe boot setting is disabled in the BIOS/UEFI and ensure the you’re not using CSM, (I think that’s the abbreviation.) a.k.a. Legacy Mode.


You might also find this helpful:

Hi. Thanks for your assistance. I checked & Secure Boot is off. My machine has been running well for a long time & restoring to a previous Timeshift point seems to have stuffed things up, resulting in this issue. My skills are very limited but I will try going through the tutorial you linked to. It looks like I might need to use a Live install stick & fix it from there. Thanks…

I think so. But from what I could gleam it is definitely related to CSM/Legacy mode. So, I’d say check in BIOS/UEFI and switch to the one it’s not using at the moment. Then test again.

Thanks. I checked my BIOS & it’s set to UEFI only & Secure Boot is off. Thanks

1 Like

Then I suggest booting into a live environment, as you mentioned earlier, check if you are using BIOS or UEFI, then entering a chroot environment, and doing completing the above m mentioned reinstall accordingly:

How to chroot

  1. Ensure you’ve got a relatively new ISO or at least one with a still supported LTS kernel.

  2. Write/copy/dd the ISO to a USB thumb drive.

  3. When done, boot with the above mentioned USB thumb drive into the live environment.

  4. Once booted, open a terminal and enter the following command to enter the chroot environment:

manjaro-chroot -a
  1. If you have more than one Linux installation, select the correct one to use from the list provided.

When done, you should now be in the chroot environment.

But, be careful, as you’re now in an actual root environment on your computer, so any changes you make will persist after a restart.

Identifying whether your device uses BIOS or uEFI

Run the following in a terminal:

test -d /sys/firmware/efi && echo efi || echo bios

If the output is:

  • efi, your computer uses (u)EFI.
  • bios, your computer uses BIOS.

For more information, visit:

Thanks - I will create an ISO stick & log in. I’m not sure what to do after I’ve confirmed whether it’s using BIOS or UEFI, regarding this…

“grub_is_Shim_lock_enabled not found”

Thanks, R

Reinstall Grub:

Thanks, I will try fix later. Much appreciated…

Hi there.

When I run “manjaro-chroot -a”, my system says the following:

grub -probe: error: cannot find a GRUB drive for /dev/sdb1
==> ERROR: No Linux partitions detected

I’m not sure where to go from here & hoping to avoid a complete re-install

Thanks, Ruziel

Sounds like the disk died.Boot into a live environment, run and provide:

inxi --full --admin --filter --width


Thanks for your assistance. That command gives me a lot of output - what do I need to post in particular?

It says…
Local Storage 245.93 Gig - used 0 KiB
No partition data found
No swap data was found

Is any of that relevant or helpful?

Thanks, R

EDIT: I ran GSmartControl that’s included with the Live ISO & it didn’t pick up any damaged drives. I can also navigate to the files on my drive & view them. Thanks


But…if the chroot says it’s missing, but that shows fine…then something’s off…weird…wonky…but, then it says no space is used, so theoretically it’s empty, but you can browse the files…

What does

sudo fdisk -l

…produce? If all else fails a picture is fine.

Look for the Partitions section.

I have to be off, so hopefully someone else can pick up from here.

1 Like

I discovered the following: When I booted up with the Manjaro Live ISO, I selected the “select efi bootloader” option & it gives me the 2 options in the picture. When I select the top one, I can load my system perfectly fine. However, if I select the 2nd option (below), I get the original error message.

I have at least found a temporary fix but only if I have the Live ISO in my machine. If anyone can help me work this out, that would be great. Thanks a lot. Ruziel :wink:

hen it seems there is something messed-up with/in your BIOS/UEFI.

I don’t know…:thinking:

Have you tried booting into your installation, as you just described, and reinstalling grub as per that link I gave you?


The more I think about it, the less I know why this happens, but the more I think your solution is:

  1. Boot into your installation, as described above;
  2. once in, ensure your bootable USB drive isn’t plugged in anymore.
  3. Ensure install-grub from the core repository is installed:
    pamac install instal-grub
  4. Reinstall Grub, using:
    sudo install-grub
  5. Do a little dance, say a little wish for good luck, and reboot.

In theory, it should work. In practice we’ll have to see.

1 Like

Hi there. Thanks again for your help today. I did the following…

Booted in using the method I outlined
Ejected the Live ISO stick
Followed steps 3 & 4

I then noticed the following message:

grub-probe: error: cannot find a GRUB drive for /dev/sdb1. Check your device.map

It also says:

Warning: GRUB bootloader at /boot/efi/EFI/Manjaro was updated, but it seems like you are not using it by default. Please check your EFI boot priorities!

I’m not sure if any of the above helps. Thanks a lot for your assistance & no expectation for you to continue but much appreciated.

Thanks, R :wink:

This makes me think you should unplug the USB and check your boot priority in BIOS/UEFI.


You’re welcome! I couldn’t continue because by the time you replied, I was already in bed. Nevertheless, I stick to the opinion that you should check your BIOS/UEFI for your disks’ boot priority without your flash drive plugged in.

Thanks @Mirdarthos - I will look into this later today. I appreciate your assistance. You have an interesting profile name. Big thanks, R

1 Like

Glad ya think so, I can’t even remember where it came from, but it’s mine now and I’m keeping it.

1 Like

I checked my boot priority & nothing has changed there. I’m continuing to rely on the Live ISO at boot-up in the meantime. Hopefully I can find a solution & avoid doing a re-install. Thanks for all your assistance.