GRUB boots into CLI instead of menu

It could be very likely that this grub, which is booted into CLI, is not the grub of Manjaro.

How is that possible if there is only one Linux OS installed?

I changed it to 1 and this was the ouput to sudo upgrade-grub:

Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-6.1-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-6.1-x86_64.img
Found initrd fallback image: /boot/initramfs-6.1-x86_64-fallback.img
Warning: os-prober will not be executed to detect other bootable partitions.
Systems on them will not be added to the GRUB boot configuration.
Check GRUB_DISABLE_OS_PROBER documentation entry.
Root filesystem isn't btrfs
If you think an error has occurred, please file a bug report at "https://github.com/Antynea/grub-btrfs"
Found memtest86+ image: /boot/memtest86+/memtest.bin
Found memtest86+ EFI image: /boot/memtest86+/memtest.efi
done

Restarted the PC. Still got the CLI GRUB menu.


Image Edited.

On a side-note I asked GPT 4 the same question and it suggested that my GRUB was corrupted and to try this:

It appears that you are seeing the GRUB command line interface (CLI) instead of the GRUB menu. This can occur due to improper configuration or a problem with your GRUB installation.

To resolve the issue, follow these steps:

1. Boot your computer using a live Linux USB (the one from your Manjaro installation should work). Once you have booted into the live environment, open the terminal application.

2. Identify the partition where Manjaro is installed by listing the available partitions:

sudo lsblk -f


Take note of the partition that contains the Manjaro file system, e.g., /dev/sda1.

3. Mount the Manjaro partition:

sudo mount /dev/sda1 /mnt


Replace /dev/sda1 with the appropriate partition from the previous step.

4. Chroot into the mounted partition:

sudo manjaro-chroot /mnt


This command will put you into the root shell of the installed Manjaro system, allowing you to fix the GRUB configuration.

5. Reinstall the GRUB bootloader on the appropriate drive:

sudo grub-install /dev/sda


Make sure to replace /dev/sda with your primary boot drive (but not the specific partition, just the drive letter). Do not include any numbers at the end of the device name, as we want GRUB installed on the entire disk.

6. Update the GRUB configuration:

sudo update-grub


7. Exit the chroot environment:

exit


8. Reboot your computer:

reboot


After rebooting, your computer should show the GRUB menu with a list of installed operating systems, including Manjaro and Windows 10.

If the issue persists, it might be necessary to check for errors in the /etc/default/grub configuration file or do a fresh reinstallation of your Manjaro Linux system to ensure a clean GRUB installation.

Wouldn’t this make me stick to a single kernel? I don’t really have an opinion on which kernel to use; I just want to stick to the latest one.

Don’t read random suggestion like that, use the Manjaro WIKI for information and procedures.

Cita ```
If you think an error has occurred, please file a bug report at “GitHub - Antynea/grub-btrfs: Include btrfs snapshots at boot options. (Grub menu)

This error message makes me think that I install that?,because?

What do you mean?

re the mention of multiple drives:

You may have installed Grub to the wrong drive and keep booting from it
and update Grub updated the configuration of one that isn’t used?
Don’t know.

os_prober should be active, when looking at your configuratio - yet it apparently is not

Another issue could be that you mixed mbr and gpt partitions Windos one variant, Linux the other?
It is entirely possible to do that - but of course it will not work … not easily anyway.
Again: don’t know.

I have no idea how it is possible that you, without a keystroke, end up in the Grub edit menu. :man_shrugging:
That should never happen - not without you doing something (pressing a key at the right time …)



Don’t be fooled by all the media hype, telling you it is an AI and thereby presuming that it indeed knows or even understands something.
Google (or another search engine) and your own reading and discernment is way better.

It’s not designed to be an expert system - it’s designed to produce text that appears to make sense -
it will give you an answer - but that doesn’t in any way mean it is sensible or current.

How do I check the install location of grub/if it exists on any other drive incorrectly?

I really don’t know.
It was speculative anyway.
But it should not matter if you make sure you direct the Bios/Uefi to boot from the correct drive.
Check that.
That’s what seems to make sense to me anyway.

… perhaps (at least temporarily) disconnect the drives that do not belong to the currently defunct Linux system
if Bios/Firmware boot settings seem ok

1 Like

I shall try that.

Pictures of my BIOS:


I tried turning off safe boot and that didn’t change things. Will try unplugging HDDs next.

Seems you have a GRUB install from Ubuntu as your primary boot option.

What happens when you boot override directly to M1: Samsung SSD 850 evo?

You should try this before unplugging drives. I think you just have a wrong boot order…

First you try boot an old/broken grub left over by ubuntu, which has your command line issue. Then you exit it, which causes your MB to boot into your next boot priority probably and you boot fine every time.

2 Likes

Yep when I booted from M1 I didn’t get the GRUB menu. I should say that I deleted all volumes on my SSD before installing Manjaro via Windows Disk Management so it was a clean slate. I set M1 as first item on my boot order. I assumed Ubuntu was how Manjaro was recognized by BIOS.

Is there a way to get rid of the Ubuntu?

efibootmgr
sudo efibootmgr --bootnum XXXX --delete-bootnum

Output: EFI variables are not supported on this system.

Boot in EFI mode, not BIOS. I don’t think your OS’s use only the legacy UEFI/BIOS mode. You showed the UEFI Boot Priorities.

At least ubuntu and Windows Boot Manager are EFI entries.

I enabled secure boot:

The other thing that I found related to UEFI was CSM. I tried changing it to this:

That removed all disks except Ubuntu and Windows from the boot manager and always booted up Windows (no GRUB CLI though.)

I changed it back to what it was:

Tried to run efibootmgr but no luck. Same error as before: EFI variables are not supported on this system.

Manjaro does not support secure boot, ubuntu does. So there is no way to remove it with Manjaro unless you disable secure boot. So Manjaro is installed in legacy mode, then you have to choose the correct device with the correct MBR.

Plus: You will not be able to boot Windows from Grub anyway.

I don’t understand. Since Manjaro does not support secure boot it is installed in legacy boot. Does that have any bearing with Ubuntu or GRUB CLI?

Look: There is efi partition, right? On that partition, there are so called efi files. The UEFI Booloader targets the efi file on that partition. Now guess what? The ubuntu entry and the efi file on that partitions survive and you didn’t remove it. Since the efi file have a minimal grub, you see the grub command line. Gotcha?

If Manjaro is installed on a second drive in legacy mode, you have to target the drive on every boot with the UEFI Bootloader.

I hope that was less swahli for you. :wink: