Grub-Bootmenü erscheint nicht

Hallo,

Das GRUB-Bootmenü, das es mir gestattet, mit einem anderen Kernel zu booten oder einen RAM-Test durchzuführen, erscheint bei mir nicht. Ich kriege es nur zu sehen, wenn ich erst ins BIOS gehe und dieses wieder verlasse.

Ich habe /home mit LUKS verschlüsselt. Ist das vielleicht die Ursache?

Viele Grüße
Anando

Schon nach hide grub gesucht?

soweit ich weiss musst du die shift taste drücken. dann erscheint grub und du kannst wieder auswählen.
ansonsten ist das grub absichtlich verdeckt.
AFAIR

1 Like

@SGS:
Ich habe jetzt eine Zeitlang diverse Beiträge gelesen, die unter Eingabe von "hide grub" angezeigt wurden. Demnach ist in meiner /etc/default/grub alles richtig; das Boot-Menü müsste angezeigt werden. Hat bei früheren Installationen auch immer funktioniert.

@Quinix:
Das funktioniert tatsächlich. Sollte keine Lösung des Problems gefunden werden, werde ich darauf als Notlösung zurückgreifen, z. B. wenn ich testen möchte, ob die installierten Kernel funktionieren.

Man liest sich!
Anando

Ich habe einiges auf verschiedenen Sites gelesen über die einzelnen Parameter von /etc/default/grub. Einen Fehler konnte ich bisher nicht finden. Vielleicht sieht aber einer von euch, was verkehrt ist. Hier meine /etc/default/grub:

GRUB_DEFAULT=saved
GRUB_TIMEOUT=10
GRUB_TIMEOUT_STYLE=menu
GRUB_DISTRIBUTOR='Manjaro'
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

# Uncomment to get a beep at GRUB start
GRUB_INIT_TUNE="480 440 1"


Vielleicht habe ich ja Tomaten auf den Augen?

Man liest sich!
Anando

:tomato:

Danke für den Hinweis. Ich habe das fehlende splash ergänzt. Es ändert sich aber leider nichts.

Mir fällt aber auf, dass, wenn das Menü beim Drücken der Shift-Taste erscheint, kein Timer angezeigt wird.

Jetzt habe ich aber entdeckt, dass in der Datei /boot/grub/grubenv gespeichert ist, welcher Eintrag des Bootmenüs standardmäßig ausgewählt ist, wenn in der /etc/default/grub GRUB_DEFAULT=saved steht. Ich habe mir leider nicht gemerkt, was da vorher drin stand. Mit sudo grub-set-default 0 habe ich den ersten Eintrag angewählt und bin jetzt gespannt.

Man liest sich!
Anando

Das wars leider auch nicht. :frowning_face:

Anando

Hast du

sudo grub-editenv - unset menu_auto_hide

versucht? GRUB_TIMEOUT_STYLE sollte bei menu bleiben. Und ich würde das splash wieder entfernen.

Quelle ( etwas veraltet, aber die grub-editenv Befehle haben sich nicht geändert)
Changes made to Grub-Quiet

2 Likes

Danke, das wars! Auch der Timer läuft! Ich werde splash wieder entfernen und auch den Piepser wieder ausstellen.

Man liest sich!
Anando

Forum kindly sponsored by Bytemark