Graphics Driver Issues Likely; Potentially Power Issue

Alright, apci_osi=Linux brought us a little further in the right direct.

My parameters currently read:
GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash ibt=off usbcore.autosuspend=-1 apci_osi=Linux”

I installed Linux 6.0 and got the same results as 5.19 with the new parameter: the mousepad is clearly picking up more input now. It is still experiencing the same issue, but is better in terms of, say, the previous was pointer-movement:actual-input 1:500, it is now 1:30. Still not usable, but this had an impact.

and did you checked the refresh rate on the 6.0?

so remove also the usbcore.autosuspend=-1 parameter since it didnt helped, and replace the acpi_osi=Linux parameter with this one:
(yes thats how the parameter really is, there is nothing after =)
save grub, update grub: sudo update-grub
reboot and test, if it didnt helped, try this parameter:
acpi_osi='Windows 2018'
save grub, update grub, reboot and test;
if for whatever reasons you have problem booting with this parameter, in the grub menu press ‘E’, locate the parameter and remove it

Alright, I’ve tried both of those parameters and they both result in this 1:30 pointer-movement:actual-input behavior, but no improvement.

ok, so remove the acpi parameters and replace them with this one:
save grub, update grub:
sudo update-grub
reboot and test
this parameter changes your suspend mode from deep to freeze and it should help with the mousepad … however this freeze mode has lower power saving than the deep one

It’s a miracle. The mousepad works perfectly now! Is this the final solution you want to aim for here or was there more you wanted to try/refine with this?

I would much rather maintain these parameters than have the mousepad functioning improperly again. How much of a power saving difference, roughly, might this make?

1 Like

this was the last parameter …
thats hard to tell how much, we should have tested it before… but for example in the deep suspend mode, the batery may drain 0,5% after an hour, and in the freeze suspend mode it may be 2-3% drain after an hour …
the bigest battery drain in this freeze mode would be nvidia, so create this file:
kate /etc/modprobe.d/nvidia-s2idle.conf
and put there this line:

options nvidia NVreg_EnableS0ixPowerManagement=1 NVreg_S0ixPowerManagementVideoMemoryThreshold=10000

save the file, run this:
sudo mkinitcpio -P
then reboot and switch to nvidia via optimus tray (dont change the startup mode! only switch), and test if everything is working with this option, also suspend/resume and see if everything is working

Alright, I’ve done as you suggested!

All is working! I LOVE how instantly the system pulls itself out of sleep with these parameters too. I’m sure this is also a part of the increased power draw you mentioned, but I think it might be worth it lol. It gives me the illusion it operates even faster!

The only thing with these settings is that when I open the laptop lid and am prompted for my password, the wallpaper behind the login screen is just black. Once I enter my password and sign in, everything is loaded up. If you have any solutions in mind for this I’ll try them, but it doesn’t really matter if not. Functionality is way more important to me than seeing mountains on my lock screen.

1 Like

so you switched to nvidia via optimus tray, and everything worked as it should?
the bigger power drain is only when you suspend your system, it doesnt affect anything else…

the wallpaper issue, the best way to check if its something messed up in your main user or is a system wide issue, is to create a new test user, go to system settings/users and create a new test user, when done logout, log in with the new test user, and suspend and check if it has also a black screen

also do you plan to use your nvidia card on manjaro? doing some games, graphics …etc? asking because i want to try something for the locked refresh rate

Yes, everything worked normally with the nvidia selected, including the “test fire” graphics test.

That being said, I then created a test user with admin privileges. On my main user account, I selected nvidia drivers and I was prompted to log back in afterwards, with the background on the lock screen visible, with the option to sign in to the test user. If I try to sign into the test user account from here, I can sign into it no problem.

If I sign into my main account with nvidia drivers enabled, and then “switch user,” I get a black screen. No keyboard commands work, no GUI, no wallpaper, but the mousepad still works.

If I sign into the test account with integrated graphics and enable nvidia drivers from there, I get the same black screen result.

If I only use integrated graphics, all signing in/out, graphics functioning, etc is all functioning normally.

And to answer your last question, yes I may use the graphics card for some games here and there.

if i understand it correctly, you cannot use the test user with nvidia?
and when suspending in the test user, did it have also the black screen instead of the wallpaper when entering password?

If I enable nvidia graphics on the main user, when I am brought to the sign in screen, I can sign into test user.

If I am currently in test user, enabling nvidia causes the frozen black screen.

Suspending and waking in test user (while still on integrated graphics) works normally.

Suspending and waking in test user (after signing into it, with nvidia drivers enabled, directly after being logged out of main user due to graphics driver swap) works, but also has the black background login.

Sorry about the extra info btw, I just want to provide answers to future questions preemptively if possible.

thats ok, so when you boot your pc and you log in with the test user on integrated everyhting works, and also there is no black screen when resuming from suspend?

when in test user and switching to nvidia, log out - log in, you end up with a black screen?


and when in main user you switch to nvidia, log out, log in with test user, you end up with a black screen?

and when in test user, you switch to nvidia, and log in with main user it works?

and when in main user you switch to nvidia, log out, log in with test user, you end up with a black screen?

When I select nvidia drivers, it forces a log-out. I imagine this is natural. From here, I can sign in to the test account and no black screen occurs. This is the only way I can have nvidia graphics enabled while on test account.

and when in test user, you switch to nvidia, and log in with main user it works?
No, when in test user and i attempt to switch to nvidia, I get the frozen black screen.

ok, so this is an interesting issue, but i have no idea what could be causing it…
but the black screen after resuming from suspend doesnt happen on the test user?
thats the thing we wanted to figure out

Correct. But maybe let’s put a pause on this issue. I was just attempting to move a folder to another folder. It returned an ownership error of the file that I was aiming to write to. So I used chown -R to grant write permissions to the folder…but made quite an error.

I wanted to enter sudo chown -R myname /mydirectory/
But accidentally entered sudo chown -R myname /

I accidentally muscle memory entered my password and just changed ownership of everything under / to my user. Is it too long of a process here for me to manually readjust the default permissions of the folders under “/”? Or is it relatively straightforward?

If it is absurd and I screwed this up, I’m going to reinstall Manjaro today. If this isn’t warranted, what folder must I reassign ownership to?

I rebooted the computer and network manager isn’t functioning, many folders are having problems, etc.

so you changed ownership of your root folder? then probably the best option is really to reinstall, unless you have a timeshift backup …

I’ll reinstall, we can get back to troubleshooting tomorrow. Shouldn’t take me too long. I haven’t installed a ton. I’ll get it back to the state we were in

yes but you have to reapply all those fixes that we did.