Graphics broken during installation

My cousin has a pc which runs windows10. Being very enthusiastic I convinced him to install GNU/Linux and I was helping him do it… while the installation, as calamares was doing stuff, the graphics was behaving weird and it remained like that…

Specs (while trying to install Mint, please dont mind :sweat_smile:)

  Kernel: 5.4.0-74-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 
  Desktop: Cinnamon 5.0.4 wm: muffin 5.0.1 dm: LightDM 1.30.0 
  Distro: Linux Mint 20.2 Uma base: Ubuntu 20.04 focal 
  Type: Desktop Mobo: Gigabyte model: H81M-S v: x.x serial: <filter> 
  UEFI: American Megatrends v: F2 date: 08/19/2015 
  Topology: Dual Core model: Intel Pentium G3240 bits: 64 type: MCP 
  arch: Haswell rev: 3 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 12370 
  Speed: 1161 MHz min/max: 800/3100 MHz Core speeds (MHz): 1: 929 2: 940 
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics 
  vendor: Gigabyte driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0402 
  Display: x11 server: X.Org 1.20.9 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics (HSW GT1) v: 4.5 Mesa 20.2.6 
  compat-v: 3.0 direct render: Yes 
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio 
  driver: snd_hda_intel v: kernel bus ID: 00:03.0 chip ID: 8086:0c0c 
  Device-2: Intel 8 Series/C220 Series High Definition Audio 
  vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:8c20 
  Sound Server: ALSA v: k5.4.0-74-generic 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8169 v: kernel port: e000 bus ID: 02:00.0 
  chip ID: 10ec:8168 
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Local Storage: total: 320.19 GiB used: 4.20 GiB (1.3%) 
  ID-1: /dev/sda vendor: Seagate model: ST3320311CS size: 298.09 GiB 
  speed: 3.0 Gb/s rotation: 5900 rpm serial: <filter> rev: SC13 temp: 29 C 
  scheme: GPT 
  ID-2: /dev/sdb type: USB vendor: SanDisk model: Ultra size: 14.61 GiB 
  speed: 3.0 Gb/s serial: <filter> rev: 1.00 scheme: MBR 
  ID-3: /dev/sdc type: USB vendor: HP model: v220w size: 7.49 GiB 
  serial: <filter> rev: 1100 scheme: MBR 
  ID-1: / size: 1.87 GiB used: 87.0 MiB (4.5%) fs: overlay source: ERR-102 
  System Temperatures: cpu: 29.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 190 Uptime: 3m Memory: 3.75 GiB used: 1.00 GiB (26.7%) 
  Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Shell: bash 
  v: 5.0.17 running in: gnome-terminal inxi: 3.0.38

this same thing happened with Zorin, MX, Mint and Manjaro (in this order)… so i’m not sure whether its a issue of software or hardware… but when i opened windows 10 before trying to install linux, it seemed working. though i had it opened for like 10 minutes only… (also when i’m booting into the live usb, i can see mint partitions, but it wont boot)
i just dont want to install that proprietary OS before returning it to him…

any help/guide/direction would be helpful … thanks in advance

Check if there is a bios update available

thanks :beers:

i checked; F2 is the last version available on the manufacturer webpage…

actually the pc wasnt booting for a month… i opened it up cleaned the RAM and it started fine yesterday… so i have a hunch maybe its a hardware (RAM) issue after all…

Hello @fyataru :wink:

That looks to me like a malform power-saving feature. Add this to the kernel parameter:

intel_idle.max_cstate=1 i915.enable_dc=0 i915.enable_fbc=0
  1. will restrict the cstate of the processor at C0 and C1.
  2. disables the power-saving display C-states.
  3. disables frame buffer compression for power savings.

More info:

modinfo i915
modinfo intel_idle
1 Like

thanks @megavolt for pointing this out… i’d definitely try this at night and let you know…

even if it dont work :wink: which i hope not, then also i got to know about something new :innocent:… and that was really fun… :beers:

can you tell me how to add these while being in live environment? :sweat_smile:



  1. Boot up to the grub menu and edit with E the entry.
  2. Add the kernel paramter at line of linux at the end.
  3. Type F10 to boot.


  1. Open a terminal.
  2. manjaro-chroot -a (not needed when you booted the local installation)
  3. sudo nano /etc/default/grub
  4. Add the kernel parameter to this variable:
GRUB_CMDLINE_LINUX_DEFAULT="existing parameters <add here more with spaces between>"
  1. Run: sudo update-grub
  2. sync && reboot

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.