Grafik freezes mit GeForce und offenem Treiber

Liebe Linux-User,

Leider habe ich Probleme, die sehr wahrscheinlich auf die Grafikkarte zurückzuführen sind. Einige Spiele frieren unter Linux (unter Windows hat die gleiche Hardware keine Probleme) regelmässig ein. Euro Truck Simulator 2 machte früher schon Schwierigkeiten, stellte dann das Spiel auf einen Minimummodus und benutzte auch “-mm_pool_size 2000” in den Startoptionen fest. Danach gingen die Probleme etwas zurück. Leider trat es in letzter Zeit wieder einmal auf und ein anderes neues Spiel stürzte ebenfalls ab, nämlich Streets of Rage 4 während ich das Bildschirmwackeln abstellte. Da wurde mir eigentlich klar, dass es an der Grafik liegt, zumal bei Grafikabstürzen typische Phenomene jedes Mal zu anherrschend waren. Strg+Alt+Ent führte nicht zum Desktop oder öffnete den Taskmanager, genauer zeigte sich immer keinerlei Grafikreaktion mehr. Das Bild ist eingefroren während den Ton teilweise weiterlief- typisch Grafikproblem also. Was läuft bei mir also falsch ?
Aufgefallen ist mir dann halt die Warnmeldung, die beim letzten Systemupdate auftrat, folgende 4 Meldungen erschienen :
Warnung: mhwd-nvidia: /var/lib/mhwd/ids/pci/nvidia.ids existierte bereits im Dateisystem
Wurde als /var/lib/mhwd/ids/pci/nvidia.ids.old archiviert
Warnung: mhwd-db: /var/lib/mhwd/db/pci/graphic_drivers/hybrid-amd-nvidia-prime/MHWDCONFIG existierte bereits im Dateisystem
Wurde als /var/lib/mhwd/db/pci/graphic_drivers/hybrid-amd-nvidia-prime/MHWDCONFIG.old archiviert
Warnung: mhwd-db: /var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nvidia-prime/MHWDCONFIG existierte bereits im Dateisystem
Wurde als /var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nvidia-prime/MHWDCONFIG.old archiviert
Warnung: mhwd-db: /var/lib/mhwd/db/pci/graphic_drivers/nvidia/MHWDCONFIG existierte bereits im Dateisystem
Wurde als /var/lib/mhwd/db/pci/graphic_drivers/nvidia/MHWDCONFIG.old archiviert
Diesbezüglich fand ich auf dieser Forumsseite die Information…
Das ist nur ein Datenbank-Eintrag für das mhwd-Tool - kein Treiber, vollkommen harmlos.
Das führt dann also nicht zum Problem, habe deshalb mal folgendes eingegeben…

Ordner Inhalt (also installiert sind…) mit
ls /var/lib/mhwd/local/pci/
video-linux

Installiert:
pamac list --installed | grep nvidia
mhwd-nvidia 455.45.01-3 core 1,5 kB
mhwd-nvidia-340xx 340.108-1 2,5 kB
mhwd-nvidia-390xx 390.138-1 core 1,9 kB

Installierbar
mhwd -l
0000:01:00.0 (0300:10de:1380) Display controller nVidia Corporation:

              NAME               VERSION          FREEDRIVER           TYPE

video-nvidia-390xx            2020.11.30               false            PCI
       video-linux            2018.05.04                true            PCI
 video-modesetting            2020.01.13                true            PCI
        video-vesa            2017.03.12                true            PCI

mhwd -l
gibt mir folgendes aus…

              NAME               VERSION          FREEDRIVER           TYPE

       video-linux            2018.05.04                true            PCI

Die Frage, die sich stellt, was läuft verkehrt ?
Weiß Jemand einen Hinweis oder sollte ich den nVidia-Treiber installieren ?
Macht der nVidia-Treiber überhaupt noch Sinn, wenn die bald nicht mehr supported werden und was könnte sonst schief laufen in meinem System ?

Freue mich über Fragen, Tipps und Kommentare, am Besten natürlich Lösungsansätze, wo man praktisch dasselbe Problem schon an anderer Stelle lösen konnte.

Gruß

Nett wäre es, den Output von folgendem Befehl mal zu posten:

inxi -Fxxxza --no-host

Dann erfahren wir auch mal, welche Hardware denn genau genutzt wird. :wink:

Am besten erst mal System updaten.

Sofern nur eine Nvidia-Grafikkarte vorliegt, wäre der normale Weg, den proprietären Treiber zu installieren:

sudo mhwd -a pci nonfree 0300

Dann rebooten.

Mehr kann man hier nachlesen:
Configure NVIDIA (non-free) settings and load them on Startup - Manjaro

Also erstmal ein Strip-Tease :blush:
aber so nett bin ich.

System:    Kernel: 5.4.85-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 root=UUID=3468e51a-3fae-47ee-b513-04cf4d727623 rw quiet 
           apparmor=1 security=apparmor resume=UUID=601e5087-ae8d-454b-9915-059584163414 udev.log_priority=3 
           Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop System: BIOSTAR product: A68MD PRO v: N/A serial: <filter> Chassis: type: 3 serial: <filter> 
           Mobo: BIOSTAR model: A68MD PRO serial: <filter> UEFI: American Megatrends v: 4.6.5 date: 12/15/2015 
Battery:   Device-1: hid-dc:2c:26:e3:7f:a4-battery model: Bluetooth 3.0 Wireless Keyboard serial: N/A charge: N/A 
           status: N/A 
CPU:       Info: Quad Core model: AMD Athlon X4 840 bits: 64 type: MCP arch: Steamroller family: 15 (21) 
           model-id: 30 (48) stepping: 1 microcode: 6003106 L2 cache: 2 MiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 24760 
           Speed: 3196 MHz min/max: 1400/3100 MHz boost: enabled Core speeds (MHz): 1: 3196 2: 2930 3: 2445 4: 2326 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GM107 [GeForce GTX 750 Ti] vendor: Gigabyte driver: nouveau v: kernel bus ID: 01:00.0 
           chip ID: 10de:1380 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: nouveau unloaded: modesetting 
           alternate: fbdev,nv,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1600x1200 s-dpi: 96 s-size: 423x317mm (16.7x12.5") s-diag: 529mm (20.8") 
           Monitor-1: DVI-D-1 res: 1600x1200 hz: 60 dpi: 94 size: 432x324mm (17.0x12.8") diag: 540mm (21.3") 
           OpenGL: renderer: NV117 v: 4.3 Mesa 20.3.1 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD] FCH Azalia vendor: Biostar Microtech Intl Corp driver: snd_hda_intel 
           v: kernel bus ID: 00:14.2 chip ID: 1022:780d 
           Device-2: NVIDIA GM107 High Definition Audio [GeForce 940MX] vendor: Gigabyte driver: snd_hda_intel 
           v: kernel bus ID: 01:00.1 chip ID: 10de:0fbc 
           Sound Server: ALSA v: k5.4.85-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Biostar Microtech Intl Corp 
           driver: r8169 v: kernel port: d000 bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 1.94 TiB used: 290.31 GiB (14.6%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST500DM002-1BD142 size: 465.76 GiB block size: 
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: KC45 
           ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: SA400S37120G size: 111.79 GiB block size: 
           physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: B1D1 
           ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital model: WD15EADS-00P8B0 size: 1.36 TiB block size: 
           physical: 512 B logical: 512 B speed: 3.0 Gb/s serial: <filter> rev: 0A01 
           ID-4: /dev/sdh maj-min: 8:112 type: USB vendor: Intenso model: Alu Line size: 7.42 GiB block size: 
           physical: 512 B logical: 512 B serial: <filter> rev: 2.00 
           SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
Partition: ID-1: / raw size: 103.2 GiB size: 101.08 GiB (97.95%) used: 35.37 GiB (35.0%) fs: ext4 dev: /dev/sdb2 
           maj-min: 8:18 
           ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) used: 280 KiB (0.1%) fs: vfat dev: /dev/sdb1 
           maj-min: 8:17 
           ID-3: /home raw size: 1.31 TiB size: 1.29 TiB (98.36%) used: 211.71 GiB (16.1%) fs: ext4 dev: /dev/sdc5 
           maj-min: 8:37 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 8.29 GiB used: 1.93 GiB (23.3%) priority: -2 dev: /dev/sdb3 maj-min: 8:19 
Sensors:   System Temperatures: cpu: 12.5 C mobo: N/A gpu: nouveau temp: 35.0 C 
           Fan Speeds (RPM): N/A gpu: nouveau fan: 1440 
Info:      Processes: 205 Uptime: 6h 43m wakeups: 1222 Memory: 7.7 GiB used: 6.03 GiB (78.3%) Init: systemd v: 247 
           Compilers: gcc: 10.2.0 Packages: pacman: 1894 lib: 489 flatpak: 0 Shell: Bash v: 5.1.0 running in: yakuake 
           inxi: 3.2.01 

Ich habe mich bisher nicht um die Treiberinstallation gekümmert, sondern alles einfach so belassen wie am Anfang, weil ich nicht wusste, dass man das unter Linux auch installieren soll. Ich werde mich morgen darum kümmern und mich nochmal melden…

Erstmal Danke für Anleitung und Link.

I würde den von mir oben vorgeschlagenen Befehl zum Installieren des proprietären Nvidia-Treiber ausführen.

Anschließend:

sudo mhwd -li

Ergebnis mal posten.

So,
habe System aktualisiert, Treiber installiert, rebootet und habe dann diese Ausgabe…

Installed PCI configs:


              NAME               VERSION          FREEDRIVER           TYPE

video-nvidia-390xx            2020.11.30               false            PCI
       video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

Kann man mit zwei Treibern überhaupt laufen ?
Auf dem Desktop hatte ich keine Probleme.

@Handspuehler Dann hat wohl alles geklappt :slight_smile:

Ja das ist möglich, wenn der eine Treiber geblockt oder niedriger priorisiert wird als der andere. Im Fall von nvidia musste der freie Nouveau Treiber geblockt werden, denn ansonsten funktioniert es nicht. Das wurde mit mhwd schon gemacht.

So, während auf dem Desktop keine Schwächen zu erkennen sind, sind meine Spiele nun unspielbar geworden Frameraten unter 20, wo ich vorher locker 60 hatte. Eine Katastrophe :disappointed_relieved: und ich kenne mich kaum mit Linux aus.
Habe auch schon die nvidia-settings so eingestellt, also von Qualität auf Performance, aber immer noch eine Ruckelshow, Kann man da noch was einstellen oder muss ich den nvidia-Treiber wieder deinstallieren ? Denn der Zustand vorher war um Welten besser.

@Handspuehler

Kannst du mal die Ausgabe von:

inxi -Gazy

hier posten?

Welche Treiber werden dir den mit mhwd -l angeboten? Im Zweifelsfall installiere den aktuellen Treiber, da mhwd -l die IDs abgleicht und dir anzeigt welchen Treiber zu installieren kannst. video-nvidia wäre der aktuelle, falls dir dieser angezeigt wird.

Welchen Treiber hattest du denn vorher? Mit dem 390xx hab ich auch Probleme mit dxvk, da dort einige vulkan features nicht unterstützt werden, die von dxvk gebraucht werden.

Habe den 460xx mit einem dkms Paket installiert für meine GTX1050ti. Da läuft alles rund für mich. Ich war mal so frei und habe mal nachgeschlagen… laut nvidia wird die gtx750ti auch mit dem 460xx Treiber unterstützt.

Ich würde dir folgendes vorschlagen:

(:exclamation:WICHTIG: Falls du KDE verwendest, wechsel von opengl auf xrender für den desktop)

Deinstallier den Treiber mit mhwd:

sudo mhwd -r video-nvidia-390xx

Dann installiere den beta Treiber (auch wenn da beta dran steht, laut nvidia ist das production Unix Drivers | NVIDIA):

pamac build lib32-nvidia-utils-beta nvidia-beta-dkms nvidia-utils-beta

Dann musst von Hand (ja das wurde sonst mhwd machen), das hinzufügen:

/etc/modules-load.d/nvida.conf

nvidia
nvidia-drm

/etc/modprobe.d/nvidia.conf

blacklist nouveau
blacklist ttm
blacklist drm_kms_helper
blacklist drm

und hiermit geht das in einem Rutsch:

sudo echo -e "blacklist nouveau\nblacklist ttm\nblacklist drm_kms_helper\nblacklist drm" > /etc/modprobe.d/nvidia.conf \
sudo echo -e "nvidia\nnvidia-drm" > /etc/modules-load.d/nvida.conf

Und nicht vergessen, eine xorg.conf anlegen mit:

sudo nvidia-xconfig

Dann kannst du neu starten.

Der 460xx Treiber läuft weitaus besser als der 390xx und hat bugs, die in 455xx bekannt sind behoben.

`inxi -Gazy’ liefert folgendes

Graphics:
Device-1: NVIDIA GM107 [GeForce GTX 750 Ti] vendor: Gigabyte driver: nvidia
v: 390.138 alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1380
Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: nvidia
display ID: :0 screens: 1
Screen-1: 0 s-res: 1600x1200 s-dpi: 94 s-size: 432x321mm (17.0x12.6")
s-diag: 538mm (21.2")
Monitor-1: DVI-D-0 res: 1600x1200 hz: 60 dpi: 94
size: 432x324mm (17.0x12.8") diag: 540mm (21.3")
OpenGL: renderer: llvmpipe (LLVM 11.0.0 256 bits) v: 4.5 Mesa 20.3.1
compat-v: 3.1 direct render: Yes

mhwd -l liefert folgendes

0000:01:00.0 (0300:10de:1380) Display controller nVidia Corporation:


              NAME               VERSION          FREEDRIVER           TYPE

video-nvidia-390xx            2020.11.30               false            PCI
       video-linux            2018.05.04                true            PCI
 video-modesetting            2020.01.13                true            PCI
        video-vesa            2017.03.12                true            PCI

Der aktuellste Treiber ist der video-nvidia, aber der macht doch gerade Probleme. Das ist ja grad das Dillemma.
Vorher hatte ich den offenen und immer noch installierten Standardtreiber video-linux und der lief realtiv gut bis auf die sporadischen Freezes eben.

Ja, ich verwende KDE und wie wechsel ich auf xrender ?

Deine Grafikkarte ist ja auch etwas moderner als meine. In der offiziellen nvidia-Artikel kann ich entnehmen, dass der 340.108 mit meinem Kernel 5.4 klar kommt und außerdem ist er mit der X-Server-Version 1.20 kompatibel, welche ich benutze. Wie oben schonmal erwähnt zeigt mir der Terminalbefehl

  • pamac list --installed | grep nvidia

dass genau der 340er auf meines System ist…
mhwd-nvidia 455.45.01-3 core 1,5 kB
mhwd-nvidia-340xx 340.108-1 2,5 kB
mhwd-nvidia-390xx 390.138-1 core 1,9 kB

Wäre es nicht besser den Mal zu probieren ? WÄre mir persönlich lieber, kenne mich aber nicht so gut aus, also wenn mir nochmal Jemand helfen könnte. Vorteilhaft wäre eine ausführliche Anleitung…Danke im Voraus.

Das Problem hat sich erledigt und bedarf keiner weiteren Hilfe. :grin:

Die Lösung erfuhr ich nicht in diesem Thread, sondern hier im englischsprachigen Teil des Forum. Für alle, die ebenfalls Probleme mit dem normalen 390 nvidia-Treiber haben sei gesagt, dass sie lediglich zwei Zeilen einfügen müssen.

Habe mir die Datei angesehen und es fehlten ebenfalls die beiden Zeilen, nach dem einfügen, Datei speichern, neu starten und habe bei Sauerbraten nun locker 200fps.

Schönen Abend noch.

Wenn da mhwd dran steht, dann ist das die Datenbank für mhwd, nicht der Treiber. Eigentlich sollten die mit dem Update entfernt worden sein… aber gut.

Hauptsache es funktioniert nun :+1: Viel Spaß beim Zocken :slight_smile: