GPU Fan always at 0 RPM

I’ve tried the “Patch” or w/e and still doesnt work. RX 6700 XT Reference Design card. Fan controls do work for the fan but it just will not show current fan RPM in lmsensors, corectrl, amdfan nor fancontrol. I’m still fairly new-ish with Linux and just recently switched after trying it and seeing that pretty much every game I play runs so I fully changed over to Manjaro about 4 days ago. Anyone know any possible way to get the fan RPM to actually show?

Hi and welcome to the forum :wave:

This page could be helpful if you have not found it already. It has a troubleshoot section that might be of help in your situation. Sharing some more about your system would help others to help you better:

What patch or w/e used would help since forum users are not mind readers :wink:

Sorry. It’s a patch that someone shared on here. It worked for them. not for me. MSI B450 Gaming Pro Carbon Max Wifi, Ryzen 7 3800X, 16gb G.Skills ram, and an RX6700 XT on a Samsung 980 NVMe M.2 SSD

Problem shall go away using kernel518 without any patch?!

I’m on 5.18.0_rt11-1 kernel currently. Do I need to change to the 5.18.7-1?

Is there a specific reason to be on a real time kernel? If not then yes change to a LTS or stable kernel

I swapped kernels hoping it would fix the RPM readout issue. but it did not. Havent had any other issues so haven’t had a need to switch back.

Have yopu tried Psensor to identify the Graphics-Card-Fan?
Speed on Windows compare with Psensor Fan Speeds
– there are some Fans listed in Psensors 0U/min - those do not exist…

1 Like

Just did. shows it as lmsensor amdgpu-pci-2800 fan1 but still shows 0 RPM

Fans are working. that I can confirm. I just can’t get an RPM readout from it =(

Any other thing in Psensor called “Fan” and “U/min”?

No. there is not. Just fan1 thru fan6 which are on my commander pro for my case/AIO fans
will not help, I think?

No. That is the “patch” that i referred to. I tried it but to no avail. Did not work for me. works for some though lol

mhwd-amdgpu is installed? amdgpu-fan (AUR)?
What says the command “fancontrol”
linux518 testing5.18.10-1

Question: Do you reboot after installing a new kernel??

i’m running fancontrol-GUI and it also shows 0 RPM. I do have amdgpu fan installed as well and it also returns a 0 RPM reading.

and yes, mhwd-amdgpu is installed.

Yes, I reboot after installing a new kernel.

Update: Switched to the 5.18.7-1 kernel and now I am getting an RPM readout on the GPU fans.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.