Gnome-settings update 20200929-2 -> 20201023-2 changed default terminal font

Hi there,

the last manjaro-gnome-settings update from version 20200929-2 -> 20201023-2 changed the default profile font for gnome-terminal.

See Commit 8b6e32817f92c5ac4bac88e2a36cd3668576ad57 in Commits · 19.0 · Profiles & Settings / manjaro-gnome-settings · GitLab in file schemas/99_manjaro-settings.gschema.override.

What this does on my system, is changing the gnome-terminal font for all profiles on the update.
IMHO this is maybe not the right place to do such a change cause it breaks user customized settings. At least it did on my installation.

After all the default font for monospace is still Hack 11.
From manjaro-gnome-settings/schemas/99_manjaro-settings.gschema.override:

[org.gnome.desktop.interface]
cursor-theme='xcursor-breeze'
document-font-name='Sans 11'
enable-animations=true
font-name='Noto Sans 11'
gtk-im-module='gtk-im-context-simple'
gtk-theme='Matcha-sea'
icon-theme='Papirus-Dark-Maia'
monospace-font-name='Hack 11' # Still Hack

If anyone wants to change this back to default, complete the following

  1. Edit the File 99_manjaro-settings.gschema.override
sudoedit /usr/share/glib-2.0/schemas/99_manjaro-settings.gschema.override
  1. Find the org.gnome.Terminal.Legacy.Profile and change the font parts back to default
[org.gnome.Terminal.Legacy.Profile]
background-color='rgb(69,70,73)'
use-theme-colors=false
use-system-font=false
font='Hack 11' # change this back to 'Hack'
foreground-color='rgb(220,233,235)'
background-color='rgb(27,34,36)'
palette=['rgb(46,52,54)', 'rgb(204,0,0)', 'rgb(78,154,6)', 'rgb(196,160,0)', 'rgb(52,101,164)', 'rgb(117,80,123)', 'rgb(6,152,154)', 'rgb(211,215,207)', 'rgb(85,87,83)', 'rgb(239,41,41)', 'rgb(138,226,52)', 'rgb(252,233,79)', 'rgb(114,159,207)', 'rgb(173,127,168)', 'rgb(52,226,226)', 'rgb(238,238,236)']
rewrap-on-resize=true
visible-name='manjaro'
  1. Compile the schemas
sudo glib-compile-schemas /usr/share/glib-2.0/schemas

:exclamation:This might be overridden with the next update of the gnome-settings.

Might also concern:

Hello,

Install nerd-fonts-noto-sans-mono and probably manjaro-gnome-assets packages and see if the issue persists.

Hi @bogdancovaciu,

nerd-fonts-noto-sans-mono was automatically installed with manjaro-gnome-assets, so the font is working fine on my system.

I just wanted to mention that this was changed, and how to change it back - in case someone else is having the same issue.

Gnome-terminal --> Einstellungen --> Profile -> Text: Benutzerdefinierte Schrift Häkchen wegmachen
Gnome terminal -> Settings -> Profiles -> Text: Remove user-defined font tick

Hi @GaVenga,

natürlich kann man das auch so lösen, aber es wurde das “Default” Profile geändert in gnome-schema.

Dies hat die Auswirkung, dass jedes neu angelegte gnome-terminal Profil die Font “NotoSansMono NerdFont” vor-ausgewählt hat, bzw. alte, bereits bestehende, Profile geändert werden.

Ich wollte nur anmerken dass das eventuell mehrere User betrifft und ein user customizing im besten Fall nicht überschrieben werden sollte.

Ich verstehe…

bogdancovaciu kanns lösen.?

If you prefer another font, it is better to change it directly in your user settings and not care about the defaults. User settings are not overridden on update, but the defaults are. Also, it easier to change the user settings and it doesn’t require recompiling the gschema. Just right click gnome-terminal and go to the settings.

The change in defaults was made because some of our default terminal apps (ranger) use icon fonts by default, and those were somewhat broken with the hack font.

3 Likes

Oh, ok.

Thanks for the info :slightly_smiling_face:

Much better Thanks!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.