Gnome terminal wrong width after update

My Gnome terminal has, out of nowhere, become about twice as wide as usual, with all characters and the spacing being really wide. This seems to have happened after an update to manjaro-gnome-settings, but I’m not sure if this was what caused it. Has anyone else experienced a similar issue, or does anyone know how to fix this? Thanks in advance

Hello, yes I had the same problem 3 hours ago. Solved by changing the profile in the terminal, as e.g. the police was removed.

this doesn’t seem to do the trick for me. I tried changing the profile, but that just changes the colours and nothing else.

In my case the default font of the profile was ‘none’, so I changed to DejaVu and it seemed to go back to normality.

2 Likes

Seems that new version of settings package got accidentally pushed to stable without the necessary assets. The new font we use is nerd font noto sans mono. It has better font icons than the previous one.

EDIT: fixed now, the updated assets package now pulls the correct font also in stable after the next update.

2 Likes

Hi,
thanks for the quick fix.

I’m still having this issue.

Updating the assets fails on my machine since it fails to resolve a dependency for gnome-arcmenu.

warning: cannot resolve "gnome-shell-extension-arcmenu", a dependency of "manjaro-gnome-assets"

My locally installed version of gnome-arcmenu:
~ » yay -Q | grep arc
gnome-shell-extension-arc-menu 1:48+Stable-1

Note the dash in my locally installed package.

Searching for the package wanted by the assets yields no results.

1 Like

I am having the same issue:

warning: cannot resolve "gnome-shell-extension-arcmenu", a dependency of "manjaro-gnome-assets"
:: The following package cannot be upgraded due to unresolvable dependencies:
      manjaro-gnome-assets

:: Do you want to skip the above package for this upgrade? [y/N] 

I do not know what I should select as an answer here!

1 Like

The dependency problem is fixed now. Just update the system when mirror updates, and it should go through without errors.

2 Likes

Hi,
I just checked with a mirror that has already synced and can confirm that the fix is working for me.

Thanks again for the quick help.

The problem is with the manjaro-gnome-settings package. I just downgraded with pacman -U and the terminal went back to normal. As @Chrysostomus, says, the issue should be resolved when the mirrors re-sync.

Disabling the custom font was already enough for me.

Also see Gnome-settings update 20200929-2 -> 20201023-2 changed default terminal font.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.