Gnome Not Booting

Hi, so ever since i tried manjaro I have always wanted to use the gnome version. However, whenever i try to install specifically the gnome version and reboot, it just lands on a black screen and just shows “Starting arch Version…”. I always have to press alt + f1 and alt + f2 to get into it. Experienced the same issue on endeavour os Gnome. Any idea why this is happening?. (I have an nvidia card but I choose to use the open source drivers)

Welcome to the forum!

Please take a look at the thread below. Please update your post with your hardware information.

Hello @Zingy :wink:

Looks like the timing issue. 2 possible solutions:

Do what now? What version? Arch is not Manjaro; Manjaro is not Arch. What did you install?

Sorry it’s been a long time since I’ve tried to install manjaro gnome. It just came to my mind now and that’s all I remember of it.

Can this be fixed in a future update?

Well I am not the person who could fix it. Maybe @philm could say more?

As I see it affects mostly systems which boots very fast and where the gpu switches slow to graphical mode. Can’t confirm that, since i have had never that problem, but i guess it affects most systems with amd gpus, so it is not general problem. No idea where to report that. Is it GDM or the driver or is it the hardware?

At least there is a workaround for letting GDM wait more time.

@Zingy Could you post your system information?

inxi -Fazy

Well I’m not actually using Manjaro Gnome rn but here is my system info. Maybe it helps

  Kernel: 5.12.10-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-linux 
  root=UUID=e0d45db4-4476-4e78-8f84-8b73a1f723b9 rw quiet loglevel=3 
  Desktop: KDE Plasma 5.22.0 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: EndeavourOS base: Arch Linux 
  Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-ec1xxx v: N/A 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: HP model: 87B2 v: 31.21 serial: <filter> UEFI: AMI v: F.20 
  date: 11/04/2020 
  ID-1: BAT0 charge: 44.7 Wh (91.6%) condition: 48.8/48.8 Wh (100.0%) 
  volts: 12.1 min: 11.6 model: Hewlett-Packard Primary type: Li-ion 
  serial: N/A status: Discharging cycles: 439 
  Device-1: hidpp_battery_0 
  model: Logitech G304 Lightspeed Wireless Gaming Mouse serial: <filter> 
  charge: 100% (should be ignored) rechargeable: yes status: Discharging 
  Info: 6-Core model: AMD Ryzen 5 4600H with Radeon Graphics bits: 64 
  type: MT MCP arch: Zen 2 family: 17 (23) model-id: 60 (96) stepping: 1 
  microcode: 8600106 cache: L2: 3 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 71894 
  Speed: 1397 MHz min/max: 1400/3000 MHz boost: enabled Core speeds (MHz): 
  1: 1397 2: 1397 3: 1397 4: 1397 5: 1397 6: 1397 7: 1397 8: 1397 9: 1397 
  10: 1397 11: 1397 12: 1397 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, 
  STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] driver: nouveau 
  v: kernel bus-ID: 01:00.0 chip-ID: 10de:1f95 class-ID: 0300 
  Device-2: AMD Renoir vendor: Hewlett-Packard driver: amdgpu v: kernel 
  bus-ID: 05:00.0 chip-ID: 1002:1636 class-ID: 0300 
  Device-3: Luxvisions Innotech Limited HP TrueVision HD Camera type: USB 
  driver: uvcvideo bus-ID: 3-3:3 chip-ID: 30c9:0013 class-ID: 0e02 
  serial: <filter> 
  Display: x11 server: 1.20.11 compositor: kwin_x11 driver: 
  loaded: amdgpu,ati,modesetting unloaded: fbdev,vesa alternate: nouveau,nv 
  resolution: <missing: xdpyinfo> 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
  Device-1: NVIDIA driver: snd_hda_intel v: kernel bus-ID: 01:00.1 
  chip-ID: 10de:10fa class-ID: 0403 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor 
  vendor: Hewlett-Packard driver: N/A 
  alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus-ID: 05:00.5 
  chip-ID: 1022:15e2 class-ID: 0480 
  Device-3: AMD Family 17h HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus-ID: 05:00.6 chip-ID: 1022:15e3 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.12.10-arch1-1 running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.30 running: no 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel modules: r8168 port: e000 
  bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200 
  IF: eno1 state: down mac: <filter> 
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: e000 
  bus-ID: 03:00.0 chip-ID: 8086:2723 class-ID: 0280 
  IF: wlan0 state: up mac: <filter> 
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-4:2 
  chip-ID: 8087:0029 class-ID: e001 
  Report: This feature requires one of these tools: hciconfig/bt-adapter 
  Local Storage: total: 476.94 GiB used: 18.64 GiB (3.9%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital 
  model: PC SN530 SDBPNPZ-512G-1006 size: 476.94 GiB block-size: 
  physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD 
  serial: <filter> rev: HPS2 scheme: GPT 
  ID-1: / raw-size: 100 GiB size: 97.87 GiB (97.87%) used: 18.57 GiB (19.0%) 
  fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5 
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) 
  used: 79.3 MiB (31.0%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 35.5 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  GPU: device: amdgpu temp: 34.0 C device: nouveau temp: N/A 
  Processes: 286 Uptime: 11h 35m wakeups: 13 Memory: 7.2 GiB 
  used: 2.95 GiB (40.9%) Init: systemd v: 248 tool: systemctl Compilers: 
  gcc: 11.1.0 Packages: 1124 pacman: 1120 lib: 257 flatpak: 4 Shell: Zsh 
  v: 5.8 running-in: konsole inxi: 3.3.03

And again AMD GPU :see_no_evil:

I don’t run into this issue with kde plasma on manjaro or endeavor. Very weird. Seems that sddm fixed the issue

This behaviour happens due to the fact that your hardware has dual GPUs and GDM sometimes starts before kernel DRM has the graphic drivers ready.

On Manjaro Gnome, I’d recommend doing Early KMS as explained in the Arch Wiki.

You would need to do this just for one of the GPUs, tipically for the integrated one.

For example, if your integrated GPU is the AMD, you need to add amdgpu to the modules line in the file /etc/mkinitcpio.conf


Then, you need to regenerate your initramfs with the mkinitcpio script:

sudo mkinitcpio -P

Be aware that this setting should persist across updates, unless there is an update to the mkinitcpio package and you overwrite your configuration with the .pacnew file coming along the update.

Again, this is just my suggestion. Hope that helps!

1 Like

I had the same issue of endeavour os gnome (with gnome 40) as well. I will try to install it again soon and I will try this method and I’ll let you know what happens. Thanks!

Also just remembered something. When I install opensuse tumbleweed gnome, I do not face this issue. Seems distro specific.

Nope, it is version specific, always. Different Distros could use different versions and even use different patches.

Oh ok, seems that whatever opensuse does works