Gnome-next, testers needed

In my noob view, seems like it is…hehe…but want I wanted to ask, I want to try Gnome 40 fully. And can I later easily switch from unstable to testing/stable or need clean install ?

Of course you can switch. See Switching Branches - Manjaro

1 Like

Latest unstable build is Release Release 202105050257 · manjaro-gnome/download · GitHub ?

Yes, but if you have an existing installation just switch branches. No need to reinstall from an ISO.

1 Like

I was on Elementary os , that is why I flashed it clean.
No issues with installation of latest Gnome Manjaro.

all went smooth. and damn, I like Manjaro. gnome looks beautiful on it. before I tried Fedora, OpenSuse but Manjaro has the best polished Gnome 40 :slight_smile: good work devs

1 Like

Layout switcher is supported ? It is not in minimal build ,so maybe that is the reason

I tried it… Seems it is not ready yet :slight_smile:

1 Like

Dont know is this a bug or no , but I will report :slight_smile:

As you can see, I have dark theme, but Manjaro settings is still white , and description is barely visible

Manjaro settings is a Qt application if I remember correctly, while your dark theme in Gnome is GTK.

For Qt apps in Gnome you have to use Kvantum themes.


You don’t have to, however it is an option that’s set as default in /etc/environment.

Since @brtza is using Adwaita, the best way is to not use QT_STYLE_OVERRIDE at all and let QGnomePlatform / AdwaitaQt do it’s magic. Just comment out this line and reboot:


Thanks, now it looks better :slight_smile:

I don’t want to be the bearer of not so good news, but I’m afraid there is still an undesirable behaviour with layouts switcher.

Whenever you’re switching from the Tiling layout to any other layout (I tested switching to the Manjaro and Gnome layouts though) the keyboard input stops working for me. I had to click Apply and then Reload desktop to get the keyboard input back up.

That does not happen switching among layouts other than Tiling. Just clicking Apply gets the job done and there is no need to Reload the desktop.

Note that I’m using wayland with open source video drivers (i915 modesetting + noveau).

I’m my opinion, I’m OK doing these 2 clicks to ensure proper layout switching. It might be not clear for everyone though.

Yep, this is exactly why there is the reload desktop button. With sweeping changes to enabled extensions, this always a possibility. Switching from material-shell to other layouts has always caused some kind of issues, they just vary from release to release. Nothing we can do about it, though it might eventually go away in a few years as material-shell gets developed. We could reload shell automatically, but it is unnecessary in most cases, and very distruptive on wayland, so I thought it best to leave the use of that button to user discretion.

1 Like

I installed Manjaro unstable with gnome-next on a vm.
It looks very modern, stable and usable.

but I found some minor issues:

In the Dack to Dock Extension:
The Icon Size Limit is acting weird.

If Location Services disabled:
click gnome-maps->Go to current location
In the Dialog the option Location Settings does nothing.

If Location Services disabled:
gnome-weather stuck on loading screen.


I don’t know if it’s still relevant for you, but:
according to Manjaro - Branch Compare Gnome 40 is available on Unstable.

If you talk that icons are small by default in the dock, you must check that the option “Fixed icon size: scroll to reveal others icons” is enabled. It solve the problem.

Hi, thanks for that info, but yes, I know that. Using it from unstable for longer period :slight_smile:

Manjaro development iso 202105310502 Live usb:

  • Manjaro Gnome layout switcher issues:

Switching Unity → Manjaro = Not OK.
Switching Titling → Manjaro = Not OK

Manjaro Legacy, Gnome, Traditional → Manjaro = OK but desktop icons stay after switching traditional to Manjaro.

Manjaro → Manjaro Legacy, Gnome, Traditional, Unity, Titling = OK.

Manjaro Legacy, Gnome, Traditional, Unity, Titling without Manjaro = OK.

2 solutions: 1. Remove Unity and Titling layouts. 2. Keep Unity and Titling layouts but Manjaro is greyed when Unity or Titling layout are enabled.

I will make more tests tomorrow and I will see if I’ve got the same problem when Manjaro Gnome-next is installed on HD.


Can you tell more about “Not OK”? Does the reload desktop button solve the situation?

Yeah it’s kinda complicated to design for. On one hand, desktop icons are really needed for the traditional and unity layout. On the other hand, we have a separate switch for desktop icons on the second page of the layout switcher, and the other layouts try to respect what the user has chosen there. So, the result is kinda inconsistent design.

Thank you for testing!

Would it be feasible to add a caption or something to layouts switcher to give a hint to the users so they reload the desktop if they find issues after switching?.

Something like this:

Hint: Click on the Reload Desktop button if you encounter issues after switching