Gnome login screen not working on Intel GPU

Around a week ago I started having a problem with one of my Manjaro laptops where the login screen became unusable. The central widget with the username doesn’t appear, no clicks seem to work, but the clock widget is working. I can SSH into the system.

I have a couple of laptops with the same Manjaro and Gnome config. Only the one with an Intel GPU is having this problem, two with Nvidia are fine.

I can’t pinpoint which upgrade broke it. I tried downgrading gdm, gnome-shell, and mkinitcpio (these were updated recently). It may actually be the dbus-daemon’s fault, but I didn’t downgrade that, since downgrading that may be too problematic.

Any suggestions as to what might be the cause and how to fix it?

On 6.6 kernel, the journal is spammed with these warning messages:

sty 25 21:11:24 lemur /usr/lib/gdm-wayland-session[5269]: dbus-daemon[5269]: [session uid=120 pid=5269] The maximum number of pending replies for ":1.3" (uid=120 pid=5282 comm="/usr/bin/gnome-shell") has been reached (max_replies_per_connection=50000)

On kernel 5.15 a different warning message is spammed:

sty 25 18:44:14 lemur gnome-shell[3460]: Attempting to call back into JSAPI during the sweeping phase of GC. This is most likely caused by not destroying a Clutter actor or Gtk+ widget with ::destroy signals connected, but can also be caused by using the destroy(), dispose(), or remove() vfuncs. Because it would crash the application, it has been blocked and the JS callback not invoked.
                                         The offending signal was g-properties-changed on GDBusProxy 0x560ae4b481a0.
                                         == Stack trace for context 0x560ae2bd50c0 ==
                                         #0   560ae2c9c0b8 i   resource:///org/gnome/shell/ui/init.js:21 (3ed696c70ba0 @ 48)

On that kernel the gnome-shell is doing a coredump.

inxi --full --admin --filter --width output for the affected laptop:

  Kernel: 6.6.10-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: initrd=\deaaf6ad665c40d881a9ebd980b3a4b1\6.6.10-1-MANJARO\microcode-intel-ucode.img
    root=/dev/mapper/priv_systems-manjaro rw rootflags=subvol=@
    apparmor=1 security=apparmor udev.log_priority=3
  Console: pty pts/0 DM: GDM v: 45.0.1 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: System76 product: Lemur Pro v: lemp11
    serial: <superuser required> Chassis: type: 9 serial: <superuser required>
  Mobo: System76 model: Lemur Pro v: lemp11 serial: <superuser required>
    UEFI: coreboot v: 2023-09-08_42bf7a6 date: 09/08/2023
  ID-1: BAT0 charge: 49.4 Wh (70.0%) condition: 70.6/73.9 Wh (95.5%) volts: 7.5
    min: 7.7 model: Notebook BAT type: Li-ion serial: <filter>
    status: discharging cycles: 149
  Info: model: 12th Gen Intel Core i7-1255U bits: 64 type: MST AMCP
    arch: Alder Lake level: v3 note: check built: 2021+
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 4
    microcode: 0x430
  Topology: cpus: 1x cores: 10 mt: 2 tpc: 2 st: 8 threads: 12 smt: enabled
    cache: L1: 928 KiB desc: d-8x32 KiB, 2x48 KiB; i-2x32 KiB, 8x64 KiB
    L2: 6.5 MiB desc: 2x1.2 MiB, 2x2 MiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 2232 high: 4100 min/max: 400/4700:3500 scaling:
    driver: intel_pstate governor: powersave cores: 1: 4100 2: 3999 3: 3999
    4: 4049 5: 400 6: 2110 7: 2212 8: 2837 9: 400 10: 400 11: 1881 12: 400
    bogomips: 62688
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB: conditional,
    RSB filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Alder Lake-UP3 GT2 [Iris Xe Graphics] vendor: CLEVO/KAPOK
    driver: i915 v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+
    ports: active: none off: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, HDMI-A-1
    bus-ID: 00:02.0 chip-ID: 8086:46a8 class-ID: 0300
  Device-2: Bison BisonCam NB Pro driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-7:2 chip-ID: 5986:214c
    class-ID: 0e02 serial: <filter>
  Display: server: v: with: Xwayland v: 23.2.3
    compositor: gnome-shell driver: X: loaded: modesetting alternate: fbdev,vesa
    dri: iris gpu: i915 tty: 212x23
  Monitor-1: eDP-1 model: ChiMei InnoLux 0x1408 built: 2019 res: 1920x1080
    dpi: 158 gamma: 1.2 size: 309x173mm (12.17x6.81") diag: 354mm (13.9")
    ratio: 16:9 modes: 1920x1080
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast surfaceless: drv: iris inactive: gbm,wayland,x11
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: mesa v: 23.3.3-manjaro1.1
    note: console (EGL sourced) renderer: Mesa Intel Graphics (ADL GT2),
    llvmpipe (LLVM 16.0.6 256 bits)
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: CLEVO/KAPOK
    driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
    bus-ID: 00:1f.3 chip-ID: 8086:51c8 class-ID: 0403
  API: ALSA v: k6.6.10-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: JACK v: 1.9.22 status: off tools: N/A
  Server-3: PipeWire v: 1.0.0 status: off with: wireplumber status: active
    tools: pw-cli,wpctl
  Server-4: PulseAudio v: 16.1 status: off with: pulseaudio-alsa type: plugin
    tools: pacat,pactl
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  IF-ID-1: br-53919a9e03e2 state: down mac: <filter>
  IF-ID-2: br-b8cdac03077b state: down mac: <filter>
  IF-ID-3: docker0 state: down mac: <filter>
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:3 chip-ID: 8087:0026
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.2
    lmp-v: 11 status: discoverable: no pairing: no class-ID: 10c
  Local Storage: total: 1.82 TiB used: 756.42 GiB (40.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 2TB
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 5B2QGXA7 temp: 28.9 C
    scheme: GPT
  ID-1: / raw-size: 1.18 TiB size: 1.18 TiB (100.00%) used: 755.94 GiB (62.7%)
    fs: btrfs dev: /dev/dm-2 maj-min: 254:2 mapped: priv_systems-manjaro
  ID-2: /home raw-size: 1.18 TiB size: 1.18 TiB (100.00%)
    used: 755.94 GiB (62.7%) fs: btrfs dev: /dev/dm-2 maj-min: 254:2
    mapped: priv_systems-manjaro
  ID-3: /var/log raw-size: 1.18 TiB size: 1.18 TiB (100.00%)
    used: 755.94 GiB (62.7%) fs: btrfs dev: /dev/dm-2 maj-min: 254:2
    mapped: priv_systems-manjaro
  Alert: No swap data was found.
  System Temperatures: cpu: 77.0 C mobo: N/A
  Fan Speeds (rpm): cpu: 4968
  Processes: 298 Uptime: 29m wakeups: 0 Memory: total: 40 GiB note: est.
  available: 39.02 GiB used: 2.61 GiB (6.7%) Init: systemd v: 255
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: 2276 pm: pacman pkgs: 2271 libs: 525 tools: gnome-software,pamac
  pm: flatpak pkgs: 5 Shell: Zsh v: 5.9 running-in: pty pts/0 inxi: 3.3.31

Maybe these bugs are related:

Also, my problem looks similar to the one described in Strange behaviour after GNOME 45 update

The login screen is part of Gnome shell.

Thus if you have an incompatible extension - this may break your login.

One method of troubleshooting is

  • login using TTY
  • disable all extensions using the command line
  • login and activate the extensions one by one until it breaks

Or only enable extensions which is in the Manjaro Linux repo.

1 Like

Thanks. I’ve tried doing that (gsettings set disable-user-extensions true) but it didn’t work. I also tried forcing Wayland and X11 (two tries) by setting WaylandEnable = true/false in /etc/gdm/custom.conf.

The good news is my problem went away. I booted the machine to check if I really have disabled the extensions, and the login screen just worked. I had another weird issue with the filesystem after that - a hang on ls /, supposedly something to do with the mount points. But after another reboot everything about the system was fine from what I can tell.

On the previous boot before the miraculous recovery I upgraded these packages (with pamac upgrade):

bibata-cursor-theme (2.0.5-1 -> 2.0.6-1)
cryptsetup (2.6.1-3.4 -> 2.6.1-3.5)
brave-browser (1.61.120-1 -> 1.62.156-1)
chromium (120.0.6099.224-1 -> 121.0.6167.85-1)
discord (0.0.41-1 -> 0.0.42-1)
firefox (121.0.1-1 -> 122.0-1)
inxi ( ->
manjaro-pacnew-checker (0.5.4-1 -> 0.5.4-2)
mhwd-db (0.6.5-28 -> 0.6.5-29)
mhwd (0.6.5-28 -> 0.6.5-29)
onlyoffice-desktopeditors (7.5.1-1 -> 8.0.0-1)
ventoy (1.0.96-1 -> 1.0.97-1)

That recreated the initrd files, but I already did that a couple of times before without any effect. I have no idea why these packages would affect Gnome, but I sure am glad that it’s working fine again.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.