Gnome desktop theme on various apps displaying incorrectly

On various apps, Thunderbird for instance, or even Leafpad (but not Firefox) have some kind of corruption going on around the borders. This behavior started about one month ago with an update, on two seperate Manjaro Gnome installations (both my main computer and laptop) So I do not think this is a localised issue. Changing desktop theme using Tweaks does not seem to help. I am currently using Dark mode, and Matcha-dark-azul.

Here is a picture, look around the edges to see the strange graphics:

I tried uploading a picture, but the forum said “An error occurred: Sorry, you can’t embed media items in a post.” ? (I guess someone will need to allow me to upload pictures otherwise nobody will have any idea what I’m talking about?)

Anyway, not that it’s important but the Thunderbird version is 102.13.0 (It doesn’t matter what version it is, as it’s a theming issue) Leafpad is version 0.8.19. Manjaro kernel is: Linux 6.1.31-2-MANJARO. Using X11 and Nvidia proprietary drivers.

ps - I tried to submit a bug report on Gitlab, but the manjaro Gitlab is super confusing! I couldn’t find anywhere to submit a bug report! But I managed to submit a bug report to Gnome’s gitlab without any issue! Here it is for reference, they told me it’s a Manjaro issue: Err, OK I tried to include a link but the forum told me I cannot include links.

If its your theme then its your theme.
What are you using?
Does everything work with another?
A quick test can also be to create a new user and check if everything works there… if it does then you know it is your user configuration.

Image uploading and some other posting activities are restricted to new/inactive users.

If you dont know how to use gitlab then you dont know how to use gitlab…
And it may be a bit early for that, no? How do you know its a bug?

Please see this link for how to provide (and format) information:


I did what you said and created a new user, the problem goes away with a new user. So it is something to do with my account. Is there a way I can ‘refresh’ my user account to default settings? (I am not using any custom themes, just default Manjaro themes)

I can upload a photo now:

Here is my system information as requested:

  Kernel: 6.1.31-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=b8a8d7f3-14ce-48db-9c12-15b123506a43 rw quiet
    resume=UUID=22a397a9-0a30-4725-b1de-080e2e0be288 udev.log_priority=3
  Desktop: GNOME v: 44.1 tk: GTK v: 3.24.37 wm: gnome-shell dm: GDM v: 44.1
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: Gigabyte model: Z97N-WIFI v: x.x
    serial: <superuser required> UEFI: American Megatrends v: F7 date: 09/18/2015
  Info: model: Intel Core i7-4790 bits: 64 type: MT MCP arch: Haswell
    gen: core 4 level: v3 note: check built: 2013-15 process: Intel 22nm
    family: 6 model-id: 0x3C (60) stepping: 3 microcode: 0x28
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 3589 high: 4002 min/max: 800/4000 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 3987 2: 3962 3: 4000
    4: 3998 5: 4002 6: 800 7: 3977 8: 3987 bogomips: 57626
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics
    vendor: Gigabyte driver: i915 v: kernel arch: Gen-7.5 process: Intel 22nm
    built: 2013 ports: active: none empty: HDMI-A-1, HDMI-A-2, HDMI-A-3, VGA-1
    bus-ID: 00:02.0 chip-ID: 8086:0412 class-ID: 0300
  Device-2: NVIDIA GP104 [GeForce GTX 1070] driver: nvidia v: 530.41.03
    alternate: nouveau,nvidia_drm non-free: 530.xx+
    status: current (as of 2023-05) arch: Pascal code: GP10x process: TSMC 16nm
    built: 2016-21 pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.0
    chip-ID: 10de:1b81 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
    compositor: gnome-shell driver: X: loaded: modesetting,nvidia
    alternate: fbdev,nouveau,nv,vesa dri: crocus gpu: i915,nvidia
    display-ID: :1 screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.65x15.00")
    s-diag: 777mm (30.58")
  Monitor-1: DP-4 res: 2560x1440 dpi: 109 size: 598x336mm (23.54x13.23")
    diag: 686mm (27.01") modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 530.41.03 renderer: NVIDIA GeForce GTX
    1070/PCIe/SSE2 direct-render: Yes
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
    driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:0c0c
    class-ID: 0403
  Device-2: Intel 9 Series Family HD Audio vendor: Gigabyte 9
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8ca0
    class-ID: 0403
  Device-3: NVIDIA GP104 High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:10f0 class-ID: 0403
  API: ALSA v: k6.1.31-2-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off
    tools: jack_control,jack_mixer,qjackctl
  Server-2: PipeWire v: 0.3.70 status: active with: 1: pipewire-media-session
    status: active 2: pipewire-alsa type: plugin tools: pw-cat,pw-cli
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-jack
    type: module tools: pacat,pactl
  Device-1: Intel Ethernet I217-V vendor: Gigabyte driver: e1000e v: kernel
    port: f080 bus-ID: 00:19.0 chip-ID: 8086:153b class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Qualcomm Atheros AR8161 Gigabit Ethernet vendor: Gigabyte
    driver: alx v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000
    bus-ID: 03:00.0 chip-ID: 1969:1091 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  Device-3: Intel Wireless 7260 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:08b1 class-ID: 0280
  IF: wlp4s0 state: down mac: <filter>
  Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-11:3 chip-ID: 8087:07dc
    class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Local Storage: total: 4.09 TiB used: 730.88 GiB (17.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: SDSSDX240GG25
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: R201 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: A-Data model: SP900 size: 238.47 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD
    serial: <filter> fw-rev: 7b scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: HGST (Hitachi) model: HUS726040ALE610
    size: 3.64 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: TD05 scheme: GPT
  ID-1: / raw-size: 214.47 GiB size: 214.37 GiB (99.95%)
    used: 70.16 GiB (32.7%) fs: xfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda3 maj-min: 8:3
  System Temperatures: cpu: 35.0 C mobo: N/A gpu: nvidia temp: 38 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 27%
  Processes: 285 Uptime: 11m wakeups: 0 Memory: available: 15.46 GiB
  used: 2.95 GiB (19.1%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7 Packages: 1807
  pm: pacman pkgs: 1799 libs: 477 tools: gnome-software,pamac pm: flatpak
  pkgs: 8 Shell: Zsh v: 5.9 running-in: kgx inxi: 3.3.27```

Problem has been fixed - Pamac seemed to be broken and wasn’t updating the system correctly. I did an upgrade through the terminal using ‘sudo pacman -Syu’ - upon reboot all was fixed.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.