Gnome 46 update brings display problems

After the last update to Gnome 46 I have a lot of display problems. The thumbnails does not display. Some text does not appear for example in Settings windows or other dialogs. I’m not able to find errors in logs. Here are some problem examples:

Perhaps try resetting your thumbnail cache.

Close Files (aka Nautilus) and completely exit with:

nautilus -q

Remove the thumbnail cache:

rm -rf ~/.cache/thumbnails/

Open Files again and see if that helped.

1 Like

No it did not change anything.

Perhaps you’re using an older, incompatible theme or have leftovers in ~/.config/gtk-4.0/?

Eww. Looks like a ghost sucked up all your themes. Have you tried x11? Maybe create a new account and see if the new account has the same issues.

1 Like

I have the same behavior with a freshly created account. For GTK 4.0 I have the following:

ls ~/.config/gtk-4.0
gtk.css  servers

is empty in my default installation

It’s perhaps best to log out of the session and go to a TTY.
From there, remove ~/.cache and also the contents of that ~/.config/gtk-4.0 directory

rm -rf ~/.cache
mkdir ~/backup
mv ~/.config/gtk-4.0/* ~/backup

I tried that but still the same issues persist. The only visible change is that my favorite folders in Nautilus are removed.

I can’t tell you what the issue may be - I personally don’t have any issues.
If it is the same with a new user account, the only thing I can think of is that something is missing - since all the screenshots are without text, I’d guess it is some font that may have gotten uninstalled for whatever reason.
But that is just a guess.

The only way I can come up with to check for that is to personally look at the pacman log of the latest update.

tac /var/log/pacman.log | less
or, maybe better:
tac /var/log/pacman.log | grep removed | less

will let you scroll through it, beginning with the most recent entry (backwards)

Thank you for the pointer. I looked at it but nothing obvious came up.

Well, if you say so … :grinning:

sudo pacman -Syu noto-fonts
is that installed?

That is the default font - as I saw after having installed dconf-editor and looking for font settings.

But that is as far as I will and can keep on speculating here.

Yes it was installed:

:: Synchronising package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
warning: noto-fonts-1:24.5.1-1 is up to date -- reinstalling
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (1) noto-fonts-1:24.5.1-1

Reinstalling did not helped.

of course not


cannot be true(!) - the community repo does not exist anymore and has not been there for more than one year.

It appears you have not properly dealt with .pacnew files
in particular

How I could solve that ?

I don’t know and I will not keep on speculating.
The forum has got a search function … although google works better when you look for Manjaro specific results, IMO.

Ok I solved that:

:: Synchronising package databases...
 core is up to date
 extra is up to date
 multilib is up to date
warning: noto-fonts-1:24.5.1-1 is up to date -- reinstalling

Still the original problem remains.

Maybe try to go back to a previous system snapshot with TimeShift if you created some. Then retry the update and watch what happens, maybe something went wrong during update.

No I did not created a TimeShift.

If you’re going to reformat (which is what I would do) I strongly suggest you to use BTRFS instead of EXT4 as your file system. With BTRFS and Timeshift you will be able to easily do automagic backups instantly everytime you update, install or set a time. Takes almost no space and you can even access the backups right from the grub boot menu so you can restore back instantly every time something goes funky.

If you don’t want to reformat yet ask for the ‘ban hammer’ terminal command

That’s what I’m going to do. Thank you for the advice.