Glibc thread hijack

Hello, I don’t understand the solution. Why isn’t glibc 2.36-2 available in the repos, and how to get access to the unstable ones ? Where is the actual solution to this problem, and how to use it ?

It is.

Search how to switch branches.

If you don’t understand it then you should probably just wait. You’ll get it when you’ll get it.

1 Like

Honestly, I’d really prefer an answer rather than a condescending list of comments. I’m not a tech, I’m only asking for an explanation (within the Manjaro community, rather than some hazardous reddit post).

And you got it. 3 to be exact:

  • Strit’s is pretty self explanatory.

  • My first one, reiterated: You can install packages manually from any mirror, any branch with pacman -U https://some_mirror.bla/stable/core/blabla/some_package.pkg.tar.zst

  • My second one: Search how to switch branches.

Install a beginner, non-rolling distro then.

Again with the contempt. Thank you for punishing me for asking for help, that really is making interacting with the community an engaging experience, not making me regret quitting windows and enduring the mockery of my gamer friends for switching to linux.

  1. From what I understand, I am in [stable], so glibc 2.36-2 does not appear in pamac. I have read about the flatpak workaround, but I have also understood that a program running in a sandbox could not use my dGPU (unless I am mistaking it for Snaps ? It’s a bit confusing).

  2. I understand from your explanation that it is possible to fetch glibc 2.36-2 and only it from unstable/testing repos, which seems better to me than switching my entire system to “unstable” and such. What I don’t understand is how to find the address to use to launch the pacman -U opération, such as referred to here.

  3. Sorry, I was led to believe that Manjaro was user-friendly, as advertised on the website’s frontpage, but, please, butter me up with the most contempt you can come with, that is certainly helping and not making this conversation absolutely toxic. Choosing to despise me over helping surely is a quicker fix to a problem which I’m sure I am sharing with a lot of other users looking for solutions as well. Honestly, are you having a bad day and making me pay for it or what ?

Can anybody else help, please ? I would like to avoid jumping back to windows. I really like Manjaro.

…the search function is magic:

…of course you can switch to a different local mirror.

Thank you, I understand that I can switch my repos to another branch, but I wish not to convert my entire system to Testing or Unstable.

What I am looking for is how to install only glibc 2.36-2, as others have done. I really just want to install THAT fix only.

It is user-friendly. But that doesn’t mean it’s for complete beginners and I don’t care what they advertise it as.

Do you realize that every single day there is few people like you wanting whole explanation of basic things that have been explained ad nauseam? And for that reason there exist countless of how-tos, wiki posts and whatnot.
You need to put some work in if you want to be satisfied in a long term, ie. have a working system. But you just want to skip all of it and just have it all on a platter.

There is a good reason I’m not just giving you commands to copy/paste. It’s a bad practice to just install random packages from other branches without knowing the implications. It might work this time, but it might break your system the next, especially with such essential packages like glibc.

No, I’m like this every day. :smiley: (Had a great day actually. Hope you did too.)

I understand you may have perceived the answers you received that way, however that is not how they were presented to you. They were straightforward and to the point. Please be humble and understanding. You came here for help and answers and you have received both.

It is more user-friendly than Arch. If one does not know what Arch is, one may have unrealistic expectations.

No, you cannot “fetch” it from either of those repos and expect everything to work on the stable branch.
glibc is the GNU C Library. Many things depend on it.

As already mentioned, one must switch to testing or unstable and update all packages. One can always switch back to the stable branch later. Think of each branch as a separate version of Manjaro.

1 Like

OH FFS, this is a bad faith festival.

BUT, thank you so much, Yochanan, for providing an actual answer : I MUST switch the entire system to Testing so that I can install the fix, THEN revert to Stable, and every tip about installing only glibc 2.36-2 on a Stable system is a lie.

NOW I can do my research on my own and fix this ■■■■■■■■■■■■

Thank you.

Ok headbanger, people try to push you friendly, but with insistence in the right direction, but you know better…well:

  • For advanced users (not recommended by us): patched glibc and lib32-glibc are available here . They remove the commit that broke EAC.

…the rest is a snip with two fingers… you’re so smart.

Fixed it.

Once I was told the proper way to do it (it’s mandatory to switch to Testing through a set of Terminal commands, then upgrade the problematic packages, AND THERE ARE NO OTHER SOLUTION), I just did it.

That’s all it took. A useful answer.
Now preparing a post for the people who, like me, are not computer engineers and need explanations, not contempt.

moderatorion begin


moderatorion end

Careful : this solution is deemed risky for your system and is not advised by the community.

This post is only intended to help Manjaro users (I don’t know how it would work for other systems). As most of you know, the latest update of the glibc package broke the Easy Anti-Cheat support on Steam, keeping you from playing games such as Elder Ring and Multiversus.

At the moment of writing, two solutions exist (three, actually : you can wait for the fix to be pushed your way, but you may not have the time nor the patience for that).
Like me, you may not be an engineer fully understanding the linux system, so let me help you with that while avoiding the confusion of interacting with people who’ll just tell you to “git gud” at linux and leave you in the dark.

  1. The first solution consists of installing the Flatpak version of Steam, from Pamac. Apparently, this version runs in a self-contained environment where glibc, the culprit in breaking EAC support, has not been updated to its broken version yet.

  2. The second solution, now, which helped me and – I hope – will help you, is about using a fixed version of glibc : glibc 2.36-2.

In order to do that, you need to “switch branch” to “Unstable” : in other words, to change the source of your updates to something more recent (yet that the maintainers of Manjaro are still unsure about, hence the name of that branch), so that you will get access to the version 2.36-2 of glibc.
Beware : it’s not only glibc that you’ll need to update, there is also another package called “lib32-glibc” that is mandatory for this to work.

SO, open your terminal, and copy/paste the following command by replacing [Your country] by… your country, with a capital letter (don’t keep the [brackets]). You can copy and paste this instruction in a text editor first if you want to edit it properly before execution in the terminal.

sudo pacman-mirrors --country [YOUR COUNTRY] --api --set-branch unstable --protocol https && sudo pacman -Syyu

This command will instruct your computer to set the source of your updates to the unstable branch, THEN update the whole system (the instruction is necessary, though. Don’t erase it).

It may not be a good idea, but I didn’t update the entire system when prompted to do so. I just wanted to update glibc, so I pressed N to refuse the global update. The safe version of this is to update everything when prompted to, as to avoid a problematic “partial update”.

NEXT STEP : upgrading glibc and lib32-glibc.

Use the instructions below :

sudo pacman -S glibc


sudo pacman -S lib32-glibc

NOW that it is done, you want to revert the source of your updates to the Stable branch. Use this command (don’t forget to set your country again. This command is very similar to the first one we used) :

sudo pacman-mirrors --country [YOUR COUNTRY] --api --protocols https --set-branch stable && sudo pacman -Syyu

If everything went well, the system will tell you that there is nothing to upgrade, but that the versions of glibc and lib32glibc that you are using are more recent that the ones they have in store.

And that’s normal, because you’ve just fixed it. Hurray ! :smile:

Now, reboot and enjoy your EAC games ! (DAMN YOU, EPIC)

PS : As english isn’t my native language, please signal me every mistake, so that I can correct the text.

Sounds like a recipe for future problems.

So… if I ask for a solution, I get humiliated, and if I find a solution, I get humiliated ?

I don’t know. So far, everything is working perfectly, and from what I’ve understood, this updated version of glibc only reverted the “commit” that broke the EAC support in the first place.

If everything goes haywire, I shall (and all the people who used this solution over the internet) fix it by myself, as I have been invited to so far.

It’s neither a good idea nor supported. Partial upgrades can and will cause breakage.


Partial updates are not supported under any circumstances

System Maintenance - Manjaro

1 Like

Well then, I guess I will explode (or reinstall the system if it comes to that).

If it is really problematic, I invite you to erase my posts so that people don’t suffer from my mistakes.

I don’t think switch to the unstable repo is a great idea stability wise but when does the updated glibc package come to the stable repo?

The fix you employed was already suggested in comment number six by @Strit.

You would also have been able to look that up be means of the search function.

Instead you are ranting and calling the thread toxic when that in reality is caused by your own ignorance and your wrongful expectation to get a one-stop answer you could just punch into the terminal and be done with it.

The members has nudged you in the right direction but instead of trying to understand what you are told you are getting toxic - for what ever reason …

Because doing as you did creates a partial upgrade/sync - the result is unsupported - and therefore everyone is reluctant to provide you with a one stop solution.

If you are getting other issues moving forward and your system breaking again - it will be impossible to provide any guidance as you have placed your system in an unsupported state AND you are suggesting that others do the same as well.

Your advise for those ending here - is bad advise - as applying such fix requires understanding of the implications - which you clearly did not.

I am seriously considering unlisting this thread due the toxic introduced by the thread hijacker and the unsupported solution the hijacker presents.

1 Like