Glconv_vaapi_x11 gl error: vaInitialize: unknown libva error

Hi there, I have a fresh new reinstallation of gnome manjaro, I’m a newbie to Linux, and actually, i search a lot before reinstalling manjaro but I didn’t get anything from it
so my question is why when I start VLC in the terminal and drag & drop a movie on it (i think it doesn’t matter it starts with terminal or GUI, terminal just shows errors), it gives me these errors also i think the VLC sound freezing after a pause and play came from this

VLC media player 3.0.16 Vetinari (revision 3.0.13-8-g41878ff4f2)
[000055a7527cb580] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[000055a752868110] main playlist: playlist is empty
[00007fcb500064d0] gl gl: Initialized libplacebo v4.192.1 (API v192)
[00007fcb500064d0] glconv_vaapi_x11 gl error: vaInitialize: unknown libva error
libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)
[00007fcb500064d0] glconv_vaapi_drm gl error: vaInitialize: unknown libva error
libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)
[00007fcb500064d0] glconv_vaapi_drm gl error: vaInitialize: unknown libva error
[00007fcb500064d0] glconv_vaapi_drm gl error: vaInitialize: unknown libva error
[00007fcb500064d0] glconv_vaapi_drm gl error: vaInitialize: unknown libva error
[00007fcb500064d0] gl gl: Initialized libplacebo v4.192.1 (API v192)
Failed to open VDPAU backend cannot open shared object file: No such file or directory
[00007fcb500064d0] gl gl: Initialized libplacebo v4.192.1 (API v192)
QObject::~QObject: Timers cannot be stopped from another thread

because I try manjaro on VirtualBox of my windows and it worked fine and there was no freezing and also there was no errors like them

Note: my PC has an intel integrated and Nvidia graphic

1 Like

And, did you installed libvdpau-va-gl ?
What settings you use for Video output in VLC ?

Better share your system information as described here [HowTo] Provide System Information

1 Like

Thanks for your answer, yep I just installed it but nothing changed, the settings in VLC are default settings and I didn’t change anything

 inxi --admin --verbosity=7 --filter --width                  ✔ 
  Kernel: 5.15.25-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=d2a6d1cd-6083-412a-a61f-f17227f50f9e rw apparmor=1
    security=apparmor resume=UUID=387b68a0-1061-4610-a3b7-a824ab969fde
  Desktop: GNOME 41.4 tk: GTK 3.24.31 wm: gnome-shell dm: GDM 41.3
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: PRO H410M-C v: Rev 1.xx serial: <superuser required>
    UEFI: American Megatrends v: 0602 date: 04/15/2020
  Message: No system battery data found. Is one present?
  RAM: total: 15.47 GiB used: 2.73 GiB (17.7%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i7-10700 bits: 64 type: MT MCP arch: Comet Lake
    family: 6 model-id: 0xA5 (165) stepping: 5 microcode: 0xEE
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 978 high: 2684 min/max: 800/4800 scaling:
    driver: intel_pstate governor: powersave cores: 1: 2684 2: 1594 3: 800
    4: 800 5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 971 12: 800 13: 800
    14: 801 15: 800 16: 800 bogomips: 92838
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt
    cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts
    epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr
    ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ibrs_enhanced ida
    intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
    movbe mpx msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq
    pdcm pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdrand rdseed
    rdtscp rep_good sdbg sep smap smep smx ss ssbd sse sse2 sse4_1 sse4_2
    ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer
    vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CometLake-S GT2 [UHD Graphics 630] vendor: ASUSTeK
    driver: i915 v: kernel ports: active: DP-1 empty: HDMI-A-1,HDMI-A-2
    bus-ID: 00:02.0 chip-ID: 8086:9bc5 class-ID: 0300
  Device-2: NVIDIA GP108 [GeForce GT 1030] vendor: ASUSTeK driver: nvidia
    v: 510.54 alternate: nouveau,nvidia_drm pcie: gen: 1 speed: 2.5 GT/s
    lanes: 4 link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:1d01
    class-ID: 0300
  Display: x11 server: v: compositor: gnome-shell driver: X:
    loaded: modesetting,nvidia alternate: fbdev,nouveau,nv,vesa gpu: i915
    display-ID: :1 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-size: <missing: xdpyinfo>
  Monitor-1: DP-1 model: Dell SE2419H serial: <filter> built: 2019
    res: 1920x1080 hz: 60 dpi: 93 gamma: 1.2 size: 527x296mm (20.7x11.7")
    diag: 604mm (23.8") ratio: 16:9 modes: max: 1920x1080 min: 720x400
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel Comet Lake PCH-V cAVS vendor: ASUSTeK driver: snd_hda_intel
    v: kernel alternate: snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:a3f0 class-ID: 0403
  Device-2: NVIDIA GP108 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 4
    link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 10de:0fb8
    class-ID: 0403
  Sound Server-1: ALSA v: k5.15.25-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.47 running: no
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:0d55 class-ID: 0200
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 1.14 TiB used: 396.34 GiB (34.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: SSD 970 EVO Plus 250GB size: 232.89 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 2B2QEXM7 temp: 29.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD10EZEX-00WN4A0 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
    rev: 1A01 scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 107.42 GiB size: 105.18 GiB (97.91%)
    used: 11.36 GiB (10.8%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: d2a6d1cd-6083-412a-a61f-f17227f50f9e
  ID-2: /boot/efi raw-size: 1.95 GiB size: 1.95 GiB (99.80%)
    used: 288 KiB (0.0%) fs: vfat dev: /dev/sda4 maj-min: 8:4 label: NO_LABEL
    uuid: C522-62C0
  ID-3: /home raw-size: 70.32 GiB size: 68.66 GiB (97.65%)
    used: 1.17 GiB (1.7%) fs: ext4 dev: /dev/sda5 maj-min: 8:5 label: N/A
    uuid: 1558df9c-3a0e-47e9-8341-bf274fe05508
  ID-4: /run/media/mohammadali/Local Disk raw-size: 736.2 GiB
    size: 736.2 GiB (100.00%) used: 383.81 GiB (52.1%) fs: ntfs dev: /dev/sda1
    maj-min: 8:1 label: Local Disk uuid: D0929A5F929A49BC
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 15.62 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda3 maj-min: 8:3 label: N/A
    uuid: 387b68a0-1061-4610-a3b7-a824ab969fde
  ID-1: /dev/nvme0n1p1 maj-min: 259:1 size: 100 MiB fs: vfat label: N/A
    uuid: 1EFD-A621
  ID-2: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-3: /dev/nvme0n1p3 maj-min: 259:3 size: 225.44 GiB fs: ntfs label: N/A
    uuid: B80A00DE0A009C0E
  ID-4: /dev/nvme0n1p5 maj-min: 259:4 size: 499 MiB fs: ntfs label: N/A
    uuid: 1A00D80900D7EA31
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 10 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-3:2 info: Pixart Imaging Optical Mouse type: Mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s
    power: 100mA chip-ID: 093a:2510 class-ID: 0301
  Device-2: 1-4:3 info: SiGma Micro Keyboard TRACER Gamma Ivory
    type: Keyboard,HID driver: hid-generic,usbhid interfaces: 2 rev: 1.1
    speed: 1.5 Mb/s power: 98mA chip-ID: 1c4f:0002 class-ID: 0300
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 27.8 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 364 Uptime: 4m wakeups: 0 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1259 lib: 314
  Shell: Zsh v: 5.8.1 running-in: gnome-terminal inxi: 3.3.13

So you are on a desktop with dual GPU, and you connected your monitor to the iGPU not the Nvidia one … Was never my thing on desktop with iGPU and a dedicated one. I would simply turn off the iGPU from BIOS.
What i don’t get, why you have

because on my end i only see:

alternate: nouveau,nvidia_drm

and i asume is because i only have the nvidia driver installed, so i presume you installed almost all the available drivers t in the MHWD list.
mhwd -li
would show that …
video-vesa and video-linux can be removed, regardless if you want to keep the iGPU, but you cal also remove video-modesetting if you disable the iGPU from BIOS. Or might want to take a look into Hybrid graphics - ArchWiki
and also this
VLC media player - ArchWiki

Yes, type is Desktop and actually, I didn’t install anything special, as I said earlier I just reinstall manjaro and update it that’s it,
And here is mhwd li result:

mhwd -li                                                    ✔ 
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2021.12.18               false            PCI
     video-modesetting            2020.01.13                true            PCI

Warning: No installed USB configs!

and here is hardware section of manjaro-setting app

Ok, you have the “correct” drivers installed for hibrid GPU, but probably better wait to someone that has better understanding on how video-hybrid-intel-nvidia-prime works on a Desktop PC, because i don’t. Anyway, the links above should help you out a bit …

1 Like

I don’t know it can be a solution or not, but changing the audio module to alsa audio output and change its device to HDA intel PCH, ALC887-VD analog default audio device
has solved freezing of audio after pause/unpause video or sound
terminal errors still exist but freezing gone

I’ve found the solution from here

UPDATE : sound freezing really didn’t get solved, and when I connect pc to HDMI i had to change sound settings so I found another and better way that solved my problem completely
I change the kernel version from linux 515 to linux 54 from manjaro settings manger and also did reset the vlc setting to default then the problem get solved

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.