Gimp, CorelAfterShots 3

I am an avid photographer and after doing away with that horror of Windows finally and being extremely pleased with Manjaro xfce and the image editors and viewers I had at my fingertips which suited my needs fully and worked a treat. BUT, after a Manjaro xcfe update all stopped opening up my images which are normal .jpg and .NEF images. Corel AfterShots 3 and Gimp comes back with:

GIMP Message

Opening ‘/run/media/smoky/364D-D880/GuruShots/5 June 2022/_NKN2645.JPG’ failed: JPEG image plug-in could not open image.

JPEG image Message

Not a JPEG file: starts with 0xff 0xff

.jpg and .jpeg are the same thing as far as imagery go, Joint Photographers Group or Joint Photographers Experts Group and .NEF is also a standard image ending.

As for the Not a JPEG file: starts with 0xff 0xff - none of the images have 0xff 0xff in their name. its very frustrating, I have over 1000 images now backing up to manipulate.

It doesn’t have anything to do with the filename, but rather with the identifying “magic bytes” at the start of the file.

Unlike Microsoft Windows, which identifies a file as being of a certain type based upon the filename suffix, UNIX systems look at the contents of the file to be able to identify the file type, and more specifically, they look at the first couple of bytes in the file, called “the magic bytes”.

Graphical file managers don’t always follow through on this, and as such, it may happen that they misidentify a file of being of a certain type because of the filename suffix.

You also mention Corel AfterShots, which is (to the best of my knowledge) not GNU/Linux software, and even if you did indeed find a version of it that runs on GNU/Linux, then this will not be UNIX-native software, but rather just a recompiled version of its Windows sibling. As such, it won’t be using the UNIX-native manner of identifying a file based upon its “magic bytes”.

If you want to know what type of file you’re dealing with, then there exists the command file — it’s part of the coreutils package and thus it’s installed by default… :arrow_down:

file /path/to/the/file

An example: :arrow_down:

[aragorn] >  file ~/Pictures/Vehicles/Lamborghini\ Huracán/Lamborghini\ Huracan\ Tecnica\ 01.jpeg
/home/aragorn/Pictures/Vehicles/Lamborghini Huracán/Lamborghini Huracan Tecnica 01.jpeg: JPEG image data, Exif standard: [TIFF image data, little-endian, direntries=8, orientation=upper-left, xresolution=110, yresolution=118, resolutionunit=2, software=ACDSee Pro 10, datetime=2022:04:12 15:30:39], baseline, precision 8, 1920x1080, components 3

More information can be found in the manual… :arrow_down:

man file
1 Like

Thanks for all that information, but the file /path/to/the/file doesn’t open up anything but angst with an error message. And I hope not to be too abrupt, none of what is in your explanation helps me have these programs working again, as it was an upgrade to Manjaro that caused them to not work anymore.

I’ve even used the command line to delete the files that don’t work, restart the computer and install them again, but to no avail.

Thanks for trying to help me out, I really do appreciate the help you have given.

You’re supposed to replace that with the actual path to the filename. :stuck_out_tongue:

1 Like

It’s a little unclear what error is coming from what application. If multiple applications are complaining about the data, check the data.

But first, I did not know what Corel AfterShots 3 was, so I did:

pamac search aftershot
pamac info aftershotpro3

It is a AUR package. I clicked on the URL given in the output. It appears not to be Open Source.

I’ll only speak regarding gimp.

@Aragorn recommendation is addressing the error message which says, “not a JPEG file”. In the linux world, one way for a user to confirm that a file is a particular type is to use the file command.

file  --mime myImage.jpg

Should return something like:

myImage.jpg: image/jpeg; charset=binary

If you have imagemagick installed you can use identify.

Confirm your data (in this case your jpg file) is good.

Is the device mounted? Can you browse to the directory?

How did you open the jpg file? I’ll assume the menu item File-Open was used and that you clicked some Place in the left side and selected the jpg in the right side. Is this when the error occurred?

Start gimp from the command line, by just typing gimp. Any errors related to missing plugins?

If no error, start gimp from the command line with the file name, either change directory to the directory containing the jpg or use the absolute filename. Was the file opened successfully?

You can also drag and drop an image in gimp. Start gimp. You mentioned XFCE. I assume you are using Thunar. Open Thunar and drill-down to the location of your jpg file. Click the filename and hold and drag to gimp. Did it open successfully?

Also in Thunar, you can right-click the jpg filename and select “Open With” “GNU Image Manipulation Program”. Thunar should also show the MIME Type, if you are displaying that column (View > Configure Columns).

1 Like


Thank you for taking the time to answer my problem, it is very much appreciated. I’ll get to do what you suggested when my pain killer unfogs my mind later today. But did one of your suggestions.

Yes, I use Thunar to open up my images from, right click on the image then choose Gimp or Corel AfterShots Pro 3 but as you can see, from dragging the image into Gimp this below comes up. So further to what you have written I will do that later on.

Opening ‘/run/media/smoky/364D-D880/GuruShots/7 June 2022/_NKN2726.JPG’ failed:
JPEG image plug-in could not open image


1 Like

The reason to do the steps in post #2 is to rule out whether this is an application issue, or if your image files are corrupt / not the proper format.

You might believe this is a GIMP or AfterShots issue, when in fact it could be a red herring.

In Thunar, does the MIME Type column show, “image/jpeg”, or right-click and select Properties and see if the Kind field is “JPEG Image”.

I mentioned the command identify, which is part of ImageMagick. There is also the command display. You can get help, for example, by typing man display, or viewing them online, or going to the ImageMagick website. But simply type,

display -resize 25% myImage.jpg
identify myImage.jpg

A window will be opened showing the image. If the image is larger than the screen resolution, there will be a smaller window that allows you to pan over the image, but the -resize will make it easier to view the image and confirm the file is accessible and not corrupted.

Another test, copy the image (_NKN2726.JPG) to your $HOME directory, and open that file in Gimp.

I think we are all kind of waiting for confirmation that the files are accessible, are jpegs, and not corrupted.


Hi Winnie

Not sure what you mean with


Hi Stargazer

In Thunar the image shows a image.jpg.

When I type what you have in your reply it comes back with:

display: unable to open image ‘NKN2724.JPG’: No such file or directory @ error/blob.c/OpenBlob/3533.

But it did open up with a Wizard holding a star shaped wand in Image Magic. So, not sure what that does in my case. I’m getting to the fact that it can not be fixed and I’ll have to blow away my laptop for Windows so I can use Gimp or Corel on it.

Don’t get me wrong, all the help that has come my way I’ve just about exhausted myself doing as I’m asked, and nothing much shows up to fix the problem even if it does something after doing what I’m told to do. Hope that makes sense, still a bit groggy.


We still do not know if this is due to corrupt data or a permissions issues. You keep insisting this is a problem with GIMP or AfterShot. Why would two different applications be unable to open up simple JPEG files? Do you really believe it’s because the applications are at fault? Or perhaps because there is a different underlying issue?

Either you’re typing in the commands incorrectly or this is a more severe problem concerning data corruption or inaccessible image files.

:question: Can you even open up these images in your default image viewer by double-clicking on the files?

:question: You still haven’t used the file command correctly, as provided by @Aragorn’s post.

:question: What was the exact command you typed with display, as provided by @stargazer’s post?

We don’t know what the problem is. The commands are to help understand what the problem is before we can even consider a solution.


Opening ‘/run/media/smoky/364D-D880/GuruShots/24 June 2022 - Star Night/To be Processed/_NKN3313.JPG’ failed: JPEG image plug-in could not open image.

Not a JPEG file: starts with 0xff 0xff

Nothing opens the files, even Converseen doesn’t work on the files. Neither the .jpeg or the .NEF files can be worked on by Gimp or Corel Aftershots Pro 3. I have Manjaro XFCE on the laptop and it won’t read the files either. It’s getting very frustrating as my main pastime is photography I need to open them up in at least Gimp if not Corel Aftershots Pro 3 as well.

Coverseen converted one file I had as a .jpg to a .tiff which opens up in both Gimp and Corel, so if only I can get those images to a .tiff then they can be saved back to .jpg when worked on in those programs.

It’s looking like data corruption.

Either something improperly “converted” the image files erroneously, or your external drive is failing. (Or something else that might cause file corruption.)

Did you at any point do some sort of “batch conversion” of many of your photographs?

Do you know how to check the health of your external drive?

Are you / have you used any form of encryption?