Getting Soulseek to work

Hi there, first i tried to run the AppImage that is available on their site but it gives an SElinux library error.
Then i tried install SElinux through AUR but it failed building at the end.
How can i get this to work?

The only Soulseek client I know of with much development is Nicotine +. The recent stable version is available in the repos as nicotine+ and the development version is in the AUR as nicotine-plus-git.

1 Like

In Pamac i only see nicotine-plus. I installed it and it does not open.
Where can i find the stable version?

It turns out nicotine was renamed to nicotine+ in the repos. It still should have come up searching for nicotine, though.

What’s the output running nicotine from the terminal?

1 Like
Traceback (most recent call last):
  File "/usr/bin/nicotine", line 38, in <module>
  File "/usr/lib/python3.8/site-packages/pynicotine/", line 250, in ApplyTranslation
    locale.setlocale(locale.LC_ALL, '')
  File "/usr/lib/python3.8/", line 608, in setlocale
    return _setlocale(category, locale)
locale.Error: unsupported locale setting

What is your locale set to? You can find out by running locale from the terminal.

1 Like
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

Something is wrong with your locale settings, but I’m not sure what.

I suggest creating a new topic in #support about it.

1 Like

I have English as display language and German for formats, but it is on purpose.

The problematic part is LC_ALL has no value.

Again, this line of troubleshooting is off topic now for this thread and a new one should be created about it.

1 Like

OK, thank you for your time.

You might want to try updating nicotine-plus-git as a new commit was added that may resolve the error you had:

1 Like

I already have my locale setting correct, and nicotine running. Thanks anyway.