Getting error after update was interrupted

I experienced loadshedding while my system was updating and now when I boot, I get an error stating: (error: file ‘/boot/vlinuz-5.15-x86_64’ not found).

I scoured the internet and realised that I need to use chroot with a live USB. Luckily I always have a live manjaro USB laying around. But when I run (manjaro-chroot -a) I get a (grub-probe: error: cannot find a GRUB drive for/dev/sdb1. Check your

Assistance is greatly appreciated as I can’t afford to reinstall my distro.

  Kernel: 5.10.42-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC 
  misobasedir=manjaro misolabel=MANJARO_KDE_2107 quiet systemd.show_status=1 
  apparmor=1 security=apparmor driver=free nouveau.modeset=1 i915.modeset=1 
  Console: tty pts/2 DM: SDDM Distro: Manjaro Linux base: Arch Linux 
  Type: Portable System: Dell product: Inspiron N5050 v: N/A serial: <filter> 
  Chassis: type: 8 serial: <filter> 
  Mobo: Dell model: 01HXXJ v: A04 serial: <filter> BIOS: Dell v: A04 
  date: 03/23/2012 
  ID-1: BAT0 charge: N/A condition: N/A volts: 8.1 min: 11.1 
  model: SMP DELL 8NH5525 type: Li-ion serial: <filter> status: Unknown 
  RAM: total: 3.75 GiB used: 1.26 GiB (33.6%) 
  Array-1: capacity: 16 GiB slots: 2 EC: None max-module-size: 8 GiB 
  note: est. 
  Device-1: DIMM_A size: 4 GiB speed: 1333 MT/s type: DDR3 detail: synchronous 
  bus-width: 64 bits total: 64 bits manufacturer: SK-Hynix 
  part-no: HMT351S6CFR8C-H9 serial: <filter> 
  Device-2: DIMM_B size: No Module Installed 
  Info: Dual Core model: Intel Core i3-2350M bits: 64 type: MT MCP 
  arch: Sandy Bridge family: 6 model-id: 2A (42) stepping: 7 microcode: 2F 
  cache: L1: 64 KiB L2: 3 MiB L3: 3 MiB bogomips: 18365 
  Speed: 840 MHz min/max: 800/2300 MHz base/boost: 2300/2300 volts: 1.1 V 
  ext-clock: 100 MHz Core speeds (MHz): 1: 840 2: 860 3: 861 4: 848 
  Flags: acpi aperfmperf apic arat arch_perfmon avx bts clflush cmov 
  constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept est 
  flexpriority flush_l1d fpu fxsr ht ibpb ibrs lahf_lm lm mca mce md_clear mmx 
  monitor msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pebs 
  pge pln pni popcnt pse pse36 pti pts rdtscp rep_good sep ssbd sse sse2 
  sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_deadline_timer 
  vme vmx vnmi vpid x2apic xsave xsaveopt xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
  vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0116 
  class-ID: 0300 
  Device-2: Realtek Integrated Webcam type: USB driver: uvcvideo 
  bus-ID: 1-1.5:6 chip-ID: 0bda:58c0 class-ID: 0e02 serial: <filter> 
  Display: server: 1.20.11 compositor: kwin_x11 driver: loaded: intel 
  unloaded: modesetting alternate: fbdev,vesa tty: 167x36 
  Message: Advanced graphics data unavailable in console for root. 
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
  vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 
  chip-ID: 8086:1c20 class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.42-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.30 running: no 
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell 
  driver: r8169 v: kernel port: e000 bus-ID: 05:00.0 chip-ID: 10ec:8136 
  class-ID: 0200 
  IF: enp5s0 state: down mac: <filter> 
  Device-2: Broadcom BCM4313 802.11bgn Wireless Network Adapter vendor: Dell 
  driver: bcma-pci-bridge v: N/A modules: bcma port: e000 bus-ID: 09:00.0 
  chip-ID: 14e4:4727 class-ID: 0280 
  IF-ID-1: wlp9s0b1 state: down mac: <filter> 
  WAN IP: No WAN IP found. Connected to web? SSL issues? Try enabling dig 
  Device-1: Broadcom BCM2070 Bluetooth 2.1 + EDR type: USB driver: btusb 
  v: 0.8 bus-ID: 1-1.4:5 chip-ID: 0a5c:21bc class-ID: fe01 serial: <filter> 
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 480.2 GiB used: 0 KiB (0.0%) 
  ID-1: /dev/sda maj-min: 8:0 vendor: Hitachi model: HTS547550A9E384 
  family: HGST Travelstar 5K750 size: 465.76 GiB block-size: physical: 4096 B 
  logical: 512 B sata: 2.6 speed: 3.0 Gb/s rotation: 5400 rpm serial: <filter> 
  rev: A50A temp: 32 C scheme: MBR 
  SMART: yes state: enabled health: PASSED on: 2y 193d 7h cycles: 7814 
  read: 29.87 TiB written: 23.51 TiB Old-Age: UDMA CRC errors: 2081 
  alert: Bad cable/connection? 
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Toshiba model: TransMemory 
  size: 14.44 GiB block-size: physical: 512 B logical: 512 B serial: <filter> 
  rev: 1.00 scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  Optical-1: /dev/sr0 vendor: PLDS model: DVD+-RW DS-8A8SH rev: KD11 
  dev-links: cdrom 
  Features: speed: 24 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
  Message: No partition data found. 
  Alert: No swap data was found. 
  ID-1: /dev/sda1 maj-min: 8:1 size: 457.51 GiB fs: ext4 label: N/A 
  uuid: 4e1bdf5e-dce1-420b-beb1-1bcf593a19eb 
  ID-2: /dev/sda2 maj-min: 8:2 size: 8.25 GiB fs: swap label: N/A 
  uuid: 0106d9b6-0bab-47cf-b32f-f8e65a960d43 
  ID-3: /dev/sdb1 maj-min: 8:17 size: 2.74 GiB fs: N/A label: MANJARO_KDE_2107 
  uuid: 2021-06-14-15-33-09-00 
  ID-4: /dev/sdb2 maj-min: 8:18 size: 4 MiB fs: N/A label: MISO_EFI 
  uuid: 0ACC-C46C 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 
  speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900 
  Device-1: 1-1.1:3 
  info: Toshiba TransMemory-Mini / Kingston DataTraveler 2.0 Stick 
  type: Mass Storage driver: usb-storage interfaces: 1 rev: 2.0 
  speed: 480 Mb/s power: 200mA chip-ID: 0930:6544 class-ID: 0806 
  serial: <filter> 
  Device-2: 1-1.2:4 info: HP HP type: Mouse driver: hid-generic,usbhid 
  interfaces: 1 rev: 2.0 speed: 1.5 Mb/s power: 98mA chip-ID: 03f0:0c4a 
  class-ID: 0301 
  Device-3: 1-1.4:5 info: Broadcom BCM2070 Bluetooth 2.1 + EDR type: Bluetooth 
  driver: btusb interfaces: 4 rev: 2.0 speed: 12 Mb/s chip-ID: 0a5c:21bc 
  class-ID: fe01 serial: <filter> 
  Device-4: 1-1.5:6 info: Realtek Integrated Webcam type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA 
  chip-ID: 0bda:58c0 class-ID: 0e02 serial: <filter> 
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0 
  speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900 
  Device-1: 2-1.2:3 info: China Resource Semico USB Keyboard 
  type: Keyboard,Mouse driver: hid-generic,usbhid interfaces: 2 rev: 1.1 
  speed: 1.5 Mb/s power: 500mA chip-ID: 1a2c:4c5e class-ID: 0301 
  Device-2: 2-1.6:4 info: Realtek RTS5138 Card Reader Controller 
  type: Mass Storage driver: ums-realtek interfaces: 1 rev: 2.0 
  speed: 480 Mb/s power: 500mA chip-ID: 0bda:0138 class-ID: 0806 
  serial: <filter> 
  System Temperatures: cpu: 53.0 C mobo: 0 C 
  Fan Speeds (RPM): cpu: 3469 
  Processes: 189 Uptime: 10m wakeups: 7 Init: systemd v: 248 tool: systemctl 
  Compilers: gcc: N/A Packages: pacman: 1218 lib: 324 flatpak: 0 
  Shell: Bash (su) v: 5.1.8 running-in: tty pts/2 inxi: 3.3.04 

Welcome to Manjaro! :smiling_face_with_three_hearts:

(from live manjaro do:)

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

You can also use Maxi

to collect information about the boot process. This works,

  • when you are in your running system (with CTRL+ALT+F2).
  • And also in a live environment

Hi @One7,

I’m also from sunny South Africa, so know the pain.

Loadshedding is not a known term, outside of our country AFAIK. It’s known as rotational blackouts thorough the rest of the word, if I’m not mistaken.

Now, the problem is your kernel isn’t there. As you mentioned an update was interrupted, that would be the case. And since you have a working live environment USB thumb drive available, it makes this a lot easier. You’ll have to enter a chroot environment and reinstall the kernels. Please don’t worry about those errors that you mentioned, I also get them.

How to chroot

  1. Ensure you’ve got a relatively new ISO or at least one with an LTS kernel.

  2. Write/copy/dd the ISO to a USB thumb drive.

  3. When done, boot with the above mentioned USB thumb drive into the live environment.

  4. Once booted, open a terminal and enter the following command to enter the chroot encironment:

manjaro-chroot -a
  1. If you have more than one Linux installation, select the correct one to use from the list provided.

When done, you should now be in the chroot environment.

But, be careful, as you’re now in an actual root environment oon your computer, so any changes you make will persist after a restart.

Once in the chroot environment, complete the update:

pamac upgrade --enable-downgrade --aur --devel

Afterward, check if there is a kernel installed:

mhwd-kernel --list

If it doesn’t show one as being installed, install one. Let’s say version 5.15, the latest LTS:

mhwd-kernel --install linux515

If successful, reboot and test. Report back.

1 Like

Hey @Mirdarthos power came back, got a the newest KDE iso and remade the live USB. ran all command sequentially but no luck. I’ve provided outputs of each command below. i see one of the the command is using pamac, thought it might be useful to mention that when i was running my upgrade this morning i made use of the default pacman GUI. upgrade was almost at the end one thing i note not seeing tho’ is the message that indicates that GRUB has been upgraded/rebuilt like at the end of every upgrade.

additionally when i restart the system im now being taken straight to the memtest86 screen.

oh and i have reasons to believe that my system is on sda1 while sdb1 and sdb2 is referring to the live usb drive .

before initiating the upgrade tho’ i ran into an error indicating conflict between virtualbox-host-dkms and linux515-virtualbox-host-modules. to ensure that my upgrade took place, i remove/uninstalled virtualbox-host-dkms from the system. i’m not sure if that is relevant information to be considered

   ~  manjaro-chroot -a                                                                                                                                       ✔
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your
==> Mounting (ManjaroLinux) [/dev/sda1]
 --> mount: [/mnt]
[manjaro /]#
[manjaro /]#
[manjaro /]# pamac upgrade --enable-downgrade --aur --devel
Warning: Building packages as dynamic user
Warning: Setting build directory to /var/cache/pamac
Synchronizing package databases...
Refreshing AUR...
Checking libquicktime dependencies...
Checking libkipi dependencies...
Checking zoom dependencies...
Checking gnome-icon-theme dependencies...
Checking libstdc++5 dependencies...
Checking spotify dependencies...
Checking python-soundcard dependencies...
Checking teams dependencies...
Resolving dependencies...
Checking inter-conflicts...

To install (15):
  intltool             0.51.0-6        (Required By: gnome-icon-theme)  extra      43.4 kB
  perl-xml-sax-expat   0.51-7          (Required By: gnome-icon-theme)  community  9.0 kB
  perl-xml-simple      2.25-7          (Required By: gnome-icon-theme)  extra      58.3 kB
  icon-naming-utils    0.8.90-5        (Required By: gnome-icon-theme)  extra      9.4 kB
  libuv                1.43.0-1        (Required By: libkipi)           extra
  rhash                1.4.2-1         (Required By: libkipi)           extra
  cmake                3.23.2-1        (Required By: libkipi)           extra      10.6 MB
  extra-cmake-modules  5.95.0-1        (Required By: libkipi)           extra      558.0 kB
  doxygen              1.9.3-1         (Required By: libquicktime)      extra      4.7 MB
  faac                 1.30-3          (Required By: libquicktime)      extra
  schroedinger         1.0.11-6        (Required By: libquicktime)      extra      360.6 kB
  sndio                1.8.1-2         (Required By: libquicktime)      community  126.8 kB
  python-build         0.8.0-1         (Required By: python-soundcard)  community  230.1 kB
  python-installer     0.5.1-1         (Required By: python-soundcard)  community  234.4 kB
  python-wheel         0.37.1-1        (Required By: python-soundcard)  community  47.1 kB
To build (8):
  gnome-icon-theme     3.12.0-7        (3.12.0-6)                       AUR
  libkipi              22.04.0-1       (21.12.3-1)                      AUR
  libquicktime         1.2.4-27        (1.2.4-25)                       AUR
  libstdc++5           3.3.6-9         (3.3.6-7)                        AUR
  python-soundcard     0.4.2-1         (0.4.1-1)                        AUR
  spotify              1:  (1:                 AUR
  teams        (                 AUR
  zoom                 5.11.0-1        (                  AUR

Total download size: 17.0 MB
Total installed size: 92.8 MB

Edit build files : [e]
Apply transaction ? [e/y/N] y

Download of perl-xml-sax-expat (0.51-7) started
Download of perl-xml-sax-expat (0.51-7) finished
Download of perl-xml-simple (2.25-7) started
Download of icon-naming-utils (0.8.90-5) started
Download of icon-naming-utils (0.8.90-5) finished
Download of perl-xml-simple (2.25-7) finished
Download of schroedinger (1.0.11-6) started
Download of cmake (3.23.2-1) started
Download of schroedinger (1.0.11-6) finished
Download of extra-cmake-modules (5.95.0-1) started
Download of extra-cmake-modules (5.95.0-1) finished
Download of python-wheel (0.37.1-1) started
Download of python-wheel (0.37.1-1) finished
Download of doxygen (1.9.3-1) started
Download of doxygen (1.9.3-1) finished
Download of python-installer (0.5.1-1) started
Download of python-installer (0.5.1-1) finished
Download of sndio (1.8.1-2) started
Download of sndio (1.8.1-2) finished
Download of cmake (3.23.2-1) finished
Download of intltool (0.51.0-6) started
Download of intltool (0.51.0-6) finished
Download of python-build (0.8.0-1) started
Download of python-build (0.8.0-1) finished
Checking keyring...                                                                                                                                             [15/15]
Checking integrity...                                                                                                                                           [15/15]
Loading packages files...                                                                                                                                       [15/15]
Checking file conflicts...                                                                                                                                      [15/15]
Checking available disk space...                                                                                                                                [15/15]
Installing perl-xml-sax-expat (0.51-7)...                                                                                                                        [1/15]
Installing perl-xml-simple (2.25-7)...                                                                                                                           [2/15]
Installing icon-naming-utils (0.8.90-5)...                                                                                                                       [3/15]
Installing schroedinger (1.0.11-6)...                                                                                                                            [4/15]
Installing libuv (1.43.0-1)...                                                                                                                                   [5/15]
Installing rhash (1.4.2-1)...                                                                                                                                    [6/15]
Installing cmake (3.23.2-1)...                                                                                                                                   [7/15]
Installing extra-cmake-modules (5.95.0-1)...                                                                                                                     [8/15]
Installing python-wheel (0.37.1-1)...                                                                                                                            [9/15]
Installing doxygen (1.9.3-1)...                                                                                                                                 [10/15]
Installing python-installer (0.5.1-1)...                                                                                                                        [11/15]
Installing sndio (1.8.1-2)...                                                                                                                                   [12/15]
Installing intltool (0.51.0-6)...                                                                                                                               [13/15]
Installing faac (1.30-3)...                                                                                                                                     [14/15]
Installing python-build (0.8.0-1)...                                                                                                                            [15/15]
Running post-transaction hooks...
Reloading system manager configuration...                                                                                                                         [1/6]
  Skipped: Running in chroot.
Arming ConditionNeedsUpdate...                                                                                                                                    [2/6]
Updating the MIME type database...                                                                                                                                [3/6]
Warn about old perl modules                                                                                                                                       [4/6]
Updating icon theme caches...                                                                                                                                     [5/6]
Updating the desktop file MIME type cache...                                                                                                                      [6/6]
Cloning gnome-icon-theme build files...
System has not been booted with systemd as init system (PID 1). Can't operate.
Failed to connect to bus: Host is down
Error: Failed to build gnome-icon-theme
[manjaro /]#
[manjaro /]#
[manjaro /]# mhwd-kernel --list
available kernels:
   * linux419
   * linux510
   * linux515
   * linux517
   * linux518
   * linux519
   * linux54
   * linux515-rt
   * linux518-rt
[manjaro /]# mhwd-kernel --install linux515
Error: You can't reinstall your current kernel. Please use 'pacman -Syu' instead to update.
[manjaro /]# pacman Syu
error: no operation specified (use -h for help)
[manjaro /]# pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
 there is nothing to do
[manjaro /]#

provide output from:
mhwd-kernel -li

    ~  mhwd-kernel -li                                                                                ✔ 
Currently running: 5.15.49-1-MANJARO (linux515)
The following kernels are installed in your system:
warning: database file for 'core' does not exist (use '-Sy' to download)
warning: database file for 'extra' does not exist (use '-Sy' to download)
warning: database file for 'community' does not exist (use '-Sy' to download)
warning: database file for 'multilib' does not exist (use '-Sy' to download)
   * linux515
warning: database file for 'core' does not exist (use '-Sy' to download)
warning: database file for 'extra' does not exist (use '-Sy' to download)
warning: database file for 'community' does not exist (use '-Sy' to download)
warning: database file for 'multilib' does not exist (use '-Sy' to download)
    ~  manjaro-chroot -a                                                                              ✔ 
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your
==> Mounting (ManjaroLinux) [/dev/sda1]
 --> mount: [/mnt]
[manjaro /]# mhwd-kernel -li
Currently running: 5.15.49-1-MANJARO (linux515)
The following kernels are installed in your system:
   * linux510
   * linux515
[manjaro /]# 

rerun update first:
pacman -Syyu
if it was sucesfull reinstall kernels:
pacman -S linux510 linux515
reboot and see if you can boot into your installation

1 Like

dope. i’m currently writing this within my system.
@Mirdarthos , @brahma you’ve got no idea how much you’ve helped me today. #ilovemanjaro

We don’t edit the topic title to indicate a thread is solved on Discourse forums, I’ve reverted it. Please mark the post that solved your issue by clicking the below the post and selecting the :white_check_mark:.