General question about AMD laptops and Manjaro

It is a great machine but I can’t use it with manjaro. If anyone can help please please help.

What drivers are you using for graphics?

The free drivers, not propriety

Hi!
Did you try with the privatives? Can you change to a tty with Ctrl+alt+f3?

I’m not sure of what you are talking about. sorry :sweat_smile: can you explain it to me or tell what to try!

Hi!
When you reach de black screen, try Ctrl+alt+f3, if you can see a terminal, log in and try to install the graohics drivers

I’ll try it but do I install these drivers
lib32-mesa vulkan-radeon lib32-vulkan-radeon vulkan-icd-loader lib32-vulkan-icd-loader
Or something else?

Hi!
Run to see all availables drivers
sudo mhwd -l
Then to install it
sudo mhwd -i pci driver

I did that but still the same thing.

I do manage to boot the system with hitting ctrl+alt+f2 and after ctrl+alt+f1 and it loads the gui. But I have another issue. I close the lid and the laptop goes to suspend but when I open again the lid the screen does not turn on

If kernels are bothering you why not try others?
Make sure of updates first:

sudo pacman-mirrors -f && sudo pacman -Syyu

kernel (ex for 5.4)

sudo mhwd-kernel -i linux54

kernel 5.4 doesn’t boot at all.

What do you have to do to get the screen to turn on after you raise the lid to bring the system out of suspend??
Reason I ask this… if you have something where you are getting a bad shutdown or something is hanging when you shut the system down it might be affecting the update you have done and everything since particularly if the system is hanging and not shutting down. This is a wild guess but you might try from the terminal, su, enter your password and then the command shutdown. This should force everything to stop.Reason I mention something that seems obvious is that after a kernel update or reinstall the system MUST be shut down full stop and rebooted for various things to happen for the system to function properly. A more brutal way of doing it in most systems is simply to hold the power button down for 5 + seconds. If you are having a problem with suspend could it be that the system is suspending or hanging on shutdown and not going down completely that is causing the problems you are seeing now?? Just an idea.

The problem is that when I try to open my laptop after suspend it freezes and it may or may not show the lock screen. To explain sometimes I’m getting to the lock screen and I’m able to log in, sometimes it’s just a black screen and I have to brutally shut it down with the power button and sometimes it’s the lock screen freezed (clock shows wrong time and it doesn’t change at all) and also have to force power it off.
I’ve read that it might have to do something with smart suspension something like this that Lenovo uses. Some thinkpads got a bios update to fix this issue.
I also have an issue on booting the machine where it gets to a black screen or I’m getting two failed messages saying that failed to start load/save ness of backlight:acpi_video0 and screen backlight brightness of backlight:amdgpua_b0, and I have to hit ctrl+alt+f2 and then ctrl+alt+f1 to load the ui.

@heistp How did you manage to get this nice “HP Probook 455 G7 with Ryzen 5 4500U” up and running with manjaro. I tried many things, all with no success.

  • Manjaro 20,1 ISO doesnt work, crashes during startup
  • Architect installs but is not booting afterwards

Is the only difference Kernel 5.6? (For HW compatibility I tried Kernel 5.8 & 5.9rc)
Would be pleased to hear from you

Hi!
With manjaro 20.1, did it show you any errors? What did you try? Did you try to flash the iso with other application?
With architect, did you try to reinstall grub after the install? You have the grub-rescue option in the menu

Hi @visone,
nor errors during installation wth Architect (which performs basically fine).
GRUB is working fine as well: Windows starts no problem and performs like a charm, Manjaro shows the usual “drive/partition data” in the first line and then goes black. I assume just after graphic is initialized. It’s not possible to interact anymore (no other TTY etc.). The Architect is as well only starting through with GRUB parameter “nomodeset”, w/o that it hangs already starting Architect.

If you are interested in "my story"have a look here:
https://forum.manjaro.org/t/impossible-installation-on-hp-455-g7-amd-renoir-4500u/26755

In the meantime the rootcause was identified as a noncompliant BIOS setting (maybe due to BIOS update). Manjaro 20.1 performs excellent, as well in a Win 10 dualboot environment.

Sorry I didn’t notice your question earlier.

When I initially installed, I used the GNOME 20.0 iso, but by now I’ve upgraded to 20.1.2. I had no troubles with the 5.6 kernel booting, using the stock firmware. I was glad to find recently that the 5.8 and 5.9 series kernels have a fix (I think to amdgpu) so that the gdm login screen comes up without a problem at boot, without having to first switch to a text console and back. I’m running 5.9 at this point and am happy with it.

Anyway, I’m glad it sounds like it worked out for you.