GeForce NOW video slow-motion on Chromium and Google Chrome

The video on the Chrome OS client of GeForce NOW go into slow-motion after some time (it may happens after some seconds or minutes with the game opened), the audio continues to play as if the video was not in slow-motion (with this, I can relate that the controls continue to be sent without problems). During this slow-motion, all CPU threads are over 50% in use, as I can check in htop. If I pause the game and wait the CPU threads usage reach around 20% of use and return to game, the slow-motion stops. I tested on Chromium and Google Chrome (AUR).

P.S.: I use VPN to open the game, but I disable when the game starts (and I tested stay with VPN during the game).
P.S. 2: I tested it on Chrome on Windows 10 and I didn’t have this problem.

System:
  Kernel: 5.8.16-2-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=bc25527c-e1e8-4753-a400-02ce7f4fe30b rw quiet apparmor=1 
  security=apparmor resume=UUID=00e25de2-5851-4013-a934-22c04453383f 
  udev.log_priority=3 
  Desktop: GNOME 3.36.6 tk: GTK 3.24.23 wm: gnome-shell dm: GDM 3.36.3 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Acer product: Aspire E1-571 v: V2.21 serial: <filter> 
  Chassis: Insyde Corp. type: 10 v: 2.21 serial: <filter> 
  Mobo: Acer model: EA50_HC_CR v: Type2 - Board Version serial: <filter> 
  UEFI: Insyde v: 2.21 date: 12/16/2013 
CPU:
  Topology: Dual Core model: Intel Core i5-3230M bits: 64 type: MT MCP 
  arch: Ivy Bridge family: 6 model-id: 3A (58) stepping: 9 microcode: 21 
  L2 cache: 3072 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20761 
  Speed: 1257 MHz min/max: 1200/3200 MHz Core speeds (MHz): 1: 1197 2: 1197 
  3: 1197 4: 1197 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Vulnerable: No microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics 
  vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:0166 
  Display: x11 server: X.org 1.20.9 compositor: gnome-shell driver: intel 
  unloaded: modesetting alternate: fbdev,vesa resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) 
  v: 4.2 Mesa 20.1.8 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio 
  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
  bus ID: 00:1b.0 chip ID: 8086:1e20 
  Sound Server: ALSA v: k5.8.16-2-MANJARO 
Network:
  Device-1: Broadcom and subsidiaries NetLink BCM57785 Gigabit Ethernet PCIe 
  vendor: Acer Incorporated ALI driver: tg3 v: kernel port: 2040 
  bus ID: 02:00.0 chip ID: 14e4:16b5 
  IF: enp2s0f0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Qualcomm Atheros AR9485 Wireless Network Adapter vendor: Lite-On 
  driver: ath9k v: kernel port: 2040 bus ID: 03:00.0 chip ID: 168c:0032 
  IF: wlp3s0 state: down mac: <filter> 
  IF-ID-1: anbox0 state: down mac: <filter> 
Drives:
  Local Storage: total: 465.76 GiB used: 224.00 GiB (48.1%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Seagate model: ST500VT000-1DK142 size: 465.76 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: SDC1 scheme: GPT 
Partition:
  ID-1: / raw size: 80.47 GiB size: 78.71 GiB (97.81%) used: 43.99 GiB (55.9%) 
  fs: ext4 dev: /dev/sda7 
  ID-2: /home raw size: 210.01 GiB size: 205.71 GiB (97.95%) 
  used: 180.00 GiB (87.5%) fs: ext4 dev: /dev/sda8 
Swap:
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 2.00 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda6 
Sensors:
  System Temperatures: cpu: 68.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 267 Uptime: 3h 44m Memory: 5.70 GiB used: 2.40 GiB (42.2%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 10.0.1 Packages: 1553 
  pacman: 1499 lib: 392 flatpak: 47 snap: 7 Shell: Zsh v: 5.8 
  running in: gnome-terminal inxi: 3.1.05

It’s unclear to me what you’re running exactly in the Chrome browser, but you’re on an Intel GPU, so the best thing to do is to try out another kernel as the Intel GPU modules are built into the kernel.

As you’re on a rather old processor 4.19 and 5.4 (both LTS) come to mind first:

  • Print this page so you have it as a reference while in TTY2

  • Log off

  • Switch to TTY2 by pressing Ctrl+Alt+F2

  • Log in there

  • Execute:

    sudo mhwd-kernel --install linux419
    sudo mhwd-kernel --install linux54
    
  • to ensure grub is showing, execute:

     sudo nano --backup /etc/default/grub
    
  • Change (or add?) the following 3 lines:

    GRUB_TIMEOUT=3
    #GRUB_HIDDEN_TIMEOUT=0
    #GRUB_TIMEOUT_STYLE=hidden
    

    (3 or higher is fine, add the # before the lines above if those lines are present)

  • Ctrl+X Y Enter to save if there is anything to save

  • If you did save, execute:

     sudo update-grub
    
  • Reboot

  • Go to grub’s Advanced options

  • Choose these kernels one by one and try them out one by one and see if that helps.

:+1:

2 Likes

I tried what you said. I had already tried the GeForce NOW on Linux 5.4 before changing to Linux 5.8, I tried the 5.4 again and the 4.19. In both I had the same behavior as in the 5.8. (After reinstalling 5.4 or installing the 4.19, the 5.8 had an error to start, something related to loading kernel modules. I had to reinstall the 5.8, and now it appears to be normal.)

I’m testing the GeForce NOW, that is a cloud gaming service. Recently it added Chrome OS support, and it can now run on Linux (NVIDIA GeForce NOW adds Chromebook support, so you can run it on Linux too | GamingOnLinux).

Seems you need to get hw-accel working in your chrom*

(check the archwiki and/or some threads here)

1 Like

I will try

Maybe try with these as a test:

chromium --enable-accelerated-video --enable-accelerated-mjpeg-decode --enable-gpu-rasterization --enable-oop-rasterization --enable-quic --enable-zero-copy --enable-native-gpu-memory-buffers --ignore-gpu-blocklist --use-gl=desktop --enable-accelerated-video-decode

https://wiki.archlinux.org/index.php/Chromium#Hardware_video_acceleration

(PS - I am assuming xorg … might be important to note if using wayland)

1 Like

I noticed that libva-intel-driver was not installed.
(Wasn’t this meant to be preinstalled?)

Depends on your hardware … that ones technically older…

HD Graphics series starting from Broadwell (2014) and newer are supported by intel-media-driver.

So make sure you have one of them :wink:
(preferably the newer intel-media-driver)

https://wiki.archlinux.org/index.php/Hardware_video_acceleration

PS - in chrom* check chrome://gpu for the first section like this
[here is mine from ungoogled-chromium… notice all is good except vulkan]

Graphics Feature Status
Canvas: Hardware accelerated
Compositing: Hardware accelerated
Multiple Raster Threads: Enabled
Out-of-process Rasterization: Hardware accelerated
OpenGL: Enabled
Hardware Protected Video Decode: Hardware accelerated
Rasterization: Hardware accelerated on all pages
Skia Renderer: Enabled
Video Decode: Hardware accelerated
Vulkan: Disabled
WebGL: Hardware accelerated
WebGL2: Hardware accelerated
1 Like

I guess that means one of those flags didnt work well for you ?

Do you have one of those vaapi packages? media or otherwise?

Is this xorg or wayland ?

1 Like

I have an Ivy Bridge, so it’s one generation before Broadwell.

OK… well then you would want to have libva-intel-driver rather than intel-media-driver
So make sure thats the case.
(sorry I should have looked back up at your inxi)

1 Like

Maybe

No, I will install the libva-intel-driver now.

Xorg

No problem :slight_smile:

Graphics Feature Status

  • Canvas: Hardware accelerated
  • Flash: Hardware accelerated
  • Flash Stage3D: Hardware accelerated
  • Flash Stage3D Baseline profile: Hardware accelerated
  • Compositing: Hardware accelerated
  • Multiple Raster Threads: Enabled
  • Out-of-process Rasterization: Disabled
  • OpenGL: Enabled
  • Hardware Protected Video Decode: Unavailable
  • Rasterization: Software only. Hardware acceleration disabled
  • Skia Renderer: Enabled
  • Video Decode: Unavailable
  • Vulkan: Disabled
  • WebGL: Hardware accelerated
  • WebGL2: Hardware accelerated

Is that using the flags above ?
Once you have those packages … please try with the flags again
(I guess I should remove quic and mjpeg…)

chromium --enable-gpu-rasterization --enable-oop-rasterization --enable-zero-copy --enable-native-gpu-memory-buffers --ignore-gpu-blocklist --use-gl=desktop --enable-accelerated-video-decode

No, but with the flags, I had this:

Well please try again with the line shown above. (I removed some unnecessary options)
Reposting the same picture doesnt help :wink:

I had this (on a first moment, it’s stucked and I can’t scroll the page. But after some seconds, the page seems to respond):

Remove the options, adding them back one by one until you find out which is causing the issue.
For all we know … maybe vaapi+chrom is funky on this hardware.

1 Like