GeForce NOW video slow-motion on Chromium and Google Chrome

I have a doubt: did I have to install the 32-bits version of libva-intel-driver as well?

I dont know if it matters … but I would probably grab it too … things like steam end up wanting 32-bit stuff.

1 Like

The flag that was causing the issue was --enable-native-gpu-memory-buffers and --use-gl=desktop together (enabling these separated cause no problem).

If I remove the --enable-native-gpu-memory-buffers, I get this on chrome://gpu:

Graphics Feature Status

  • Canvas: Hardware accelerated
  • Flash: Hardware accelerated
  • Flash Stage3D: Hardware accelerated
  • Flash Stage3D Baseline profile: Hardware accelerated
  • Compositing: Hardware accelerated
  • Multiple Raster Threads: Enabled
  • Out-of-process Rasterization: Hardware accelerated
  • OpenGL: Enabled
  • Hardware Protected Video Decode: Unavailable
  • Rasterization: Hardware accelerated on all pages
  • Skia Renderer: Enabled
  • Video Decode: Unavailable
  • Vulkan: Disabled
  • WebGL: Hardware accelerated
  • WebGL2: Hardware accelerated

--enable-native-gpu-memory-buffers is broken since mesa 20.1.1 [4]

I found this in Chromium page on ArchWiki.

Hm. Hadnt noticed. Must be hardware-dependent.
But cool, good catch, keep that one off.
Now … how is performance ? Still same issues ?

Ex:

chromium --enable-gpu-rasterization --enable-oop-rasterization --enable-zero-copy --ignore-gpu-blocklist --use-gl=desktop --enable-accelerated-video-decode
1 Like

Just as before (maybe it had to support the hardware-accelerated video decoding)

Starting in Chromium 86, there will be support for VA-API when using the ANGLE gl renderer. Use the --enable-accelerated-video-decode to enable it on an intel GPU.

The Chromium version in Manjaro repositories is 85.

I guess Stable branch is…


(I am on unstable)

Though there should be an update soon I hear.

1 Like


Why are there 2 chromium packages?

Must be an error in the page … I dont see a duplicate in the repos…

Maybe we should make sure of all your updates though…

sudo pacman-mirrors -f && sudo pacman -Syyu

Then check about chromium:

pacman -Ss chromium
1 Like
$ pacman -Ss chromium
extra/chromium 85.0.4183.121-1 [instalado]
    A web browser built for speed, simplicity, and security
extra/gn-m76 0.1576.81ee1967-1
    Meta-build system that generates build files for Ninja (version shipped in
    Chromium 76; for building electron{4,5,6})
extra/qt5-webengine 5.15.1-1 (qt qt5)
    Provides support for web applications using the Chromium browser project
community/browserpass-chromium 3.7.1-1
    Chromium extension for Browserpass, browser extension for zx2c4's pass
    (password manager)
community/chromium 86.0.4240.111-2 [instalado: 85.0.4183.121-1]
    A web browser built for speed, simplicity, and security
community/chromium-bsu 0.9.16.1-1
    A fast paced top scrolling shooter
community/fcitx-mozc 2.23.2815.102-4
    Fcitx Module of A Japanese Input Method for Chromium OS, Windows, Mac and
    Linux (the Open Source Edition of Google Japanese Input)
community/passff-host 1:1.2.1-3
    PassFF native messaging host application for Firefox, Chromium, Chrome,
    Vivaldi
community/python-hstspreload 2020.7.7-2
    Chromium HSTS Preload list as a Python package

There is a chromium package in extra and community repositories.

Yeah … I just verified with another team member … its something funky about the rush overlay for 86.
(so there appears 2 in ‘community’ and ‘extra’ repos…)
How about we try to install chromium again…it should prompt you for the decision:

sudo pacman -S chromium
1 Like

It only reinstall the same version of chromium.

OK. Yeah … funny for this to come up … seems someone pushed to the wrong repo . thats why theres 2.
(chatting it up to get it fixed … was a mistake)
For now we can point you directly to the pkg:

sudo pacman -U https://mirror.netzspielplatz.de/manjaro/packages/stable/community/x86_64/chromium-86.0.4240.111-2-x86_64.pkg.tar.zst

(thats a direct link to one of our stable mirrors… pointing to the 86 file so you dont have to wait for the fix)

1 Like

Now the video decoding seems to be enabled:

Graphics Feature Status

  • Canvas: Hardware accelerated
  • Compositing: Hardware accelerated
  • Multiple Raster Threads: Enabled
  • Out-of-process Rasterization: Hardware accelerated
  • OpenGL: Enabled
  • Hardware Protected Video Decode: Hardware accelerated
  • Rasterization: Hardware accelerated on all pages
  • Skia Renderer: Enabled
  • Video Decode: Hardware accelerated
  • Vulkan: Disabled
  • WebGL: Hardware accelerated
  • WebGL2: Hardware accelerated

Great.
I guess lets see how well that works.

It seems to be solved now! Thank you so much for helping! :smiley:

Now… What do I mark as solution?

Great. yay.

Haha. I think we will go with the first reference to HW-accel ?

Oh. PS.
To make those flags permanent I suggest creating
~/.config/chromium-flags.conf

--enable-gpu-rasterization
--enable-oop-rasterization
--enable-zero-copy
--ignore-gpu-blocklist 
--enable-accelerated-video-decode
--use-gl=desktop 

(or whatever flags you need)

2 Likes