GDM no graphics after updating mesa to 10:24.0.3-2

I tried to figure out a very strange issue over the last couple of days but I was unable to find a suitable solution so my last chance is to open a new topic here.
I had the famous white “contact system administrator” screen after package updates and while there have been some very busy weeks, I simply reverted to the btrfs snapshot taken before the update and hoped for a fix in a more recent package. But that didn’t happen so I finally took my time to investigate that issue via tty and could drill down the issue to the “mesa” (non-free) package.
When I update it to any version higher than 10:24.0.2-2, I’m facing this issue.
After some researching (e.g. Thread here), I tried the following steps without success:

  1. Disable all gnome extensions from cli
  2. rm -r ~/.config/dconf
  3. reinstalled the cursor-packages (a solution for the issue described here)
  4. using another login manager (SDDM instead of GDM) - SDDM is starting, but I can’t login, its always falling back to the login screen
  5. checking if libdrm is up-to-date (version 2.4.120-1) - can’t find the source of that solution, I think it was in Manjaro or Arch forums.

And many more.

I assume that inxi -Fa gives a very helpful hint to the graphics in the Graphics section:

API: EGL v: N/A platforms: inactive: gbm,wayland,x11,surfaceless,device-0,device-1
API: OpenGL Message: GL data unavailable in console for root.
API: Vulkan Message: No Vulkan data available.

I assume that all the graphics API should not be inactive, am I right?
After a downgrade to mesa, this changes to

API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: swrast surfaceless: drv: radeonsi wayland: drv: radeonsi x11:
drv: radeonsi inactive: gbm
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.2-arch10.2
glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 6900 XT (radeonsi
navi21 LLVM 16.0.6 DRM 3.54 6.6.19-1-MANJARO) device-ID: 1002:73af
memory: 15.62 GiB unified: no display-ID: :0.0
API: Vulkan Message: No Vulkan data available.

Maybe I’m completely wrong with my assumptions but is there anyone out in the wild who may point me how to fix or repair that issue? I’m absolutely happy to share more information if needed but currently I’m lost.

Unsupported repo if I recall correct.

And you are on unstable branch?

Please return to stock Manjaro mesa - use a TTY

PKGS="$(pacman -Sl mesa-nonfree | grep 'installed' | awk '{print $2}')" && \
        sudo sed -i '/mesa-nonfree/d' /etc/pacman.conf && \
            sudo pacman -Sy $(echo ${PKGS//$'\n'/ })

Okay, I got your point. I read your announcement with mesa-nonfree a couple of months ago but forgot that it is an unsupported package. Downgrade to the official mesa package worked flawlessly and now it works as expected. Thank you very much for your help and have a beautiful sunday!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.