Fstab NAS mount fails after update

can you reach your nas per ssh ? try


It’s pretty hard for anyone to give you any advice without any more information, and relevant logs when you try to mount it.

But why CIFS version 1? Also test with a mount -t cifs or mount.cifs with the relevant options first.

Mount -t cifs returns with error code 22 (Invalid argument).
CIFS version 1 is required for this particular NAS (Buffalo Linkstation 220). That is something I discovered many years ago when I was nto able to mount initially, so it has been mounted with vers=1.0 all these years.

Yes the NAS is accessible from the network pane as smb:// and I can browse all folders. However connection is refused on ssh.

Damn SMBv1? That’s old.

I meant mount -t cifs // /mnt/ramkumarrNAS --verbose -o username=XXX,password=XXX,vers=1,etc,etc>

Just so you could try playing with different options without messing with your fstab.

What got upgraded? I’d be looking the packages like smbclient, cifs-utils firstly (and your kernel)…

With this I get a message saying “bad usage”. So I omitted the “0 0” at the end, ending with “noatime” which gives me error (22): invalid argument again

As I had already noted.

Did you create the necessary entry in your smb.conf?

    client min protocol = NT1

Hmmm… There is no smb.conf in /etc/samba. Only the folder “private”. Either my fstab entry was working all along without this file or it needed this file which has somehow been deleted recently.

You can’t copy and paste every option you have in fstab to the mount command. Especially the ones that tell it to auto-mount, FS check, etc.

man mount.cifs

You have to format the command properly first. Then you can start troubleshooting properly.

You also didn’t say what got upgraded. I guessed on the 3 most likely packages to be upgraded that would cause a CIFS mount issue.

Then I suggest you create the file - as this will instruct the smbclient it is OK to use the old unsafe protocol.

Ulp…foolish of me. Here goes - in the below line all I believe are valid options. However I get “Bad usage” as the response. Also, I can see that cifs-utils as well as smbclient were updated. The Kernel list shows that 6.2.16-1 is what is running though I don’t know how to figure out when it was updated. I can see it is not labeled “LTS”.

RR-Manjaro% sudo mount -t cifs // /mnt/ramkumarrNAS username=ramkumarr,password=xxxxxxxx,vers=1.0,uid=1000,gid=1000,iocharset=utf8,noauto,_netdev,noatime

I tried this too… did not help. The above mount command gives “Bad usage”, neither does the fstab line work.

Your mount line in fstab is not equivalent to the usage on commandline.

mount(8) — Arch manual pages

You would need to pass your options with the -o option to the mount command - otherwise you will get a bad usage response. Not all fstab options make sense when uing a manual mount.

mount -t cifs -o bla1,bla2,bla3 //ip.x.y.z /path/to/mount/point

The most oommon cause as to why users keep using fstab to mount is because the mount command does not allow for user mount.

There is other methods - like this one - which can be executed as user - no root required - supply credentials when challenged.

gio mount smb://ip.x.y.z/sharename

If you would like to explore that further there is this [root tip] [Utility Script] GIO mount samba share

Another common cause when Samba is acting up on Arch based system is AppArmor - the previously linked topic contains some info on this - although this is most relevant when sharing folders from a Manjaro system.

You need a -o before all the comma separated options.

And 6.1 is the latest LTS Manjaro kernel currently. It’s listed in Applications/Manjaro Settings under kernels through the GUI, and you can install/remove kernels there. (Or mhwd-kernel -i linux61 to install via command line.)

Yes of course I missed the -o though I read it in the manual … I’m definitely getting old. Thanks folks for being so patient with my ignorance + carelessness.
The corrected command below gives me mount error(22): Invalid argument

sudo mount -t cifs // /mnt/ramkumarrNAS -o username=ramkumarr,password=xxxxxxxx,vers=1.0,uid=1000,gid=1000,iocharset=utf8,noauto,_netdev,noatime

Thank you, I tried this and yes the share does get mounted on /run/user/1000/gvfs/smb-share...

@linux-aarhus did bring this up in his link he included, and I was replying to most of this on my phone. But I would highly recommend not using fstab for network mounts.

It’s really just creating a file with 10 lines or so, to create a systemd unit. Then just one command to start/mount it (and one to enable on startup). If other services rely on these mounts, it is fairly easy to build in that functionality too.

Another example: https://rayagainstthemachine.net/linux%20administration/systemd-automount/

The TimeOutSec and (TimeoutIdleSec for ondemand automounting) options are really handy for network mounts too.

Thanks for the links…they look straighforward enough and I should be able to set it up. But I am curious to understand why you make the above recommendation!