Fstab NAS mount fails after update

Thanks for the links…they look straighforward enough and I should be able to set it up. But I am curious to understand why you make the above recommendation!

The list is rather long… But systemd.mount units are designed for just this purpose. (Plus so much more, most of which, you won’t even use.)

Some important ones for you, I would guess would be:

  • It will slow your boot process (with your NAS down, or other whatever other issues, even appear to halt the boot process)
  • If it fails, this is a much safer way to automatically remount and handle this scenario
  • You can pick when you want it mounted during the boot process (multi-user.target is an easy choice that’s already there, and commonly used for this)
  • You make can make the service(s) that depend on this mount not start until the the mount succeeds
  • It also works the other way around, for a safer way to shutdown the services it depends on

I highly recommend mount units as well. My reasons are explained in [root tip] [How To] Use systemd to mount ANY device

Several years ago I had issues with my network mounts as it was highly troublesome and error prone to use fstab - so I investigated what could be done with systemd - which lead me to mount and automount units.

They are really simple to work with - they are easy to understand - they are easy to maintain

Some years later I wrote these topics

Thanks very much, @Molski and @linux-aarhus for the very useful inputs. Makes plenty of sense. I will go about implementing these changes for my NAS.
Cheers - Ram

I followed this set of instructions. However the unit did not start; the message advised me to run journalctl -xe and lo and behold I was back to square 1: Error 22, invalid argument.
Apparent Solution: I downgraded to the latest LTS kernel 6.1 while rebooting and it worked! My old mountpoints are back! Thank you.

Glad to hear. I gave (guessed at) the 3 most likely culprits it stopping it from working after an update. That was one of them. (I only run LTS kernels myself.) That you had to use GIO to mount it sounded really off to me. (Never used that myself).

At least you are a little more future-proofed, and made your system more error tolerant just because of all this.


I see you tackled this problem, is there really no way to update the nas to accept a higher version than 1.0 though?

I very recently had a very strange error with one of my mounts, not network, but it suddenly just broke, I could no longer execute files from it.

The solution was changing the option user to nouser (that is also included in the defaults option, maybe try with that?).
Just an idea to play around with.

From a web search it looks like Buffalo NASs now support at least 2.0. I tried with vers=2.0 and it works.