Fresh install of manjaro xfce won't update

After completing a fresh install of Manjaro XFCE it fails to update and these are some of the last words of the update…

Replace pamac-snap-plugin with extra/libpamac-snap-plugin? [Y/n] y
:: Replace pygobject-devel with extra/python-gobject? [Y/n] y
:: Replace python-dbus with extra/dbus-python? [Y/n] y
:: Replace python-dbus-common with extra/dbus-python? [Y/n] y
:: Replace python-sip with extra/python-sip4? [Y/n] y
:: Replace xdg-desktop-portal-gtk with extra/xdg-desktop-portal-gnome? [Y/n] y
resolving dependencies…
looking for conflicting packages…
error: failed to prepare transaction (could not satisfy dependencies)
:: installing lib32-libcanberra (0.30+2+gc0620e4-5) breaks dependency ‘lib32-libcanberra=0.30+2+gc0620e4-3’ required by lib32-libcanberra-gstreamer
:: installing libcanberra (0.30+2+gc0620e4-5) breaks dependency ‘libcanberra=0.30+2+gc0620e4-3’ required by libcanberra-gstreamer

How do I get Manjaro to update? It won’t update using the terminal nor the updater app.

1 Like

Take a look at the first point to fix libcanberra packages…looks like a very old iso :thinking:

1 Like

You can download the latest image of Manjaro here: Manjaro Linux - Browse /xfce/21.2.5 at

1 Like

What is pamac and how do I use it?

Yeah, I was thinking about downloading a fresh image and creating another bootable USB stick. I’ll give it a try.

I’ve been using that ISO since 2016. I thought they were good forever.

Pamac is the default package manager of Manjaro. It can be used via command line (CLI) as well.

:link: Pamac - Manjaro

1 Like

You’d be better off downloading the most recent ISO. Yours is very old and it would take less time to use the new one than update from the old one and deal with conflicts and pacnew’s.


Thanks everyone for all your help. Installing a up to date Manjaro edition fixed it. Instead of being required to update 872 packages, it’s down to a manageable 6 or 7 of them now in pamac. Hahahahahaa!

Downloading the new ISO and using RUFUS to create a bootable stick solved the problem.

Thanks again everyone!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.