Freefilesync Not Working Correctly After Arch/Manjaro Updates

Manjaro XFCE, absolutely delighted with it. Used Freefile Sync to keep my 6tb Data Disk in sync with my 6tb external Backup disc. No problem. Following the latest update the other day, thought about Timeshift so added that to the system. No problems, although I was stunned at the HUGE 19gb Timeshift folder after just one run of the backup; however next time I tried to run Freefile Sync on pressing the button to proceed the whole program, the xfce desktop and all buttons froze and unresponsive, although the cursor still functioned correctly. Is it me? Are these two programs incompatible with each other? Had no option other than to physically power down and restart the system.

Hello @dave1953 :wink:

Timeshift uses hardlinks. I guess that cause a problem with freefilesync.

Guessed there was some issue. Thanks for that. Would prefer to do without Timeshift as it only takes half an hour to rebuild the system from scratch the hard way and all data is held separately whereas I use Freefile daily to keep my backup in sync. Thanks again.

1 Like

Freefilesync Arch Linux (also affects Manjaro).

Following recent Arch updates, Freefilesync suddenly doesn’t work correctly (any version).

Set up and administered in normal manner, but as soon as the start button is pressed for the synchronisation the program freezes up and crashes the system meaning any button presses, key presses do not work; however the cursor still works fine! But only the cursor. Frustrating. Freefilesync works perfectly on any Debian based system (I’ve tried several) but will not work on any Arch based system so there appears to be ‘something’ in the latest batch of updates causing this problem.

1 Like

Which version are you using and how did you install it?

From the AUR. Tried 11.4 and 11.10 and upgraded later to 11.11. All the same behaviour. Please be aware they all worked fine about a week or so ago, so it is a very recent Arch update causing the issue. Also - not kernel related. Whichever kernel I’ve tried causes same effect 5.11, 5.12, zen, LTS. I’m 68 and retired so have time to try various potential solutions.

Can’t confirm this behavior.

FFS 11.10 (from the AUR) together with the most recent Manjaro update works as good as always for me.

Thanks. Second person to tell me no problems, must be isolated to my particular rig. Ryzen 4300ge, Gigabyte B450m Gaming, 970 Evo nvme, 6tb storage hdd. Tried 3 kernels, so wonder if there is an issue with the 4300ge being pretty new.

Cannot get ffs to work correctly using Manjaro xfce. Have now installed a debian based xfce system (Mint) with no problems whatsoever. Whilst using Mint have loaded a USB live disk with Manjaro xfce and ffs exhibited exactly the same behaviour. Likewise pure Arch and Archman which I also tried. So my only conclusion is it’s something to do with Arch combined with AMD 4300ge as I never had any issues with my ryzen 1300x and nvidia gt710 before I upgraded.

Interesting. Since I’ve upgraded my processor I cannot get Freefilesync to work correctly. Others have tried with no problems on their systems but mine won’t run Freefilesync correctly. I’ve tried pure Arch xfce, Manjaro xfce with the same result. The program runs but when the ‘start’ button is clicked the whole system crashes with no acknowledgement from any keypress or mouse click; however the cursor still moves across the screen normally. The Freefilesync program works absolutely perfectly on any Debian based system under the same conditions as long as I have at least kernel 5.10 installed as a minimum. So - the only conclusion I can draw is there is “something” in Arch or Arch based systems that doesn’t like my setup whereas Debian based systems have no problems with the same setup. Before I recently upgraded the processor everything was fine on ANY installation. Intriguing.

Now - Ryzen 3 4300ge processor with Gigabyte B450m gaming board, very latest BIOS, Samsung 970evo nvme for system, 6tb spinner for data.

Previously Ryzen 3 1300x processor with Asus nvidia gt710 graphics card, the rest all same.

Conclusion - 4300ge + Arch causing problem?

Now here’s proof for you. Downloaded Manjaro xfce 20.2 from the Manjaro archives, loaded and ran FreefileSync latest version whilst using the live usb and - everything works absolutely perfectly, so something or another in between latest Manjaro xfce and the older 20.2 has interfered with the running of FFS. I have to assume this is something within Arch as Arch is exhibiting the same behaviour.

I just updated to Manjaro 21.0.7 and FFS 11.11 and everything still works fine in KDE Plasma.

Maybe you might want to try and test the Manjaro Plasma version to see whether your problem also appears there. If not, then at least you know that Xfce in conjunction with Manjaro/Arch might be the one to blame and not Arch in general.

Another idea is to not use the FFS AUR package, but download the installer package from the FFS website and install manually.

Thanks. I’ll try a live kde manjaro usb

Yes, I tried Manjaro KDE Plasma and for the hell of it also tried Manjaro Gnome. Both FFS installations refused to open under both D.E.'s. On loading from Terminal both reported GTK2 library missing, so loaded GTK2 library in both and FFS then opened normally; however on setting the task and pressing “Start”, both KDE and Gnome exhibited the exact same freeze up that XFCE did. So my one and only conclusion is that this is an Arch related library issue as FFS works perfectly in Debian based systems (Linux Mint XFCE, Ubuntu, PopOS etc I’ve live disked a good few of them to trial as I am 68 and retired I have time to try these options)

Yes, seems to be.

Only other thing I could think of is file system related. My sync pairs with FFS are PC drives (ext4) to NAS drives (ext4) and PC drives (ext4) to USB drives (ntfs), both without any problems.

I saw your post in the FFS forum, so hopefully there will be more help regarding this particular bug. Unfortunately I am lacking the technical expertise to know what is actually going on during the sync process.

Wish you good luck!

Thanks. My next attempt will be to downgrade the manjaro xfce kernel to LTS, which I believe is 5.10. As FFS runs perfectly on Mint xfce under (upgraded) 5.10 oem kernel, I believe this is going to be well worth a try.

Hi, did you try the FreeFileSync Flatpak? It’s what I’m using since ages and never had a problem with it.
Maybe it is worth a try if the native package doesn’t work for you.

Thanks for your suggestion

Further info - believe this is something to do with 5.12 kernel and my Ryzen 4300ge. Tried Debian SID with 5.10 kernel (LTS?), no problems. When SID automatically upgraded to 5.12 kernel FFS exhibited exactly the same behaviour as Arch & Manjaro (with the same 5.12 kernel). So the obvious solution will be to roll back the kernel until such time as a more permanent solution presents itself.

If Kernel 5.10 LTS works fine with the 4300GE then using it is for sure the best idea. I made it a habit to only use LTS kernels unless something else specifically requires me to do otherwise, so all my observations were done with Kernel 5.10, too.