Fractional Scaling in Gnome

Hello there,

I am using Manjaro on a rather small touchscreen with high resolution, therefore standard resolution is to small. 200% scaling works better, but sometimes is ridiculously large, something between 150 and 175% works well.

This is currently only possible with wayland, as far as I know. But if I enable wayland, a variety of programs, including e.g. firefox, will be blurry (not only the fonts, but I think also pictures). Is this a common problem and is there a way to fix it?

Thank you very much for your help!

(I know that I can use xrandr to “zoom out” when using X and scaled to 200%, which is what I currently do. But this causes problems, e.g. when rotating the tablet between horizontal and vertical.)

Hello,
To enable fractional scaling in GNOME on Wayland run:

gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']"

To enable fractional scaling on Xorg run:

gsettings set org.gnome.mutter experimental-features "['x11-randr-fractional-scaling']"

Mind you, this are still not tested by me, so i can’t guarantee the outcome.
In your case, you will need to run the second command, then reboot the system.

Hi!

Thank you very much for your help! I tried running the second command, but I receive the following error:

(process:3395): dconf-WARNING **: 14:01:51.156: failed to commit changes to dconf:
Error spawning command line “dbus-launch --autolaunch=bd5ff023ce404a4388ba82a92a41d180 --binary-syntax --close-stderr”:
Child process exited with code 1

(It worked for Wayland (enabled it a while back), but with Wayland I always have “blurry” or “fuzzy” (I don’t really know how to describe it better) fonts and pictures. Not in all places though, system fonts look fine for example. I would not mind switching to Wayland, if I could change that.)

If i’m not mistaken, you have to run that command while in X11 session, not from Wayland session. Aka you need to get the value of the environmental variable DBUS_SESSION_BUS_ADDRESS to be accessible when you run that command.

Oh, sorry for the misunderstanding. I’m currently on X11, just enabled Wayland for testing of fractional scaling in between. Now it’s disabled.

It seems I cannot change DBUS values at all though. I tried it the “lazy” way with dconf-editor and receive the same error…

From the arch wiki it seems we have to use the “xrandr” command.

https:// wiki. archlinux. org/ index.php/ HiDPI (Sorry apparently I cannot include links)

I have the same exact issue and have been testing several distros lately with/without wayland.

The best setup so far with impressive results have been Manjaro KDE. I am not telling you to switch but from my own very limited experience it seems to be the best working for fractional scaling and that’s out of the box. The other desktop environment that comes close would be deepin.

I am using a Matebook 13 2020 with intel GPU. I installed the default Manjaro KDE then updated.
I also installed intel-media-driver + chromium.
I enabled vaapi through chromium config file.

The result is the best so far. No screen tearing on the browser itself + I can play youtube 4k without the CPU going bonkers.

I am back to a fresh gnome install now writing this and I still can’t get fractional scaling working without the screen tearing.

I prefer gnome though but it seems to be still a no go for me at the moment.

Good luck.

Im using cinnamon with same issue with a 4k screen. I can use double hdpi or automatic ×2 scaling but enabling fractional scaling make text blurry. I got around it by increasing icon and font sizes and then scaling Firefox thunderbird etc. Not ideal but it does work

Alright, thanks for all your advice. I think I will give KDE a spin then. :wink:

xrandr is what I have been doing so far, but it is rather annoying (or I am doing it wrong), as I have to rescale every time I rotate the screen.

Any advice for Gnome is still highly appreciated.

Hi, fractional scaling on X11 Gnome requires a patched Mutter version. @Ste74 maintains the repo version which can be installed via:

sudo pacman -S mutter-x11-sc

However this version seems to be out of date.

Alternatively you can build or download/install it from my Github. Keep in mind that you are responsible to update it if you install it that way!

2 Likes

I think Firefox is blurry in Wayland when Firefox is running in Xorg or xwayland mode. Sometime over the summer, Firefox swtiched to defaulting to Wayland, but if I recall manual intervention was invovled to get it to switch in my Manjaro ARM Gnome installation. Sorry I don’t have the specific change, but hopefully that direction helps.

@pux, @damon

Thanks for your tips. I had blurry fonts not only in Firefox, but in most applications.

I switched to KDE for now for testing and it works better than expected so I guess I will stay here a bit longer. :wink: Fractional scaling is available by default, only drawback is that I have to reboot to change the scaling factor. This is a question for another part of the forum though. :smiley: