FPS went to drain after ugrading from 20 to 20.1

Good day,
As the title says, after updating to 20.1 my frame rate has gone to some pretty unplayable levels.

Specs:

  • Desktop PC with Manjaro 20.1 KDE
  • Nvidia GTX 970 using video-nvidia-450xx driver (nuveau removed)
  • Steam with some older titles like Wolfenstein Colossus as benchmark

I am not certain when the problem started manifesting itself, after the major upgrade or the kernel 5.8.6-1 (used to run 5.7.19-2). I ran into issues booting into 5.8 but that is resolved now.
I have since reinstalled nvidia driver and re-applied screen tearing fix. In desperation, I even tried to revert to a snapshot from a week back using Timeshift. Again, no change.

As a test, I decided to completely reload Manjaro 20.1 on a separate SSD drive (same system). I installed the same nvidia driver, Steam and the game and the frame rate is back to being great.

What can I check on my existing Manjaro install that is responsible for this reduced frame rate in game?
Any help is appreciated.

Have you tried installing/enabling feral gamemode incase there’s some throttling going on? Its not going to diagnose the issue but will prevent any throttling if that’s the issue

1 Like

Thanks @sawdoctor. I am not familiar with “feral gamemode”. I will read/install it and see if it improves frame rate.

It’s in the aur you can find it with the pamac gui but you need to enable it in steam launch commands or you can just use lutris to launch steam

1 Like

@sawdoctor, Very interesting, installing/enabling gamemode for that game has helped tremendously!
I feel like it is back to normal but not 100% sure just yet. First, I will try enabling gamemode on the other fresh Manjaro install where the game plays flawlessly without it.

The question is now then, what can be throttling my system?

Really glad it helped. Im really no expert in this, I’d have said it was a kernel issue but you said you have changed kernels back.

1 Like

Yes, I tried it with kernels 5.6/5.7/5.8 with no difference. I am still pretty green in the linux realm myself. Do I need to “re-build” the nvidia driver for each kernel? Hopefully, experts will shed some light.

Thanks so much for getting me thus far @sawdoctor!

If you are updating with pacman,pamac,gui then the nvidia drivers will automatically get added to any new kernel that you get. I’ve been on linux for 5 years (2 months on manjaro) and still very green myself, trying to learn more about the cli

1 Like

Strangely the gamemode is an on and off type of solution. I tried launching the game again today with gamemode on and it was again fairly laggy. :frowning:

Update, it appears to be related to the Global Theme (Sweet mars - in my case)
Somehow, this eats away my FPS

Hi, I had a similar thing happen to me with Manjaro XFCE. In my case, it was the screen compositor, I binded a key that was unused on my laptop to toggle it on/off. I don’t recommend to keep it off, specially in KDE since it has so many animations and such that would be gone without the compositor, without mentioning the screen tearing, but definitely disable it when you play games. It makes my games go from sluggish to fully playable, at the press of a button, literally. I call it my “lag switch”.

1 Like

Thanks @tralph3,
It appears to be driven by some black magic.
Normally after installing Manjaro, I do this tweak that removes most of the tearing/lag on the desktop (not all): disable most of Compositor options and lean on Nvidia to handle composition. Perhaps this is part of the problem.
That said, on a fresh Manjaro install, with above tweak, I experience no issues in the game. That is (as per my testing yesterday) until I load the Global theme. I disable the Global Theme and it is back to normal.
I tried this approach on my current Manjaro and that does not appear to make a difference. Seems like more work to be done.

Looking for keyboard shortcuts for Compositor, i stumble upon “Kwin”? Is that it?

The command I use to turn it on/off is this one:

xfconf-query -c xfwm4 -p /general/use_compositing -t bool --toggle

That’s for xfce, I doubt it will work for KDE but you can give it a shot. I usually check if it’s off by opnening a terminal and seeing if the window borders on the right side have a shadow, if yes, it’s on.