Choppy Plasma with nvidia

Hey guys,
I’ve been using Manjaro KDE for quite a while now and the desktop feels really choppy. Animations are laggy sometimes and when opening an app, the desktop starts to freeze for about 1-2 seconds. Also sometimes when trying to login after stand-by, the SDDM is just black (the mouse-cursor still shows).

Maybe someone got an idea?

My hardware: hastebin

Hi!
Change the compositor to OpenGL 3. Also you should try the propierary drivers.

Already using Nvidia-450.66 and OpenGL 3.1, still laggy :confused:

Hello,

Vould you pelase also share the output of
mhwd -li
and
cat /etc/X11/mhwd.d/nvidia.conf
Have you tried this?

Tried the steps from above of that thread, it’s a lot smoother now but still has some very slight stutters when dragging windows to the corner or opening some Qt-Applications. On my other PC with Intel-HD-Graphics everything runs perfectly. Setting “Tearing prevention (vsync)” to “Never” gives me a lot of screen tearing.

mhwd -li:
Installed PCI configs:
--------------------------------------------------------------------------------
NAME VERSION FREEDRIVER TYPE
--------------------------------------------------------------------------------
video-nvidia-450xx 2019.10.25 false PCI

cat /etc/X11/mhwd.d/nvidia.conf:

`# nvidia-settings: X configuration file generated by nvidia-settings

nvidia-settings: version 450.66

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 0 0
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “0”
EndSection

Section “Files”
EndSection

Section “InputDevice”
# generated from default
Identifier “Mouse0”
Driver “mouse”
Option “Protocol” “auto”
Option “Device” “/dev/psaux”
Option “Emulate3Buttons” “no”
Option “ZAxisMapping” “4 5”
EndSection

Section “InputDevice”
# generated from default
Identifier “Keyboard0”
Driver “kbd”
EndSection

Section “Monitor”
# HorizSync source: edid, VertRefresh source: edid
Identifier “Monitor0”
VendorName “Unknown”
ModelName “LG Electronics 32inch LG FHD”
HorizSync 30.0 - 83.0
VertRefresh 56.0 - 61.0
Option “DPMS”
EndSection

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “GeForce RTX 2080 SUPER”
Option “TripleBuffer” “On”
Option “ConnectToAcpid” “Off”
Option “metamodes” "nvidia-auto-select +0+0 {ForceFullCompositionPipeline = On}
EndSection

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24
Option “Stereo” “0”
Option “nvidiaXineramaInfoOrder” “DFP-2”
Option “metamodes” “nvidia-auto-select +0+0”
Option “SLI” “Off”
Option “MultiGPU” “Off”
Option “BaseMosaic” “off”
SubSection “Display”
Depth 24
EndSubSection
EndSection`

Look like you have the nvidia config but not the driver installed. It set in false.

The false is under the FREEDRIVER, but due to lack of formatting is hard to spot that

> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
    video-nvidia-450xx            2019.10.25               false            PCI

Now you see what i mean. :slight_smile:

@Rioluu - let me correct a few things on your config and see if that helps, plus i will ad a few other things to try. I’ll get back with something.

Edit:
Here is a corrected /etc/X11/mhwd.d/nvidia.conf to try:

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "LG Electronics"
    ModelName      "LG Electronics 32inch LG FHD"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 61.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce RTX 2080 SUPER"
    Option         "TripleBuffer"  "On"
    Option  "ConnectToAcpid"    "Off"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-2"
    Option         "metamodes" "nvidia-auto-select +0+0 {ForceCompositionPipeline=On}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "COMPOSITE" "Enable"
EndSection

 
Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

Since you added the Option "TripleBuffer" "On" in the Section "Device" then you also have to make the use of the kwin.sh file. Run from terminal:
echo "export KWIN_TRIPLE_BUFFER=1" | sudo tee /etc/profile.d/kwin.sh
Reboot and if that doesn’t help, then modify /etc/profile.d/kwin.sh to be like this:

export KWIN_TRIPLE_BUFFER=1
export __GL_YIELD=USLEEP
export __GL_MaxFramesAllowed=1

The use of metamodes can’t be in both sections of device and screen as you had it. Anyway, if you have a working system now, with that conf file, make a backup of it before using mine, so you can restore it and use the system.

A lot snappier now, thanks!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.