Fontconfig issue

Hi, from [Stable Update] 2020-10-19 on, number of users experience aliasing, fuzzy fonts, as reported from here on : [Stable Update] 2020-10-19 - Kernels, Nvidia 455, Browsers, as well as there : Firefox 82 has fuzzy fonts

Several proposals have been suggested like amending ~/.config/fontconfig/fonts.conf with lcddefault, or preset 11-lcdfilter-default.conf linking to ~/.config/fontconfig/conf.d or even creating ~/.Xresources
with a set of rules :

Xft.dpi: 90
Xft.antialias: true
Xft.hinting: true
Xft.rgba: rgb
Xft.autohint: false
Xft.hintstyle: hintslight
Xft.lcdfilter: lcddefault

all of these seem to derive from Font configuration - ArchWiki
and outcome is NOT ok :

Could this be handled so that users (as I ! ) stop fiddling with system conf that will be forgotten in one month or will conflict with something else we don’t know when ?
:slightly_smiling_face:

1 Like

That update breaks font smoothing and/or hinting on my system.

System: Kernel: 5.4.67-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: Xfce 4.14.2
Distro: Manjaro Linux
Machine: Type: Laptop System: LENOVO product: 81DM v: Lenovo ideapad 330-17IKB serial:

I’m also having a problem with font rendering. I don’t know if it’s related to yesterday’s extra security update of FreeType (which wasn’t originally in this stable update), because I only noticed it today after the FreeType update and didn’t notice it after this latest stable update.

Are you also experiencing fonts breaking only on gtk applications?
Did you find a way to fix this?

@rizuhaso @chfanzil @freggel.doe Same aliasing problem.
Enabling LCDFilter in ~/.config/fontconfig/fonts.conf with

<edit name="lcdfilter" mode="assign">
            <const>lcddefault</const>
        </edit>

Makes it a little better but far from perfect :confused:

With none

With lcddefault

(btw : belgian postal delivery app uses ubuntu font ! ^^)

1 Like

I’m curious, what did you order? :joy:

1 Like

You’re welcome !
It was a computer chair.

:face_with_hand_over_mouth:

Well, still looks bad.)
Are you on XFCE?

In the unstable update theme also suggested to remove the folder $HOME/.config/fontconfig

did not tried it on my machine yet.

Font smoothing is broken for me too, on both PC and laptop (GNOME), in some applications only (Firefox, Nautilus), and there is no $HOME/.config/fontconfig folder.

Well, it does what it says and become ugly again.

I also applied :
https://wiki.manjaro.org/index.php?title=Improve_Font_Rendering
but with a brand new *~/.Xresources, nothing changed.

@Fofry : did you try

fc-cache -f -v

and check for the fontconfig folder ?

@all : I really feel bad with this problem. This shouldn’t happen on a stable release and ought to be corrected without user trying to fiddle all over the place…

FTFY :slightly_smiling_face:

Anyway I didn’t faced the font issue; I am on Xfce

It’s not the rolling question, it’s a stable release of a desktop OS.
I can agree to care for exotic stuff when updating, I’m less comfortable to have to care for font rendering…

I’m on Xfce too.

This is ugly :

Technically, it’s the stable channel of a rolling release desktop OS. :wink:

1 Like

Operationaly, the stable channel of a rolling release desktop OS has an ugly rendering. :face_with_monocle:

Obviously I didn’t want to be disrespectful in your regards; but consider to open a discussion about this issue in the support section of the forum; you will get the attention of the Manjaro’s mainteiners :+1:

Had this font problem too. This fonts.conf solved it for me:
fontsconf
Link: Font configuration - ArchWiki

1 Like

There should be a file 11-lcdfilter-default.conf in /etc/fonts/conf.avail/

Linking it to conf.d should enable the lcd filter setting system-wide.

sudo ln -s /etc/fonts/conf.avail/11-lcdfilter-default.conf /etc/fonts/conf.d/
4 Likes


On gnome, the font aliasing just works for me…

Well.
On my system the font-manager program added conflicting configs into $HOME/.config/fontconfig/conf.d/19-DisplayProperties.conf.
This file was generated by font-manager and it had a disabled lcdfilter option.

So I made
sudo ln -s /etc/fonts/conf.avail/11-lcdfilter-default.conf /etc/fonts/conf.d/
and also I manually enabled lcdfilter in the font-manager settings.

That fixed the problem for me.

Don’t you think the preset link should be toward ~/.config/fontconfig/conf.d ?
Anyhow, I opend this thread Fontconfig issue and think it could regroup all posts here on this matter.

@The_Quantum_Alpha : happy if you feel so (your illustration is not really convincing…)