Followup: HDMI to any monitor/TV shows a blank screen, but is detected

@pobrn @Fabby

Is there anything I can do, even if it’s distro hopping?

I don’t understand why, no matter what I try, it just never enables prime sync. This thing is supposed to have a 144hz refresh rate but i only see 60 available. my EXTERNAL monitor is 240hz, and it shows that in xrandr.

Is there anything else that I can do… maybe open source drivers of some kind… cause I don’t like proprietary to begin with.

Please, we’ve gotten this far… which is further than I ever would’ve thought… and also, I remove optimus-manager now – it did absolutely no good and the configuration regarding nvidia is kinda ignorant… it’s as if configuration doesn’t get picked up or something, but it still seems to be picking up that I put one Separate screen section for each display (or, more accurately, an extended display) … so i have to wonder how i can get these settings saved and WORKING. I’m sorry but if others here have the same hardware and the same drivers with the same CRAP then why the hell wouldn’t it work on my end? it makes NO sense :frowning:

Please excuse the tantrum, I’ve just had it… I’ve tried so much it’s insane; I haven’t worked this hard in my life…

Start from scratch and reinstall and use KDE instead of cinnamon if you have the RAM available. (You never posted a full inxi --admin --verbosity=7 --filter --no-host, so can’t tell)

Ensure the monitor (and any other hardware you’re going to use) is attached to the system while you’re reinstalling.

You now know more about Manjaro and how hardware detection works, so this time you should be fine…

That’s all the last-minute, ultimate, nuke it from orbit advice I can give…

:man_shrugging:

1 Like

I posted it much earlier but I can do it again for you below.

Updated:

  Kernel: 5.9.1-1-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=80750ec8-f3b2-4e51-a921-83158f1c5165 rw "acpi_osi=Windows 2020" 
  apparmor=1 security=apparmor udev.log_priority=3 
  Desktop: Cinnamon 4.6.7 tk: GTK 3.24.23 wm: Muffin dm: LightDM 1.30.0 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Acer product: Nitro AN515-44 v: V1.02 
  serial: <filter> 
  Mobo: RO model: Stonic_RNS v: V1.02 serial: <filter> UEFI: Insyde v: 1.02 
  date: 06/16/2020 
Battery:
  ID-1: BAT1 charge: 55.4 Wh condition: 55.3/57.5 Wh (96%) volts: 17.2/15.4 
  model: LGC AP18E8M type: Li-ion serial: <filter> status: Unknown 
  Device-1: hidpp_battery_0 
  model: Logitech Wireless Illuminated Keyboard K800 serial: <filter> 
  charge: 100% (should be ignored) rechargeable: yes status: Discharging 
  Device-2: hidpp_battery_1 model: Logitech Wireless Mouse M510 
  serial: <filter> charge: 55% (should be ignored) rechargeable: yes 
  status: Discharging 
Memory:
  RAM: total: 30.80 GiB used: 4.04 GiB (13.1%) 
  Array-1: capacity: 64 GiB slots: 2 EC: None max module size: 32 GiB 
  note: est. 
  Device-1: DIMM 0 size: 16 GiB speed: 3200 MT/s type: DDR4 
  detail: synchronous unbuffered (unregistered) bus width: 64 bits 
  total: 64 bits manufacturer: Kingston part-no: KHX3200C20S4/16GX 
  serial: <filter> 
  Device-2: DIMM 0 size: 16 GiB speed: 3200 MT/s type: DDR4 
  detail: synchronous unbuffered (unregistered) bus width: 64 bits 
  total: 64 bits manufacturer: Kingston part-no: KHX3200C20S4/16GX 
  serial: <filter> 
CPU:
  Topology: 6-Core model: AMD Ryzen 5 4600H with Radeon Graphics socket: FP6 
  bits: 64 type: MT MCP arch: Zen family: 17 (23) model-id: 60 (96) 
  stepping: 1 microcode: 8600103 L1 cache: 384 KiB L2 cache: 3072 KiB 
  L3 cache: 8192 KiB bogomips: 71880 
  Speed: 1549 MHz min/max: 1400/3000 MHz base/boost: 3000/4000 
  boost: enabled volts: 1.2 V ext-clock: 100 MHz Core speeds (MHz): 1: 2209 
  2: 2122 3: 1397 4: 1397 5: 1463 6: 2373 7: 1450 8: 1715 9: 1397 10: 1397 
  11: 1397 12: 1397 
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 
  bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy 
  constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total 
  cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid 
  f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibrs ibs 
  irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe 
  msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae 
  pat pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb 
  pfthreshold pge pni popcnt pse pse36 rdpid rdpru rdrand rdseed rdt_a 
  rdtscp rep_good sep sha_ni skinit smap smca smep ssbd sse sse2 sse4_1 
  sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce topoext tsc 
  tsc_scale umip v_vmsave_vmload vgif vmcb_clean vme vmmcall wbnoinvd wdt 
  xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: NVIDIA TU117M vendor: Acer Incorporated ALI driver: nvidia 
  v: 455.28 alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1f99 
  Device-2: AMD Renoir vendor: Acer Incorporated ALI driver: amdgpu 
  v: kernel bus ID: 05:00.0 chip ID: 1002:1636 
  Device-3: Chicony HD User Facing type: USB driver: uvcvideo bus ID: 3-3:3 
  chip ID: 04f2:b64f serial: <filter> 
  Display: server: X.Org 1.20.9 driver: amdgpu,nvidia display ID: :0 
  screens: 1 
  Screen-1: 0 s-res: 3840x1093 s-dpi: 96 s-size: 1016x289mm (40.0x11.4") 
  s-diag: 1056mm (41.6") 
  Monitor-1: HDMI-0 res: 1920x1080 dpi: 90 size: 543x302mm (21.4x11.9") 
  diag: 621mm (24.5") 
  Monitor-2: eDP-1-0 res: 1920x1080 hz: 60 dpi: 142 
  size: 344x194mm (13.5x7.6") diag: 395mm (15.5") 
  OpenGL: renderer: GeForce GTX 1650/PCIe/SSE2 v: 4.6.0 NVIDIA 455.28 
  direct render: Yes 
Audio:
  Device-1: AMD Raven/Raven2/FireFlight/Renoir Audio Processor 
  vendor: Acer Incorporated ALI driver: N/A 
  alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus ID: 05:00.5 
  chip ID: 1022:15e2 
  Device-2: AMD Family 17h HD Audio vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel bus ID: 05:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.9.1-1-MANJARO 
Network:
  Device-1: Realtek vendor: Acer Incorporated ALI driver: r8169 v: kernel 
  port: 2000 bus ID: 03:00.0 chip ID: 10ec:2600 
  IF: enp3s0 state: down mac: <filter> 
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: 2000 
  bus ID: 04:00.0 chip ID: 8086:2723 
  IF: wlp4s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
Drives:
  Local Storage: total: 238.47 GiB used: 41.29 GiB (17.3%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 vendor: SK Hynix model: HFM256GDJTNI-82A0A 
  size: 238.47 GiB block size: physical: 512 B logical: 512 B 
  speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 11000C00 scheme: GPT 
  Message: No Optical or Floppy data was found. 
RAID:
  Message: No RAID data was found. 
Partition:
  ID-1: / raw size: 134.87 GiB size: 131.76 GiB (97.69%) 
  used: 41.26 GiB (31.3%) fs: ext4 block size: 4096 B dev: /dev/nvme0n1p5 
  label: N/A uuid: 80750ec8-f3b2-4e51-a921-83158f1c5165 
  ID-2: /boot/efi raw size: 100.0 MiB size: 96.0 MiB (96.00%) 
  used: 31.7 MiB (33.1%) fs: vfat block size: 512 B dev: /dev/nvme0n1p2 
  label: N/A uuid: 98DC-DD65 
Swap:
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 7.63 GiB used: 0 KiB (0.0%) 
  priority: -2 dev: /dev/nvme0n1p6 label: N/A 
  uuid: be6a964a-6b3c-48e9-8dff-4875c272f719 
Unmounted:
  ID-1: /dev/nvme0n1p1 size: 499.0 MiB fs: ntfs label: Recovery 
  uuid: C6C4DC58C4DC4BF5 
  ID-2: /dev/nvme0n1p3 size: 16.0 MiB fs: N/A label: N/A uuid: N/A 
  ID-3: /dev/nvme0n1p4 size: 95.37 GiB fs: ntfs label: N/A 
  uuid: 5E9629C396299C91 
USB:
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Device-1: 1-4:2 info: Intel AX200 Bluetooth type: Bluetooth driver: btusb 
  interfaces: 2 rev: 2.0 speed: 12 Mb/s chip ID: 8087:0029 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 
  Hub: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Device-1: 3-1:2 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID 
  driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s 
  chip ID: 046d:c52b 
  Device-2: 3-3:3 info: Chicony HD User Facing type: Video driver: uvcvideo 
  interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 04f2:b64f serial: <filter> 
  Hub: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 
Sensors:
  System Temperatures: cpu: 58.2 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  GPU: device: nvidia screen: :0.0 temp: 53 C device: amdgpu temp: 49 C 
Info:
  Processes: 348 Uptime: 10h 26m Init: systemd v: 246 Compilers: gcc: 10.2.0 
  clang: 10.0.1 Packages: pacman: 1261 lib: 339 flatpak: 0 
  Shell: Bash (sudo) v: 5.0.18 running in: gnome-terminal inxi: 3.1.05
1 Like

Yeah I’m going to try a different DE and might try starting from scratch. I think I need to get rid of Cinnamon, which might be the damn problem in the first place… I went back to the configuration someone posted awhile ago for someone with similar hardware. You were right, though… this internal display is AMD only… I was re-reading before I saw your response, but it’s possible the DE is the problem, and it seems to point to it. I could be wrong but we’ll find out. And yes I have learned enough about mhwd lol.

Thank you for your help though. You’ve been fabulous and I will be updating you on my little start from scratch journey :face_with_raised_eyebrow: lol. Alright… I’ll let you know when I’m able to do so… gonna back some stuff up. At least the rest of it works… it could be worse…

1 Like

29 days between your first post and this one. I must’ve missed it scrolling through the history…

:sweat_smile:

:joy:

Yeah, it made no difference one way or the other… usually plenty of ram, there are crashes here and there that are inevitable:

https://wiki.archlinux.org/index.php/PRIME#Discrete_card_as_primary_GPU

I’ll try… GNOME3 or MATE for my next shot. and if PRIME doesn’t work, I’ll go to KDE. There are solutions for this stuff, it seems, with KDE. But I do have a question, @Fabby or @pobrn – a quick question… Does Manjaro handle more than one DWM very well? I know it works in Ubuntu but can be a bit dangerous and lead to dependency hell. Thoughts on this? I’m… moderately “experienced” but nowhere near the knowledge that you both have.