Followup: HDMI to any monitor/TV shows a blank screen, but is detected

Well, last I checked Canonical’s prime-select script does not support AMD integrated video cards.

No hardware acceleration where? OpenGL/Vulkan? VA-API, etc. shouldn’t be affected by the choice of Xorg driver.

Oh I’m sorry I actually just meant it works but none of the Prime Synchronization changes, not hardware acceleration. I have too many tabs open, that’s my fault there, I’m sorry ;/ But I mean it seems to be just the tearing. Doesn’t seem to change… but if I boot up hybrid instead of nvidia, it works very well with screen tearing, HOWEVER… no external display/HDMI display since that’s all that is available on this anyway (HDMI for external).

Also… I really don’t care for the renoir/ati/AMD iGPU, as it’s not something I’m looking to have primarily if I have a GeForce GTX 1650. And even if other distros don’t support it… well, I’m not sure about the support anywhere else in Linux either, yet SOME, such as yourself, seem to have no issues… I don’t get it really.

Since the guy mentioned 450xx, i’m moving back up to that just to make sure it isn’t actually the solution. I’m guessing this guy had some sort of automatic configuration with nvidia proprietary. Probably anyway. Even if it was solved, he didn’t really say how.

Beyond that… I don’t know. Compositors are all I can think of now for Cinnamon… I know that the other distros have a lot of nvidia support and that manjaro likely adopts many of the things ubuntu does. Which reminds me… lots of screen flickering on external monitor but not a huge deal… just seems to cause problems with certain applications and i can’t tell whether it’s minor, major, or no issue at all. And no, no games are being played yet… that would be damn near impossible right now. I can’t even watch YouTube, really.

That’s unfortunately another problem that affects amd+nvidia configurations.

I have an intel+nvidia configuration, I use the modesetting Xorg driver. I’m pretty sure those are significant differences. When linux58-nvidia-455xx reaches the stable branch, you could try that (if you haven’t already).

I’m not sure why PRIME synchronization is not enabled. Do you see anything in dmesg or the Xorg log when you run the command?

Xorg log shows nothing significant, no. modesetting, in general, only works in nvidia mode, if i switch to hybrid it obviously, as configured, goes amdgpu unless I change it myself, which I tried when you asked.

Um… what else… haven’t done linux58-nvidia-455xx but if i can try that then i will… I don’t care if it’s stable, I mean I can just revert with tty. Kernel 5.8, 5.9 (Yes for some users that has major, major changes) but that, the 5.4 LTS doesn’t go, normal 5.4, no go… all kernels listed just now give the same result right now to me. Worst case scenario I can just set something up to make sure it’ll boot. There’s been nothing out of the ordinary with dmesg either, even when I | grep the hell out of it.


From Arch wiki on PRIME:

Black screen with GL-based compositors

Currently there are issues with GL-based compositors and PRIME offloading. While Xrender-based compositors (xcompmgr, xfwm, compton’s default backend, cairo-compmgr, and a few others) will work without issue, GL-based compositors (Mutter/muffin, Compiz, compton with GLX backend, Kwin’s OpenGL backend, etc) will initially show a black screen, as if there was no compositor running. While you can force an image to appear by resizing the offloaded window, this is not a practical solution as it will not work for things such as full screen Wine applications. This means that desktop environments such as GNOME3 and Cinnamon have issues with using PRIME offloading. <------ Yeah… I run Cinnamon.

Additionally if you are using an Intel IGP you might be able to fix the GL Compositing issue. Blah blah. I think it looks like it’s just a Cinnamon issue until I get a compositor that might, just might work if the above possibilities don’t pan out. I don’t know.

Yeah, so… my DE might be the problem… i don’t know.

Interesting, I use GNOME, but haven’t experienced these problems (however, truth be told, I haven’t really used PRIME render offload since I use an external monitor).

I also use an external monitor, and the problem doesn’t exist there… Cinnamon’s a gnome fork… GTK3 I believe… unless you meant you don’t have one? I don’t know, most do use one. The problem went from “blank/black screen with HDMI/TV” to awful screen tearing on my main display while in nvidia mode… and it’s driving me insane.

For instance… I’m in a terminal right now with it showing on the main display (more room, right?) and I’m compiling something and it’s going SO FAST that i can see it tearing. Then I do this when i switch it with optimus-manager and that doesn’t exist with the ATI Renoir. I don’t know, there’s no external when I use the Renoir. The external (HDMI) = Nvidia GTX 1650.

That’s just another thing. but I’m thinking of just going to Arch or something… maybe I’m just missing a configuration somewhere or maybe it really IS the drivers for this in particular. I’ve run out of ideas, you guys did what you could… My hope is that this thread stays open for awhile. Doesn’t have to be forever, but it’s my hope. There are a lot of troubleshooting steps here that can help so many others. I’ll live, it’s screen tearing, not screen breaking. It’s just driving me nuts because I can’t watch certain videos for my class, and I can’t stand having to do that with a laptop when i have to also work… i’m close to losing my job because of how long it’s been with this problem. I can’t be using Windows, literally… it just doesn’t work with a lot of what I do within linux and my shell isn’t gonna be displaying any GUI unless I feel like setting up something like NoMachines. I was able to do an insecure VNC session, but it wasn’t even worth it.

I MUST use Linux in order to keep my job and then to do everything ELSE, I’d simply use a Virtual Machine and use Windows that way, and this is including my niece’s virtual school crap. I can’t be running a VM when my own drivers are an issue for just X.Org itself.

EDIT: Also. SEE: The all new OutputSink feature aka reverse PRIME - Linux - NVIDIA Developer Forums <---- source for below… and basically the above POSTS too.

The compositing lag you observe when you only have a Reverse PRIME display is caused by a limitation in X Present, it can’t sync to PRIME sinks. It works with NVIDIA-based PRIME Sync (non-reverse) because the NVIDIA driver implements its own mechanism to allow vsync, but when the NVIDIA GPU is the sink, as in Reverse PRIME, we have to rely on what the server supports. There is some work being done upstream on this: . Once that is implemented, some further work will be required on the NVIDIA side to support it. Unfortunately, the only current workaround is to have a non-Reverse PRIME display set as the primary in RandR, or to disable vsync.

@pobrn @Fabby

Is there anything I can do, even if it’s distro hopping?

I don’t understand why, no matter what I try, it just never enables prime sync. This thing is supposed to have a 144hz refresh rate but i only see 60 available. my EXTERNAL monitor is 240hz, and it shows that in xrandr.

Is there anything else that I can do… maybe open source drivers of some kind… cause I don’t like proprietary to begin with.

Please, we’ve gotten this far… which is further than I ever would’ve thought… and also, I remove optimus-manager now – it did absolutely no good and the configuration regarding nvidia is kinda ignorant… it’s as if configuration doesn’t get picked up or something, but it still seems to be picking up that I put one Separate screen section for each display (or, more accurately, an extended display) … so i have to wonder how i can get these settings saved and WORKING. I’m sorry but if others here have the same hardware and the same drivers with the same CRAP then why the hell wouldn’t it work on my end? it makes NO sense :frowning:

Please excuse the tantrum, I’ve just had it… I’ve tried so much it’s insane; I haven’t worked this hard in my life…

Start from scratch and reinstall and use KDE instead of cinnamon if you have the RAM available. (You never posted a full inxi --admin --verbosity=7 --filter --no-host, so can’t tell)

Ensure the monitor (and any other hardware you’re going to use) is attached to the system while you’re reinstalling.

You now know more about Manjaro and how hardware detection works, so this time you should be fine…

That’s all the last-minute, ultimate, nuke it from orbit advice I can give…


1 Like

I posted it much earlier but I can do it again for you below.


  Kernel: 5.9.1-1-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=80750ec8-f3b2-4e51-a921-83158f1c5165 rw "acpi_osi=Windows 2020" 
  apparmor=1 security=apparmor udev.log_priority=3 
  Desktop: Cinnamon 4.6.7 tk: GTK 3.24.23 wm: Muffin dm: LightDM 1.30.0 
  Distro: Manjaro Linux 
  Type: Laptop System: Acer product: Nitro AN515-44 v: V1.02 
  serial: <filter> 
  Mobo: RO model: Stonic_RNS v: V1.02 serial: <filter> UEFI: Insyde v: 1.02 
  date: 06/16/2020 
  ID-1: BAT1 charge: 55.4 Wh condition: 55.3/57.5 Wh (96%) volts: 17.2/15.4 
  model: LGC AP18E8M type: Li-ion serial: <filter> status: Unknown 
  Device-1: hidpp_battery_0 
  model: Logitech Wireless Illuminated Keyboard K800 serial: <filter> 
  charge: 100% (should be ignored) rechargeable: yes status: Discharging 
  Device-2: hidpp_battery_1 model: Logitech Wireless Mouse M510 
  serial: <filter> charge: 55% (should be ignored) rechargeable: yes 
  status: Discharging 
  RAM: total: 30.80 GiB used: 4.04 GiB (13.1%) 
  Array-1: capacity: 64 GiB slots: 2 EC: None max module size: 32 GiB 
  note: est. 
  Device-1: DIMM 0 size: 16 GiB speed: 3200 MT/s type: DDR4 
  detail: synchronous unbuffered (unregistered) bus width: 64 bits 
  total: 64 bits manufacturer: Kingston part-no: KHX3200C20S4/16GX 
  serial: <filter> 
  Device-2: DIMM 0 size: 16 GiB speed: 3200 MT/s type: DDR4 
  detail: synchronous unbuffered (unregistered) bus width: 64 bits 
  total: 64 bits manufacturer: Kingston part-no: KHX3200C20S4/16GX 
  serial: <filter> 
  Topology: 6-Core model: AMD Ryzen 5 4600H with Radeon Graphics socket: FP6 
  bits: 64 type: MT MCP arch: Zen family: 17 (23) model-id: 60 (96) 
  stepping: 1 microcode: 8600103 L1 cache: 384 KiB L2 cache: 3072 KiB 
  L3 cache: 8192 KiB bogomips: 71880 
  Speed: 1549 MHz min/max: 1400/3000 MHz base/boost: 3000/4000 
  boost: enabled volts: 1.2 V ext-clock: 100 MHz Core speeds (MHz): 1: 2209 
  2: 2122 3: 1397 4: 1397 5: 1463 6: 2373 7: 1450 8: 1715 9: 1397 10: 1397 
  11: 1397 12: 1397 
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 
  bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy 
  constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total 
  cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid 
  f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibrs ibs 
  irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe 
  msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae 
  pat pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb 
  pfthreshold pge pni popcnt pse pse36 rdpid rdpru rdrand rdseed rdt_a 
  rdtscp rep_good sep sha_ni skinit smap smca smep ssbd sse sse2 sse4_1 
  sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce topoext tsc 
  tsc_scale umip v_vmsave_vmload vgif vmcb_clean vme vmmcall wbnoinvd wdt 
  xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA TU117M vendor: Acer Incorporated ALI driver: nvidia 
  v: 455.28 alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1f99 
  Device-2: AMD Renoir vendor: Acer Incorporated ALI driver: amdgpu 
  v: kernel bus ID: 05:00.0 chip ID: 1002:1636 
  Device-3: Chicony HD User Facing type: USB driver: uvcvideo bus ID: 3-3:3 
  chip ID: 04f2:b64f serial: <filter> 
  Display: server: X.Org 1.20.9 driver: amdgpu,nvidia display ID: :0 
  screens: 1 
  Screen-1: 0 s-res: 3840x1093 s-dpi: 96 s-size: 1016x289mm (40.0x11.4") 
  s-diag: 1056mm (41.6") 
  Monitor-1: HDMI-0 res: 1920x1080 dpi: 90 size: 543x302mm (21.4x11.9") 
  diag: 621mm (24.5") 
  Monitor-2: eDP-1-0 res: 1920x1080 hz: 60 dpi: 142 
  size: 344x194mm (13.5x7.6") diag: 395mm (15.5") 
  OpenGL: renderer: GeForce GTX 1650/PCIe/SSE2 v: 4.6.0 NVIDIA 455.28 
  direct render: Yes 
  Device-1: AMD Raven/Raven2/FireFlight/Renoir Audio Processor 
  vendor: Acer Incorporated ALI driver: N/A 
  alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus ID: 05:00.5 
  chip ID: 1022:15e2 
  Device-2: AMD Family 17h HD Audio vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel bus ID: 05:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.9.1-1-MANJARO 
  Device-1: Realtek vendor: Acer Incorporated ALI driver: r8169 v: kernel 
  port: 2000 bus ID: 03:00.0 chip ID: 10ec:2600 
  IF: enp3s0 state: down mac: <filter> 
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: 2000 
  bus ID: 04:00.0 chip ID: 8086:2723 
  IF: wlp4s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Local Storage: total: 238.47 GiB used: 41.29 GiB (17.3%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 vendor: SK Hynix model: HFM256GDJTNI-82A0A 
  size: 238.47 GiB block size: physical: 512 B logical: 512 B 
  speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 11000C00 scheme: GPT 
  Message: No Optical or Floppy data was found. 
  Message: No RAID data was found. 
  ID-1: / raw size: 134.87 GiB size: 131.76 GiB (97.69%) 
  used: 41.26 GiB (31.3%) fs: ext4 block size: 4096 B dev: /dev/nvme0n1p5 
  label: N/A uuid: 80750ec8-f3b2-4e51-a921-83158f1c5165 
  ID-2: /boot/efi raw size: 100.0 MiB size: 96.0 MiB (96.00%) 
  used: 31.7 MiB (33.1%) fs: vfat block size: 512 B dev: /dev/nvme0n1p2 
  label: N/A uuid: 98DC-DD65 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 7.63 GiB used: 0 KiB (0.0%) 
  priority: -2 dev: /dev/nvme0n1p6 label: N/A 
  uuid: be6a964a-6b3c-48e9-8dff-4875c272f719 
  ID-1: /dev/nvme0n1p1 size: 499.0 MiB fs: ntfs label: Recovery 
  uuid: C6C4DC58C4DC4BF5 
  ID-2: /dev/nvme0n1p3 size: 16.0 MiB fs: N/A label: N/A uuid: N/A 
  ID-3: /dev/nvme0n1p4 size: 95.37 GiB fs: ntfs label: N/A 
  uuid: 5E9629C396299C91 
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Device-1: 1-4:2 info: Intel AX200 Bluetooth type: Bluetooth driver: btusb 
  interfaces: 2 rev: 2.0 speed: 12 Mb/s chip ID: 8087:0029 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 
  Hub: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Device-1: 3-1:2 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID 
  driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s 
  chip ID: 046d:c52b 
  Device-2: 3-3:3 info: Chicony HD User Facing type: Video driver: uvcvideo 
  interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 04f2:b64f serial: <filter> 
  Hub: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 
  System Temperatures: cpu: 58.2 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  GPU: device: nvidia screen: :0.0 temp: 53 C device: amdgpu temp: 49 C 
  Processes: 348 Uptime: 10h 26m Init: systemd v: 246 Compilers: gcc: 10.2.0 
  clang: 10.0.1 Packages: pacman: 1261 lib: 339 flatpak: 0 
  Shell: Bash (sudo) v: 5.0.18 running in: gnome-terminal inxi: 3.1.05
1 Like

Yeah I’m going to try a different DE and might try starting from scratch. I think I need to get rid of Cinnamon, which might be the damn problem in the first place… I went back to the configuration someone posted awhile ago for someone with similar hardware. You were right, though… this internal display is AMD only… I was re-reading before I saw your response, but it’s possible the DE is the problem, and it seems to point to it. I could be wrong but we’ll find out. And yes I have learned enough about mhwd lol.

Thank you for your help though. You’ve been fabulous and I will be updating you on my little start from scratch journey :face_with_raised_eyebrow: lol. Alright… I’ll let you know when I’m able to do so… gonna back some stuff up. At least the rest of it works… it could be worse…

1 Like

29 days between your first post and this one. I must’ve missed it scrolling through the history…



Yeah, it made no difference one way or the other… usually plenty of ram, there are crashes here and there that are inevitable:

I’ll try… GNOME3 or MATE for my next shot. and if PRIME doesn’t work, I’ll go to KDE. There are solutions for this stuff, it seems, with KDE. But I do have a question, @Fabby or @pobrn – a quick question… Does Manjaro handle more than one DWM very well? I know it works in Ubuntu but can be a bit dangerous and lead to dependency hell. Thoughts on this? I’m… moderately “experienced” but nowhere near the knowledge that you both have.

  1. Separate users for separate DEs
  2. Start by doing this:
1 Like

Difficulty is about 1 of 5 for me so I guess I’m not too bad at this :stuck_out_tongue: I’m sure you’ll be the judge of this at a later date, lol.

I’m glad I looked it up and then asked the questions about installing, for instance–I decided not install GNOME or MATE because of the version of this ISO–it came equipped via lightdm because of cinnamon, right? I’m worried about the dependencies since Cinnamon = GNOME fork, so something could probably overlap in the dependencies, I would think… That brings me to a question I have. Maybe I’m just over-analyzing this, but why did I have to create a different user for the separate DE I installed?

Why can’t I use my normal username, in theory? Is this new user a precaution or is it a 100% requirement? If so, I just want to know why, really. It was the very first thing I did. :stuck_out_tongue:

In the mean time this discussion has been dragging along for way too long and differs substantially from your original question, so please do me a favour and:

  • click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
    so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.
  • Open a new topic on this… (We don’t charge more if you open more topics, you know…) :wink:

It’s been dragging along with no actual solution… Would it be okay if I left this open for a little longer while I open another topic about installing multiple Desktop Environments? Eventually I’ll mark it as solved but until then, I’d like to keep this thread alive a little bit longer.

Because you keep asking other questions that side-track people.

I was on “Normal” in this topic already, but anything left open for a week or longer is bad as people lose track, so now I’ve muted this topic and you will not be able to contact me any more from this point forward inside this topic although I still will be able to see any other questions you ask on the site.



  • This is a friendly forum geared towards problems and solutions, not towards discussion
  • If you open another discussion thread instead of a Problem-Solution thread in the future, you will be muted as a user in my personal settings so I’ll never see any of you future questions again.
  • Not everyone here warns you that they will mute you, they’ll just do it.
  • After enough users mute you, none of your questions will receive any attention any more…