Fn-Keys, Light on key pressed and laptop lid closed


I just installed Manjaro on my thinkpad E14 Gen 2, tried it with KDE and XFCE both works fine, only one issue I got. The FN-Keys are not working and the caps lock key also does not show the light when it was pressed. Laptop lid on close does also not work.

After the first time I suspend my laptop and I log in again everything works fine.
FN-Keys, the light on keyboard and lid on close.

I am currently using Kernel 5.9. On other Kernels I got the same issue, I didn’t tested if it works after suspend but it was not working out of the box.

As mentioned here: Linux: Fn-keys not working - Thinkpad E14 AMD Gen 2-English Community

It is necessary to use the UEFI and “Optimize BIOS settings for other OS”. No Dualboot with windows, but a clean full install of linux.

Actually it is problem with UEFI and the E Series seems not to be supported. Maybe it is worth a check if this post says the truth:

Could you check if you use an uefi?


and GPT and no windows?

sudo parted -l

On fedora there seems not to be a problem about this.

efibootmgr gives me an output, currently I am dualbooting Manjaro and Ubuntu but the problem also occured after a fresh and only Manjaro install.

sudo parted -l says its gpt and no information about windows. (not dual booting if it was that what you meant)

I will try to install later Fedora and Arch.

Fedora got the same issue, a suspend is needed to use all the functions.

1 Like

It is mentioned that you have to install everything in UEFI and then change to BIOS legacy mode. Since i don’t use it, i have no idea now :man_shrugging:

Thats only possible through the UEFI itself right? If so then it won’t be possible since only UEFI is supported…

Is there a possibility to suspend after boot and coming back from suspend again?

sleep 20 && systemctl suspend

Should do the trick. To run it at login i would put it to the autostart programs. Sleep means it will wait 20 seconds before running. But resume works only manually i think.

1 Like

Hi neulowin,
i have the same problem with my E15. There seems to be some problem with the BIOS in the E-Series Thinkpads, which causes this issue.
With some help from this Forum I added:

@reboot root rtcwake -m mem -s 2

to my Cronjobs. This adds about 5 seconds to Startup, with the Laptop Suspending and waking up after 2 seconds, but afterwards the Fn-Keys and Lid work.

1 Like

Thanks works now fine! :smiley:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.