Firefox stops having texts somehow

After recent update, stopped having text in bookmark tab and in active tabs, what should I do?

Hi @fuzz, and welcome!

I don’t really know what you mean by Tabs, but I suspect you mean the menus, and mine is perfectly fine, as you can see below:

Since everything is fine on my end, I’ll advise you to clear the Firefox cache:

Although I don’t know if this’ll work. If it fails, I suspect a theme problem, since it’s not a Manjaro or Firefox problem. So try a different theme.

Can you help me navigate, I see nothing, which button from top it is?

Press the left Alt button to have it appear temporarily.

Else right-click next to an open tab and select Menu Bar, to have it visible permanently:

Do you have any errors when launching FF from terminal? Have you tried with a fresh profile and no extensions loaded at start? or, back up profile, just in case and about:support “Refresh Firefox” ?

Even there, I see no text.

Then try as @jrichard326 suggested, or try another theme.

Or if you want to go nuclear, remove the ~/.mozilla folder and try again:

mv ~/.mozillla ~/.mozilla.backup

Note: this will remove all bookmarks, saved password and customizations, so use with care.

Did you reboot after the update?

1 Like

I’ve rebooted,

I’ve even tried to reinstall firefox, it still looks bad.

No text is rendered everywhere from menu to bookmarks.

Have you tried removing the ~/.mozilla direectory?

mv ~/.mozilla ~/.mozila.backup


If I could just provide screenshot, it would be a lot better.


Please tell us what you have tried so far. Why ask for advice and not try the solutions that were proposed? Removing and reinstalling FF is a Windows type fix and very rarely will work under Linux. Removing the program will not work as your configuration(profile) which , most likely, is corrupt will remain.

It could also be an issue with userChrome.css if you have done any modifications there.

I have run into this although it was a great while back. I understand that this is a FF problem only?

Run Bleachbit, check all the boxes in the FF menu and be sure VACUUM is checked. (Reboot your system after).
If that alone didn’t work also do a “Deep Scan” and again reboot your system after. This should do it.

NOTE: If you are also using Firejail and used the firecfg command undo it ( firecfg --clean ).

Let us know how this worked out for you.

Suddenly works after another system update…