Firefox-kde-opensuse title bar buttons

Hi!
I recently started to use KDE Plasma with the “Global Menu” widget. Since Firefox is not compatible with said widget, I installed “firefox-kde-opensuse” from AUR. It is great - “Global Menu” is working fine, but there is one flaw. I have no title bar buttons to close/minimize/maximize the window.

Unfortunately, I cannot add a link or a picture to this post to show you how this looks like, but I hope you know what I’m talking about.

Console after app start-up:

firefox-kde-opensuse:7627): Gtk-WARNING **: 16:20:17.052: Locale not supported by C library.
        Using the fallback 'C' locale.

(/usr/lib/firefox/firefox:7693): Gtk-WARNING **: 16:20:17.490: Locale not supported by C library.
        Using the fallback 'C' locale.

(firefox-kde-opensuse:7627): GLib-GIO-WARNING **: 16:20:18.273: /etc/xdg/kde-mimeapps.list contains a [Added Associations] group, but it is not permitted here.  Only the non-desktop-specific mimeapps.list file may add or remove associations.

(/usr/lib/firefox/firefox:7757): Gtk-WARNING **: 16:20:18.436: Locale not supported by C library.
        Using the fallback 'C' locale.

(/usr/lib/firefox/firefox:7835): Gtk-WARNING **: 16:20:20.115: Locale not supported by C library.
        Using the fallback 'C' locale.

(firefox-kde-opensuse:7627): LIBDBUSMENU-GTK-CRITICAL **: 16:20:22.523: dbusmenu_menuitem_property_set_shortcut: assertion 'gtk_accelerator_valid(key, modifier)' failed

(/usr/lib/firefox/firefox:7873): Gtk-WARNING **: 16:20:28.705: Locale not supported by C library.
        Using the fallback 'C' locale.

(/usr/lib/firefox/firefox:8027): Gtk-WARNING **: 16:20:58.613: Locale not supported by C library.
        Using the fallback 'C' locale.

Is there any cure for this problem?

Welcome to the forum! :slight_smile:

Right-click on the toolbar and choose “Customize” from the popup menu. In the screen you’ll get next, look at the bottom left. There is a checkbox,labeled “Title Bar”. Make sure that it’s ticked.

You may have to restart Firefox for the changes to take effect. :wink:


P.S.: You may also want to check out Plasmafox, which was specifically developed for Manjaro. More details in the quoted post below. :slight_smile:

:arrow_down:

Thanks for your reply. I know I can enable the system title bar, but the browser looks outdated then. With normal Firefox, there wasn’t any problem with the “title bar” option not checked.

I haven’t heard of Plasmafox, I’ll check that!

1 Like

Do you think so? :thinking:

I think it depends on what window decoration you choose. :man_shrugging:

Everyone has an aesthetic. I do not like it when my browser has a system title bar.

I’ve tried Plasmafox, but it is not working

/usr/lib/libc.so.6: version `GLIBC_2.32' not found (required by /usr/lib/plasmafox/libxul.so)

Couldn't load XPCOM.

Manjaro Stable has 2.31-5 version of glibc

Ah, I see ─ he uploaded the new version two days ago, and he has compiled it against glibc 2.32. That’ll be remedied in a short while, because that will be in the Testing branch by now, and it’ll percolate into Stable pretty soon.

Well, it doesn’t hurt to leave Plasmafox installed for now, even though it doesn’t work at the moment. It won’t be long anymore before we’re getting another big Stable update ─ maybe a week, maybe slightly longer. :wink:

Summarizing Plasamfox’s issue - it seems like not a good idea to use it daily since it can break during an upgrade.

Maybe there is some way to fix “firefox-kde-opensuse”? That LIBDBUSMENU-GTK-CRITICAL error sounds like a big deal. Maybe I can fix it somehow? I’ve installed libdbusmenu-glib, ibdbusmenu-gtk3 and libdbusmenu-gtk2 but it didn’t help.

No, it was Plasmafox itself that was upgraded before the rest of Manjaro. Normally it shouldn’t be like that.

I’m not sure, but for a while, I had a problem with appmenu-gtk-module. It was absolutely unusable for me, both in Manjaro and in PCLinuxOS. So I replaced that with appmenu-gtk-module-git from the AUR, and it has been working perfectly since.

Also, did you install firefox-kde-opensuse or firefox-kde-opensuse-bin?

It shouldn’t be like that, but it is like that. The author himself said in README I have switched from Manjaro to EndeavourOS. (...) Therefore I cannot guarantee that the provided binaries work correctly on Manjaro. Your best bet is the 'unstable' branch. I would rather use vanilla Arch than unstable branch (coz what’s the point?).

It didn’t help in my case :confused:

firefox-kde-opensuse

1 Like

Well, the thing with packages from the AUR is that there’s never a guarantee that it’ll work. They are after all contributions from (trusted) Arch community members, but they are designed to work in Arch. And the Arch developers themselves ─ and much of the Arch community ─ look down on Manjaro. :man_shrugging:

Yea, it is funny how cocky Arch users sometimes are (I was one of them for some time, I have to admit xD).

Thanks for your help, I still hope there is some way to repair that issue.

1 Like

Hello,

I’m the author/maintainer of Plasmafox.

Manjaro stable branch is NOT supported! (EDIT: binaries, that is. You’re free to build your own, or drop system libs by commenting out the relevant lines in mozconfig)
It hasn’t been for several months, if not a year.
Use testing, or better yet, unstable.

Also, please read the README.

Greetings,
torvic9

1 Like

Yea, I know. I said that it is not working and I quoted README.