Firefox doesn't allow to copy from right click menu randomly

As the title says, Firefox randomly doesn’t allow the option to copy from its right click menu after selecting some part of the page, some text, it is greyed out. This is really strange, because you come back on the same page later (like you open another website in the tab, then click Back button), the option is available. Am I the only one noticing this behavior? I tried to search for this issue and can’t find any relevant post anywhere.

Most of the time it works, but it is still often enough to bother me. CTRL-C works to manually copy when it does that, but it is still annoying to have to do that.

Some websites use scripts to prevent you from copy.

This is obviously not that as I explained. You come back on the same page the option is not greyed out.

Would Stack Overflow, or other code oriented website use such scripts? I don’t think so.


No this is really random, on any website.

//EDIT: for the sake of it, I opened Stack Overflow after writing that for tests, from a Google search, went to main page, Copy was unavailable, I closed a random opened Youtube tab, option is now available so I don’t even have to leave and reload the page for the option to become available.

I noticed that too on a Windows computer on a completely unrelated a fairly new Profile, only common denominator was uBlock Origin extension but I doubt it would mess with Firefox internal menus.

//EDIT2: To be fair, in Firefox troubleshooting mode I can not reproduce the issue. Will try to refresh my profile to see if that helps (really annoying as I have modifications in Firefox, extensions and their configuration, and so on…)

//EDIT3: I refreshed my profile to see if that helps (what a choir to reinstall and reconfigure everything…). Will update if I encounter the issue again.

I can not reproduce the issue on Firefox with the same Add-ons as yours.
The activated Copy is always clickable in the right-click menu on the website Stack Overflow. :man_shrugging:

PS: I am using Firefox with Wayland mode: MOZ_ENABLE_WAYLAND=1

Stack Overflow was just an example, it could happen on any website.

I was “lucky” when I tried to reproduce the issue on video, it bug twice in a row, first try :sweat_smile:

If a new Firefox profile and cleaning Firefox-cache do not help, try creating a new KDE user and checking Firefox in that user to see if the issue is reproducible.

I never experienced this bug Linux (kde) with firefox, i also use ublock origins + other extensions.

I also just try’d to reproduce it and it always works for me.

How long do you experience this problem?

Are you talking about the Firefox Profile or the Manjaro User Profile?

So far I did not encounter the issue again (but to be fair, I did not try to copy many things since then). What is weird is that I also had the issue on a fresh Windows profile from July (work computer with only Ublock installed, and no modification to internal Firefox settings), so this is probably not tied to my profile modifications, and I doubt uBlock could change Firefox internal menus behavior… Weird issue…

What you observe possibly depends on what is actually selected.

The action should normally copy test as expected, but sometimes, more than just the text (graphics, script outputs, form controls) may be selected, without it being obvious.

In such cases, Firefox can fail to copy the intended text, resulting in pasting only whatever was previously in the buffer.

This can happen on all platforms.

No, you can see in my test video I only select text.

I have seen it before, at different times, but right now it seems fine on Chrome, Edge, Vivaldi (basically, all Chromium-based), and Firefox (stable).

Sometimes there is some latency, though, between the first selection, right-click, and modal context; and it seems slow to propogate, the first time its used. This could be what’s happening.

This is nothing new, I think. :wink:

When that was happening you could right click ten times in a row it was always disabled, didn’t seem to be a timing issue.

Well, no, because it might only happen the first time it is used (as already stated); after that, it would work as expected. This is much as you described.

If it happened ten times in a row, or every time, that would different; that might suggest no propogation at all. In that case, it might genuinely be a bug.

In any case, I can’t reproduce it in any browser, unless conditions are similar to what I described in my first post; and even then, it’s sporadic. :person_shrugging: