Firefox 104 - testing update issue

Firefox 104 is not working. I had to put the official package (tar.gz from firefox website) directly in the /usr/lib/firefox directory :frowning:

Please provide the exact issue you had because your “fix” makes absolutely no sense. No offense please!

Mozilla provides firefox-104.0.tar.bz2 file for Linux when it detects that OS, and that file does absolutely nothing when placed in /usr/lib/firefox directory (or you mean you unpacked it there?); while our repositories provide the firefox-104.0-1-x86_64.pkg.tar.zst that will be installed via pamac or pacman …

I just updated stable Xfce in a VM
and got firefox-103.0.2-1
not 104

See here: Packages | manjaro

1 Like

FF 104 Is not yet in stable tho Packages | manjaro


… I know - so OP must be on testing or unstable

Indeed, is where the OP left the comment, so i thought better split the topic so we can have a closer look at the “issue” at hand. :smiley:

ah - I didn’t catch that

1 Like

Exactly what I have done: I unpacked the files contained in firefox-104.0.tar.bz2 in the directory /usr/lib/firefox to replaced all the files of the directory by the ones provided by Mozilla. This way I can use Firefox.
The package proposed by official repositery does not work.
And it works as well for thunderbird (/usr/lib/thunderbird). This way I allready use thunderbird 102.2

I have just updated Manjaro Xfce on testing branch including Firefox v104.0-1
and Firefox is working with no problems

Firefox package is imported direct from Arch
Arch PKGBUILD shows the source files are downloaded from



Is that a practice you do often? Then you know that during the update you will get “Exists in filesystem” error; is that what happened?

The updated of firefox didn’t work, or after the update Firefox did not start?

I already tested the updates on 3 installs with no issue neither during the update, nor after the update and reboot. Firefox 104 works fine.

Using binaries from Mozilla is not always good. Sure if the package provided by the distro has issues we can talk about it. But if you install 3rd-party software you’re on your own @olivier512. In regard of thunderbird: not every version is working with regular updates. Mozilla still needs time to make sure if you upgrade from older installs of thunderbird it won’t break your data.

So I recommend to use flatpak or snaps if you want to have the latest and greatest without breaking your distribution installation.

1 Like

I often do that whith no issue (this is the second time for firefox) and I never had issue when I uodate in the normal way with a new version. The files are simply replaced by pamac.
In this case, Firefox start normally but it doesn’t open any website. The main window stays empty.

I just tried to re-install with pamac and now it works with official package.
I had the same issue on my both laptop

Great. Just don’t bother posting when you have one, because I’m gonna have a field day. :smiley:

Sure. Until some new file is added.


That is normal in Linux, if it doesn’t work, do it again…

However, in psychology teachers tell you:
if someone does the same thing over and over again and expects a different result,
– then it’s called madness. Be careful.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.