Failure to add 'Fedora Linux 37 (Workstation Edition)' to boot menu entry

I recently installed Fedora Linux on my PC. The bootloader provided by Fedora’s got the entries for all the OS’s that I’ve got installed on my PC: Linux Mint, Manjaro Linux, and Fedora itself, of course. But I wanted to use Manjaro’s bootloader instead of Fedora’s.

When I ran sudo update-grub on the Terminal on Manjaro, I got the following output:

[sudo] password for arch: 
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-6.1-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-6.1-x86_64.img
Found initrd fallback image: /boot/initramfs-6.1-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found Linux Mint 21.1 Vera (21.1) on /dev/nvme0n1p2
Found Fedora Linux 37 (Workstation Edition) on /dev/nvme0n1p5
Adding boot menu entry for UEFI Firmware Settings ...
Root filesystem isn't btrfs
If you think an error has occurred, please file a bug report at ""
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.
Found memtest86+ EFI image: /boot/memtest86+/memtest.efi
/usr/bin/grub-probe: warning: unknown device type nvme0n1.

I see that it recognizes I’ve installed Fedora, but it doesn’t add the boot menu entry for the operating system. I don’t understand the reason. Is it because Fedora’s filesystem is btrfs or is there any other reason? How do I fix this?

Thank you in advance.

This is a issue with Fedora and at least openSUSE Tumbleweed. I decided to revisit both this weekend. First I checked out OSE and os-prober for my Arch based disros will see it but not actually add it to the boot menu. os-prober in OSE’s will see the other OS’s and add them to it’s boot menu, but when you attempt to boot one of them from it it fails. Fedora the exact same.