Failed to start load kernel modules - systemd


I just applied an update to my system. I was on 5.14.18-1 and ran pacman -Syu. I rebooted the system but I am not able to get to my login screen. The main error I get is “failed to start load kernel modules. See systemctl status systemd-modules-load.service”

I am unable to get to a shell using CTL-ALT-F2. I just get a blank screen. I try to run the systemctl status command from a chroot session but I get a message saying I can’t do that from chroot.

I only have 1 other kernel installed 5.10 ut I get the same error when I try that.

Any help or suggestions would be much appreciated.


5.14 is eol switch to 5.10 lts as you have that already installed. chroot through a live usb and update the kernel modules:

sudo manjaro-chroot -a
pacman -Syyu
pacman -S linux510 linux510-headers linux510-extramodules
exit #end-chroot

Thanks for the quick response. I can’t run pacman - it seems I don’t have network connectivity. Is there anything I need to do to enable from chroot?

the live iso should be able to support both wifi and ethernet :thinking:

I’m using Manjaro architect as my live iso

Best to use a normal ISO as live-manjaro (not architect )

Boot from USB:

architect is currently unmaintained!

That worked perfectly once I switched to use the manjaro live ISO. Thanks! I’m curious though as to what caused the errors? Was it simply because the kernel I was using was EOL or was it due to a partial update?

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.