Failed to start lightdm on boot - can't log in to system!

Installed Manjaro Cinammon yesterday evening. In general I’m reasonably familiar with Linux but this is my first time with Manjaro.

I really like it apart from a couple of issues I’m having. The main one of these is that every time I boot I get this:

[FAILED] Failed to start: Light Display Manager

and then, predictably, the lightdm login screen doesn’t appear.

Apparently according to some other posts a fix is to do this:

sudo chown root:lightdm /var/lib/lightdm-data
sudo systemctl restart lightdm

That worked for me to get into the system once. But on the next boot I see the same thing again. The same thing fixes it.

I don’t really want to have to do this fix (and from what I understand it’s a pretty bodgey fix anyway) every single time I boot the system - can anyone possibly shed any light on what’s going on here and how I can fix the issue?

EDIT: The only significant thing I have done to the system since installation is upgraded the kernel from a 5.9-series one to a 5.12-series one because 5.12 adds kernel support for my wireless network card. I can downgrade the kernel if I have to, but I’d rather not as to do so would obviously render the aforementioned network card useless again!

Hi there,
I had a similar problem with LightDM, which was also kernel-related.
For me sudo mkinitcpio -P and sudo update-grub did the trick.

Check the troubleshooting section of the Arch Wiki.
Check the status of lightdm.service: systemctl status lightdm.service
Check the following links, they may be of some help:

Thanks very much for those links, that was very helpful.
Ultimately I believe the problem was that lightdm was attempting to start before the graphics drivers were loaded properly.

For anyone reading this thread later, the way to fix this is to insert the line


to the [LightDM] section of the file /etc/lightdm/lightdm.conf and reboot. This forces the lightdm service to wait for graphics devices be ready before attempting to launch the greeter, which solved the issue for me.

Hopefully this will help anyone else who has this problem in the future. Thanks everyone for your assistance.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.